Ergebnis 1 bis 10 von 10

Thema: Mit FRITZ!OS: 06.00 kein OpenVPN mehr möglich.

  1. #1
    IPPF-Einsteiger
    Registriert seit
    31.10.2011
    Beiträge
    7

    Frage Mit FRITZ!OS: 06.00 kein OpenVPN mehr möglich.

    Hey Leute,

    ich habe eine FritzBox! 7390 und habe darauf einen OpenVPN client installiert. Alles lief wunderbar, bis ich gestern die Firmware OS 06.00 installiert habe. Seit dem kommt immer wenn ich den openvpn starten will
    Code:
    : can't handle reloc type 0x2f
    Weiß irgendwer was ich jetzt tun kann um OpenVPN auf der aktuellen Version zum laufen zu bringen?

  2. #2
    IPPF-Urgestein
    Registriert seit
    22.04.2007
    Beiträge
    12.343
    Und das hat mit der vorherigen AVM Firmware funktioniert?

  3. #3
    IPPF-Einsteiger
    Registriert seit
    31.10.2011
    Beiträge
    7
    Einwandfrei. Keine Probleme war die vorherige OS 05.xx.

  4. #4
    IPPF-Fan
    Registriert seit
    11.06.2007
    Beiträge
    203
    Etwas mehr Infos bzgl. OpenVPN wären interessant:
    - welche Version
    - statisch oder dynamisch gelinkt
    .....
    FBF 7360 an 1&1 Regio ADSL-6000 (früher 7170)

  5. #5
    IPPF-Einsteiger
    Registriert seit
    31.10.2011
    Beiträge
    7
    Also der OpenVPN-Server ist Version 2.3. Die genaue Version vom Client kenne ich leider nicht. Das TAP Interface wird mit folgendem Befehl erstellt:

    Code:
    mknod /var/tmp/VPN/tun c 10 200
    Und die VPN config sieht folgendermaßen aus:
    Code:
    client
    daemon
    dev tun
    dev-node /var/tmp/VPN/tun
    proto tcp
    remote #######
    resolv-retry infinite
    nobind
    persist-key
    persist-tun
    ca /var/tmp/VPN/ca.crt
    cert /var/tmp/VPN/client.crt
    key /var/tmp/VPN/client.key
    tls-auth /var/tmp/VPN/ta.key
    cipher AES-256-CBC
    comp-lzo
    verb 3
    log /var/tmp/VPN/openvpn.log
    Eigentlich sollte es auch nicht an der Konfiguartionsdatei liegen. Egal mit welchen Parametern ich versuche den openvpn zu starten es kommt immer der oben genannte Fehler.

  6. #6
    IPPF-Urgestein
    Registriert seit
    22.04.2007
    Beiträge
    12.343
    Es ist dynamisch gelinkt und verwendet dafür Einträge, die normalerweise von der AVM Firmware nicht unterstützt werden.
    Wenn es mit der vorherigen Version funktioniert hat, müsste man von dieser den dynamischen Linker verwenden.

  7. #7
    IPPF-Einsteiger
    Registriert seit
    31.10.2011
    Beiträge
    7
    Okay das klingt nach einem brauchbaren Ansatz. Aber so tief bin ich nie in die Materie eingestiegen. Kann man denn irgendwie herausfinden welche Links von der openvpn Binary verwendet werden und die dann nachinstallieren?

  8. #8
    IPPF-Urgestein
    Registriert seit
    22.04.2007
    Beiträge
    12.343
    Ich habe nichts geschrieben von Links, die verwendet werden und nachinstalliert werden könnten, sondern dass man den dynamischen Linker aus der Vorgänger-Version verwenden könnte.
    Es wundert mich aber trotzdem, dass AVM in der altern Version einen Linker gehabt haben soll, der das konnte, und in der neuen einen, der es nicht kann.

  9. #9
    IPPF Sechstausend-VIP
    Registriert seit
    01.02.2005
    Beiträge
    6.907
    Die Binaries aus diesem Thread funktionieren bei mir auf einer 7390 mit Fritz!OS 6.00

    Code:
    root@fritz:/var/tmp# echo "$CONFIG_VERSION"
    06.00
    root@fritz:/var/tmp# ./openvpn_2.3.2-mips-openssl-static  --genkey --secret my.key
    root@fritz:/var/tmp# ./openvpn_2.3.2-mips-openssl-static  --dev tun --ifconfig 10.8.0.1 10.8.0.2 --secret ./my.key  
    Wed Oct 30 19:33:56 2013 OpenVPN 2.3.2 mips-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [IPv6] built on Jul 13 2013
    Wed Oct 30 19:33:56 2013 TUN/TAP device tun0 opened
    Wed Oct 30 19:33:56 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Wed Oct 30 19:33:56 2013 /sbin/ifconfig tun0 10.8.0.1 pointopoint 10.8.0.2 mtu 1500
    Wed Oct 30 19:33:56 2013 UDPv4 link local (bound): [undef]
    Wed Oct 30 19:33:56 2013 UDPv4 link remote: [undef]
    ^CWed Oct 30 19:34:02 2013 event_wait : Interrupted system call (code=4)
    Wed Oct 30 19:34:02 2013 /sbin/ifconfig tun0 0.0.0.0
    Wed Oct 30 19:34:02 2013 SIGINT[hard,] received, process exiting
    root@fritz:/var/tmp#
    (FR) Eumex 300IP FW 06.04.49 (englisch) und "relativ aktuellem" freetz-devel mit openvpn und dropbear hinter AGFEO TK-HomeServer

  10. #10
    IPPF Fünfhunderter
    Registriert seit
    20.12.2005
    Beiträge
    882
    Ursache - AVM ist auf NTPL-based threading support umgestiegen. Damit sind die meisten dynamisch gelinkten Binaries inkompatibel zu 06.00

Ähnliche Themen

  1. [Problem] über Fritz!Box 7390 kein analog Telekom-Anschluss mehr möglich!?!
    Von caCaRoTt im Forum FRITZ!Box Fon: Telefonie
    Antworten: 57
    Letzter Beitrag: 15.11.2012, 12:03
  2. Fritz!Box 7170 kein Zugriff per LAN mehr möglich (Festnetz LED leuchtet)
    Von St0ny4Dreamer im Forum FRITZ!Box tot? Recover, Firmware Up-/ Downgrade
    Antworten: 7
    Letzter Beitrag: 05.02.2010, 20:24
  3. Antworten: 10
    Letzter Beitrag: 14.02.2009, 17:52
  4. Fritz Homeserver 7240, kein Telekomanschluß mehr Möglich?
    Von Keen im Forum FRITZ!Box Fon: Telefonie
    Antworten: 8
    Letzter Beitrag: 26.12.2008, 15:40
  5. Fritz!Box Fon im Ebay ersteigert kein Internet mehr möglich
    Von Sportie im Forum FRITZ!Box tot? Recover, Firmware Up-/ Downgrade
    Antworten: 12
    Letzter Beitrag: 24.04.2005, 09:30

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •