Ergebnis 1 bis 2 von 2

Thema: Compile (most) prerequisites for building freetz on unsupported distros

  1. #1
    IPPF-Fortgeschrittener
    Registriert seit
    29.07.2009
    Ort
    Frankfurt
    Beiträge
    70

    Compile (most) prerequisites for building freetz on unsupported distros

    Hi guys,

    I just installed a bleeding edge distro (Kali 2.0) that lacked a lot of the prerequisites but I still wanted to build freetz so I got started building a lot of the required packages myself.

    Installed were gcc (4.9.2-2), g++ (4.9.2-10), make-guile (4.0-8.1).

    Here is the rest that I needed to prepare to "make menuconfig":
    Code:
    wget http://ftp.gnu.org/gnu/autoconf/autoconf-latest.tar.xz && tar xfJ autoconf-latest.tar.xz && cd autoconf-latest && ./configure && make && make install && cd .. && rm -rf autoconf-*
    wget http://ftp.gnu.org/gnu/automake/automake-1.15.tar.xz && tar xfJ automake-1.15.tar.xz && cd automake-1.15 && ./configure && make && make install && cd .. && rm -rf automake-1.15*
    wget http://ftp.gnu.org/gnu/gawk/gawk-4.1.3.tar.xz && tar xfJ gawk-4.1.3.tar.xz && cd gawk-4.1.3 && ./configure && make && make install && cd .. && rm -rf gawk-4.1.3*
    wget http://ftp.gnu.org/gnu/bison/bison-3.0.4.tar.xz && tar xfJ bison-3.0.4.tar.xz && cd bison-3.0.4 && ./configure && make && make install && cd .. && rm -rf bison-3*
    wget http://ftp.halifax.rwth-aachen.de/gnu/libtool/libtool-2.4.6.tar.xz && tar xfJ libtool-2.4.6.tar.xz && cd libtool-2.4.6 && ./configure && make && make install && cd .. && rm -rf libtool-2.4.6*
    wget ftp://ftp.gnu.org/gnu/ncurses/ncurses-6.0.tar.gz && tar xfz ncurses-6.0.tar.gz && cd ncurses-6.0/ && ./configure --enable-ext-colors && make && make install && cd .. && rm -rf ncurses-6.0*
    wget http://http.debian.net/debian/pool/main/a/attr/attr_2.4.47.orig.tar.bz2 && tar xfj attr_2.4.47.orig.tar.bz2 && cd attr-2.4.47/ && ./configure && make && make install install-dev install-lib && cd .. && rm -rf attr*
    wget http://http.debian.net/debian/pool/main/a/acl/acl_2.2.49-4.debian.tar.bz2 && tar xfj acl_2.2.52.orig.tar.bz2 && ./configure &&  make && make install install-dev install-lib && cd .. && rm -rf acl*
    wget http://http.debian.net/debian/pool/main/libc/libcap2/libcap2_2.24.orig.tar.xz && tar xfJ libcap2_2.24.orig.tar.xz && cd libcap2-2.24/ && make && make install && cd .. && rm -rf libcap*
    wget ftp://ftp.cwru.edu/pub/bash/readline-6.3.tar.gz && tar xfz readline-6.3.tar.gz && cd readline-6.3 && ./configure && make && make install && cd .. && rm -rf readline-6.3*
    "make menuconfig" works and I've just compiled an image. I wasn't able to do it with the precompiled toolchain, however building the toolchain myself the image creation went perfectly.

    Happy building!
    Geändert von zyrill (13.08.2015 um 11:11 Uhr)
    FRITZ!Box 7490
    immer auf einem der letzten freetz-trunks

  2. #2
    IPPF-Fortgeschrittener
    Registriert seit
    29.07.2009
    Ort
    Frankfurt
    Beiträge
    70
    For future reference, modern versions (kali-rolling) of Kali have all required packages:

    apt-get install automake autoconf bison libacl1-dev g++-multilib libncurses5-dev libtool pkgconf zlib1g-dev

    ln -s /usr/bin/libtoolize /usr/bin/libtool
    Geändert von zyrill (18.05.2017 um 10:12 Uhr)
    FRITZ!Box 7490
    immer auf einem der letzten freetz-trunks

Ähnliche Themen

  1. Error: can't compile freetype (freetz-2.0)
    Von nnppss im Forum Freetz
    Antworten: 2
    Letzter Beitrag: 20.07.2013, 12:43
  2. Antworten: 14
    Letzter Beitrag: 21.02.2011, 18:12
  3. Antworten: 0
    Letzter Beitrag: 10.08.2010, 12:48
  4. freetz compile probleme
    Von klawd im Forum Freetz
    Antworten: 8
    Letzter Beitrag: 02.03.2010, 09:57
  5. freetz-trunk compile Probleme
    Von _kb im Forum Freetz
    Antworten: 1
    Letzter Beitrag: 22.02.2010, 00:24

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •