Guten Tag, ich habe hier eine Fritzbox 7270v3 an der ich die Analogen Telefonschlüsse als Schaltkontakte verwende, das klappt soweit. Bisher läuft das Ganze unabhängig von meinem Netzwerk, soll aber möglichst drahtlos darin eingebunden werden weil das Ganze sonst in einer Orgie mit dem Bohrhammer endet was ich gerne vermeiden würde. Ich kenne mich nicht wahnsinnig gut mit Linux aus, daher scheitert es gerade daran die Box mit dem vorhandenen Wlan zu verbinden (ich hoffe zumindestens dass das möglcih ist) Ich habe also Freetz aus dem Trunk (124547) kompilliert, geflasht und läuft, habe den Telnet-Zugang aktiviert und mittels folgendem Befehl theoretisch ein neues Interface im Clientmodus erstellt:

Code:
wlanconfig ath create wlandev wifi0 wlanmode sta nosbeacon
Nun scheitert es bei mir daran dass ich versucht habe die Box mittels wpa_supplicant Befehl mit dem vorhandenen WLAN zu verbinden. Die Vorgehensweise welche ich ergooglen konnte beinhaltete es unter anderem mittels Parameter -i das Interface ath0 anzugeben, mit -c ein Configfile und mittels -D einen Treiber anzugeben. Kein einziger der Parameter scheint erkannt zu werden, folgende Ausgabe bekomme ich zu sehen:

Code:
wpa_supplicant: invalid option -- i
wpa_supplicant v0.5.9
Copyright (c) 2003-2007, Jouni Malinen <j@w1.fi> and contributors

This program is free software. You can distribute it and/or modify it
under the terms of the GNU General Public License version 2.

Alternatively, this software may be distributed under the terms of the
BSD license. See README and COPYING for more details.

usage:
  wpa_supplicant [-BddehLqquvwW] [-P<pid file>] [-g<global ctrl>] \
        [-C<ctrl>] \

drivers:
  madwifi = MADWIFI 802.11 support (Atheros, etc.)
  wired = wpa_supplicant wired Ethernet driver
Jeweils mit jedem der entprechenden Parameter die ich angebe, in diesem Falle -i.
Weiß jemand Rat? Danke im Vorraus! =)