.titleBar { margin-bottom: 5px!important; }

1&1 SIP Registrierung

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von fstolzen, 25 Sep. 2005.

  1. fstolzen

    fstolzen Neuer User

    Registriert seit:
    8 Nov. 2004
    Beiträge:
    39
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo an alle in diesem Forum,

    ich habe meinen Asterisk Server wunderbar am Laufen, nur eins bereitet mir seit Tagen Kopf zerbrechen, vielleicht könnt Ihr mir ja weiterhelfen.

    Sobald ich das SIP debug einschalte, erhalte ich folgende Fehlermeldung vom SIP Server von 1&1 zurück :

    SIP/2.0 403 Keine RFC1918-IP's erlaubt.

    Was fange ich mit dieser Meldung an?
    Oder hat sich jemand erfolgreich beim 1&1 SIP Server gestriert?

    Herzlichsten Dank schonmal im Voraus für eure Hilfe
     
  2. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Hast du nat=yes in der sip.conf unter [general] aktiviert (sollte sein!)?
     
  3. fstolzen

    fstolzen Neuer User

    Registriert seit:
    8 Nov. 2004
    Beiträge:
    39
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    erstmal danke für die Antowrt.

    Ja, in der sip.conf steht nat=yes, auch eine Dyndns Adresse, sofern man(n) das braucht, ist eingetragen.

    Eine Registrierung bei SIPGATE oder NIKOTEL funktioniert ohne Probleme.

    Nach gewisser Zeit geht der 1&1 auf unregisterd, jedoch die Meldung mit der RFC1918 Adresse kommt beim SIP Debug immer noch?
     
  4. fstolzen

    fstolzen Neuer User

    Registriert seit:
    8 Nov. 2004
    Beiträge:
    39
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [gelöst] 1&1 SIp Registrierung

    Hat sich erledigt.
     
  5. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    Läuft es denn jetzt ?

    Ich frag so doof weil ich ähnliches vor habe und gerne alles vorweg aus dem Weg räume was geht.. :wink:
     
  6. fstolzen

    fstolzen Neuer User

    Registriert seit:
    8 Nov. 2004
    Beiträge:
    39
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ja, nach ein wenig rumprobieren in den Trunk Settings, hat es bei mir nun endlich funktioniert.

    Ich habe hier noch die Parameter

    insecure = very
    nat = yes

    gesetzt.

    ´Das Problem trat immer mit der Nummer auf, die ich auch als normalen analog Anschluss habe. Die anderen drei Rufnummern liefen ohne Probleme.

    Nach dem setzten der obigen Parameter funktioniert es nun ohne Probs.

    Gruss Frank
     
  7. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey Frank und alle anderen,

    ich würde Dich gerne um etwas bitten - und zwar - ich stehe knietief im Dreck
    [schild=2 fontcolor=000000 shadowcolor=C0C0C0 shieldshadow=1]Installationsprobleme[/schild]

    1&1 mit A*H 2.0Beta

    Das ganze hinter einer AVM Fritz!Box 5050 und nicht forwardbarem Port 5060 UDP, da die Box den ja selber benützt - vorweg - eine Registrierung bei Sipgate funktioniert, scheitert aber am Invite.

    [...an dieser Stelle gekappt - denn...]

    --> ANTWORT <--

    Mit einem älteren Teledat Router läuft die ganze Sache nun...es lag also wirklich nur an der Fritz!Box 5050 und seinem verbauten - sogar inaktiven - Port 5060.

    Kurzum : [glow=red:9f494ba94d]GELÖST[/glow:9f494ba94d]

    [der Ordentlichkeit halber der Rest der ersten Anfrage...]

    Zum Thema, ich probiere seit 3 Tagen an den Konfig Files rum und hab mich schon mehr oder weniger häuslich eingerichtet, alles leider ohne Erfolg.

    Wärest Du so nett und würdest Du mit mir Deine Konfigfiles abgleichen ?

    sip.conf
    Code:
    [general]
    
    port = 5060           ; Testweise auch mal den 5160 probiert...ohne Erfolg
    bindaddr = 0.0.0.0    ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    context = from-sip-external ; Send unknown SIP callers to this context
    callerid = Unknown
    
    #include sip_nat.conf
    #include sip_custom.conf
    #include sip_additional.conf
    
    sip_nat.conf
    Code:
    nat=yes
    localnet=10.0.0.0/255.255.255.0
    externip=80.138.183.xx
    
    sip_additional.conf
    Code:
    register=492086103xxx:<secret>@sip.1und1.de/6103xxx
    
    [20]
    username=20
    type=friend
    secret=20
    record_out=Adhoc
    record_in=Adhoc
    qualify=no
    port=5060
    nat=never
    mailbox=20@device
    host=dynamic
    dtmfmode=rfc2833
    context=from-internal
    canreinvite=no
    callerid=device <20>
    
    [4920861034xx]
    username=4920861034xx
    type=peer
    secret=xxx
    host=sip.1und1.de
    
    Wäre Dir oder auch jedem anderen SEHR dankbar...

    Er meldet bei "sip show registry" immer und immer wieder : Auth sent ... failed ...
     
  8. Racerfreak

    Racerfreak Neuer User

    Registriert seit:
    3 Apr. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich habe seit einigen Wochen testweise einen Asterisk Server laufen (Trixbox 2.0). Intern läuft auch alles fantastisch - habe jedoch bisher nicht geschafft das sich Asterisk bei meinem SIP-Anbieter 1und1 registriert - bekomme die selbe Fehlermeldung wie fstolzen und habe alle in diesem Thread vorgeschlagenen Sachen ohne Erfolg getestet. Ich habe per freepbx einen Trunk mit den folgenden Daten eingerichtet - vielleicht könnt ihr mir ja weiterhelfen...

    Übrigens: Wenn ich nach draußen Telefoniere geht der Ruf raus - jedoch nur mit einseitiger Verständigung und angerufen werden kann ich auch nicht.

    Sip show registry meldet: Request sent

    Hier mal meine Einstellungen:


    Outbound Caller ID: <Name> "*meine-1und1-nummer*"

    outgoing Settings:

    Code:
    canreinvite=no
    context=from-trunk
    dtmfmode=info
    fromdomain=1und1.de
    fromuser=*meine-1und1-nummer*
    host=sip.1und1.de
    insecure=very
    nat=yes
    qualify=yes
    secret=*meinpasswort*
    type=friend
    username=*meine-1und1-nummer*
    
    User Context: *meine-1und1-nummer*


    Incoming Settings:

    Code:
    canreinvite=no
    context=from-trunk
    dtmfmode=info
    fromdomain=1und1.de
    fromuser=*meine-1und1-nummer*
    host=sip.1und1.de
    insecure=very
    nat=yes
    qualify=yes
    secret=*meinpasswort*
    type=friend
    username=*meine-1und1-nummer*
    

    Register string: *meine-1und1-nummer*:*meinpasswort*@sip.1und1.de/*meine extension*
     
  9. joerg98765

    joerg98765 Neuer User

    Registriert seit:
    24 Feb. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir hat es mit folgendem geklappt:

    sip.conf
    Code:
    [general]
    localnet=192.168.1.0/255.255.255.0
    externhost=dyn.dns.adresse
    
     
  10. Racerfreak

    Racerfreak Neuer User

    Registriert seit:
    3 Apr. 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    externhost=dyn.dns.adresse - das wars - nun klappts perfekt...

    Tausend Dank!
     
  11. nahrings

    nahrings Neuer User

    Registriert seit:
    8 Mai 2005
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Prüm

    So nun hab ich ähnliches Problem und wollte kein eigenes thema aufmachen da man dann sicher wieder an Threads verwiesenwerden wird ?

    Bei mir kan die Meldung:
    Als das Programm IVM von der Firma NCH-Swift
    sich bei meinem Provider 1&1 anmelden wollte.
    Die Rufnummer ist eine Internetnummer von 1&1.

    Wer kann Helfen das sich das Proggi anmeldet?
    Die Parameter sind in lineproperties.jpg
     

    Anhänge:

  12. deepsea

    deepsea Neuer User

    Registriert seit:
    29 Juli 2007
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problem noch vorhanden?

    Falls ja, würde ich den STUN-Server setzen auf: stun.1und1.de
     
  13. nahrings

    nahrings Neuer User

    Registriert seit:
    8 Mai 2005
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Prüm
    Half nicht s. Protokoll:

    22:00:41 Opening Internet Ports
    22:00:52 Sip Port 5065 (UDP) opened OK
    22:00:52 Local network IP is: 192.168.178.20
    22:00:52 This computer is connected to Internet over a network using a NAT, router or Internet Connection Sharing
    22:00:52 Checking with STUN
    22:01:00 NAT is symmetric so STUN will not work.
    22:01:00 Checking for a uPNP NAT
    22:01:10 No uPNP NAT or router found
    22:01:10 Because NAT or router is 'symmetric' networking will be slow unless you setup NAT manually
    22:01:11 SIP Network Tool finished
    22:01:11 Restarting SIP Engine
    22:01:11 SIP Private IP is: 192.168.178.20:5065
    22:01:11 Unable to auto-detect public IP. Using private IP
    22:01:11 SIP Public IP is: 192.168.178.20:5065
    22:01:11 SIP Number: 496551828576@192.168.178.20:5065
    22:01:11 Unable to find address of server:
     
  14. deepsea

    deepsea Neuer User

    Registriert seit:
    29 Juli 2007
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmmm.... irgendwie verstehe ich Dein Netzwerk nicht!

    Denke es ist: Internet-Service-Provider (ISP; 1und1) <-> FBF <-> Asterisk-Server <-> Telefone ..... oder?

    Weil wenn Du mal auf folgende Seite schaust (http://www.voip-info.org/wiki-STUN), dann müsstest Du ein "Restricted cone" NAT haben (aufgrund der Firewall in der FBF). Symmetrisch macht für mich keinen Sinn. ...
    Solange Du nicht an Deine externe IP-Adresse bei 1und1 kommst (das ist die die in der Übersicht der FBF angezeigt wird), kannst Du Dich nicht registrieren.

    Also, Schritt zurück, tragmal in der Option unter STUN Server Deine aktuelle externe IP-Adresse ein. Externer SIP-Port ist denke ich 5060, Rest kannste glaube ich auf 0 lassen oder setze es auf 1. Wie sieht das Protokoll jetzt aus?

    Apropro, hoffe es ist nicht Deine echte VoIP-Nummer, würde ich jedenfalls hier nicht angeben. Weiterhin denke ich Du hast Dein Passwort angegeben, weil ein echter SIP-Eintrag sieht wie folgt aus:

    sip:49xxxx:mypassword@1und1.de/49xxxx
     
  15. deepsea

    deepsea Neuer User

    Registriert seit:
    29 Juli 2007
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  16. nahrings

    nahrings Neuer User

    Registriert seit:
    8 Mai 2005
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Prüm
    kein asterisk

    Hallo deepsea,
    danke schonmal für 3 wichtige Infos aus Deinen Beiträgen.
    ich wurde dadurch inspiriert und werde noch verschiedenes ausprobieren.
    Mit allen Deinen Annahmen bzw. Vermutungen liegst Du richtig nur mit einer nicht: ich habe keinen Asterisk.
    Das Programm welches ich nutze heisst genau IVM Answering Attendant.
    Das ist eine Art Softphone, welches dafür gedacht ist Mailboxbetrieb mit bis zu 1000 Mailboxen zu bewerkstellingen und auch DTMF erkennt und Menuebäume erlaubt. Ausserdem kann das Programm viele Telefonleitungen gleichzeitig überwachen.
    Das alles nutze ich aber nicht sondern das teil kann genialer weise eine Liste mit Telefonnr. der reie nach anrufen und dort eine Nachricht hinterlassen.
    Dabei sind viele Einstellungen möglich.
    Diese Funktion wollte ich nutzen um z.B. in unserer Blaskapelle kurzfristig an eine wichtige Probe zu erinnern oder ein Platzkonzert bei schlechtem Wetter abzusagen.

    Ich checke nun mal die Anregungen und melde mich wieder hier.