.titleBar { margin-bottom: 5px!important; }

2 HFC Karten werden nicht richtig erkannt

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von konabi, 17 Nov. 2005.

  1. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    HAllo,
    ich habe das Problem dass zwei HFC Karten im System nicht richtig erkannt werden. (2 Typhoon Quick COM ISDN 128 PCI)
    Hardwaremäßig sind sie schon da:

    #lspci
    0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
    0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
    0000:00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
    0000:00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
    0000:00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
    0000:00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
    0000:00:09.0 Network controller: Cologne Chip Designs GmbH ISDN network controller [HFC-PCI] (rev 02)
    0000:00:0a.0 Network controller: Cologne Chip Designs GmbH ISDN network controller [HFC-PCI] (rev 02)
    0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

    # cat /proc/interrupts
    CPU0
    0: 2624154 IO-APIC-edge timer
    1: 2974 IO-APIC-edge i8042
    2: 0 XT-PIC cascade
    5: 13005044 IO-APIC-level uhci_hcd, zaphfc
    8: 4 IO-APIC-edge rtc
    10: 5155 IO-APIC-level eth0
    12: 12860339 IO-APIC-level zaphfc
    14: 3859 IO-APIC-edge ide0
    15: 23 IO-APIC-edge ide1
    NMI: 0
    LOC: 2624168
    ERR: 0
    MIS: 0



    #modprobe zaptel
    Zapata Telephony Interface Registered on major 196

    #modprobe zaphfc modes=1
    PCI: Enabling device 0000:00:09.0 (0000 -> 0003)
    zaphfc: CCD/Billion/Asuscom 2BD0 configured at mem 0xca885000 fifo 0xc5e18000(0x5e18000) IRQ 5 HZ 1000
    zaphfc: Card 0 configured for NT mode
    PCI: Enabling device 0000:00:0a.0 (0000 -> 0003)
    zaphfc: CCD/Billion/Asuscom 2BD0 configured at mem 0xca89d000 fifo 0xc5e58000(0x5e58000) IRQ 12 HZ 1000
    zaphfc: Card 1 configured for TE mode
    zaphfc: 2 hfc-pci card(s) in this box.
    Registered tone zone 3 (Netherlands)

    #ztcfg -vv

    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    Channel map:

    Channel 01: Individual Clear channel (Default) (Slaves: 01)
    Channel 02: Individual Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    Channel 04: Individual Clear channel (Default) (Slaves: 04)
    Channel 05: Individual Clear channel (Default) (Slaves: 05)
    Channel 06: D-channel (Default) (Slaves: 06)

    6 channels configured.



    cat /proc/zaptel/1
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 DEACTIVATED (G2)" AMI/CCS

    1 ZTHFC1/0/1 Clear
    2 ZTHFC1/0/2 Clear
    3 ZTHFC1/0/3 HDLCFCS


    cat /proc/zaptel/2
    Span 2: ZTHFC2 "HFC-S PCI A ISDN card 1 [TE] layer 1 DEACTIVATED (F4)" AMI/CCS

    4 ZTHFC2/0/1 Clear
    5 ZTHFC2/0/2 Clear
    6 ZTHFC2/0/3 HDLCFCS
    debian:~#



    Soweit schein alles OK stecke ich nun das gekreuzten ISDN Kabels mit Stromversorgung in die erste Karte (oberer PCI Slot)
    hinein, bleiben beide Karten im deaktiviertne Zustand:


    cat /proc/zaptel/1
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 DEACTIVATED (G2)" AMI/CCS

    1 ZTHFC1/0/1 Clear
    2 ZTHFC1/0/2 Clear
    3 ZTHFC1/0/3 HDLCFCS


    cat /proc/zaptel/2
    Span 2: ZTHFC2 "HFC-S PCI A ISDN card 1 [TE] layer 1 DEACTIVATED (F4)" AMI/CCS

    4 ZTHFC2/0/1 Clear
    5 ZTHFC2/0/2 Clear
    6 ZTHFC2/0/3 HDLCFCS


    Stecke ich das Kabel hingegen in die zweite Karte (untere PCI Slot) hinein ist die erste Karte aktiviert:


    cat /proc/zaptel/2
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 ACTIVATED (G3)" AMI/CCS

    4 ZTHFC2/0/1 Clear
    5 ZTHFC2/0/2 Clear
    6 ZTHFC2/0/3 HDLCFCS


    Es wird also die zweite Karte als erste Karte erkannt. Die erste Karte hingegen gar nicht. Hardwaremaäßig ist sie aber da:


    hier noch meine zaptel.conf:


    Code:
    loadzone=nl
    defaultzone=nl
    
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    
    span=2,1,3,ccs,ami
    bchan=4-5
    dchan=6
    

    Ich wäre wirklich dankbar wenn irgend jemand von Euch eine Idee Euch hätte.

    Gruß Sven
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hallo Sven,

    woher weisst du denn welches die erste und welches die zweite Karte ist?
    Du hast eine im nt und eine Karte im te-Mode.

    Da hilft bei baugleichen Karten meisst nur probieren.
    Also steck die Kabel mal entgegen deiner Meinung ein und sie was passiert.

    Ausserdem hat eine Karte einen gesharten irq, was dem Sound nicht sonderlich zuträglich ist.


    Gruß

    Karl-Heinz
     
  3. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Also mir sagte huer im Forum mal einer dass die Reihenfolge der PCI Slots entscheident wäre.

    http://www.ip-phone-forum.de/forum/viewtopic.php?t=21163

    Das eine Karte den IRQ mit uhci_hcd teilt habe ich festgestellt..
    Aber selbst wenn ich den PCI Slots der Karten fest einen IRQ zuweise ändert sich der IRQ von uhci_hcd auf den der Karte.


    Gruß Sven
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Ja, normalerweise wenn du von Vorne auf das Board schaust(Slots auf der anderen Seite) wird von rechts nach links gezählt.

    Nur halten sich nicht alle an diese Regel.


    Versuche mal einen irq freizumachen. VGA-Karte, serielle oder paralelle Schnittstellen ausschalten.

    Oder probieren, ob es so geht.

    Wenn nicht florz-Patch, da brauchst du nur eine Karte mit einem nicht gesharten irq.
     
  5. fridiy

    fridiy Neuer User

    Registriert seit:
    8 Okt. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo Forum Leute ich habe eine kleine problem ich habe Bristuff installiert und ist gut gelaufen aber jetzt mache ich probe bekomme ich diese Fehlemeldung.
    asterisk2:~ # modprobe zaphfc modes=1
    FATAL: Error inserting zaphfc (/lib/modules/2.6.11.4-20a-default/extra/zaphfc.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    asterisk2:~ # modprobe zaphfc modes=2
    FATAL: Error inserting zaphfc (/lib/modules/2.6.11.4-20a-default/extra/zaphfc.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    kann jemand mir helfen vielen Dank
     
  6. fridiy

    fridiy Neuer User

    Registriert seit:
    8 Okt. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    3HFC-Karten

    hallo zusammen
    ich möchte gerne eine Asterisk-Server mit 3-HFC-Karten aufbauen und ich brauche eure unterstützung eigentlich ich habe schon geschaft diese Sever zu bauen mit 3HFC-Karten eine in NT-mode und Zwei in TE-mode und hat alles super funktioniert aber als ich die sache umdrehen wolte d.h zwei karte in NT-mods und eine Karte in TE-mods klapt nicht mehr es weden nur zwei karten aktiviert und die 3.te nicht


    meine zapata.conf schaut so aus
    [channels]

    ;Erste Karte NT-Modus
    switchtype=euroisdn
    signalling=bri_net_ptmp
    pridialplan=unknown
    prilocaldialplan=unknown
    echocancel=yes
    immediate=no
    usecallerid=yes
    overlapdial=no
    group=1
    context=default
    channel=>1-2

    ;Zweite Karte TE-Modus
    switchtype=euroisdn
    pridialplan=unknown
    prilocaldialplan=unknown
    signalling=bri_cpe_ptmp
    echocancel=yes
    immediate=no
    usecallerid=yes
    overlapdial=yes
    group=2
    context=default
    channel=>4-5


    ; 3. Karte im NT-Modus
    switchtype=euroisdn
    pridialplan=unknown
    prilocaldialplan=unknown
    signalling=bri_net_ptmp
    echocancel=yes
    immediate=no
    usecallingpres=yes
    overlapdial=no
    group=3
    context=default
    channel=>7-8

    und meine
    zaptel.conf schaut so aus
    loadzone = de
    defaultzone=de
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    span=2,1,3,ccs,ami
    bchan=4-5
    dchan=6
    span=3,1,3,ccs,ami
    bchan=7-8
    dchan=9





    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 3: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    Channel map:

    Channel 01: Clear channel (Default) (Slaves: 01)
    Channel 02: Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    Channel 04: Clear channel (Default) (Slaves: 04)
    Channel 05: Clear channel (Default) (Slaves: 05)
    Channel 06: D-channel (Default) (Slaves: 06)
    Channel 07: Clear channel (Default) (Slaves: 07)
    Channel 08: Clear channel (Default) (Slaves: 08)
    Channel 09: D-channel (Default) (Slaves: 09)

    9 channels configured.

    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # cat /proc/zaptel/*
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 ACTIVATED (G3)" AMI/CCS

    1 ZTHFC1/0/1 Clear
    2 ZTHFC1/0/2 Clear
    3 ZTHFC1/0/3 HDLCFCS
    Span 2: ZTHFC2 "HFC-S PCI A ISDN card 1 [TE] layer 1 ACTIVATED (F7)" AMI/CCS

    4 ZTHFC2/0/1 Clear
    5 ZTHFC2/0/2 Clear
    6 ZTHFC2/0/3 HDLCFCS
    Span 3: ZTHFC3 "HFC-S PCI A ISDN card 2 [TE] layer 1 DEACTIVATED (F5)" AMI/CCS

    7 ZTHFC3/0/1 Clear
    8 ZTHFC3/0/2 Clear
    9 ZTHFC3/0/3 HDLCFCS

    kann jemand mir helfen danke alle
     
  7. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Wie startest du Hfc, make loadNT?

    wenn ja, hast du die Zeile entprechend für drei Karten angepasst?

    Das müsste bei dir modes=5 sein.
     
  8. fridiy

    fridiy Neuer User

    Registriert seit:
    8 Okt. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    danke dir kombjuderich habe das schon gemacht und hat nicht gebracht noch dazu wird die karte 3 die als NT konfiguriert wird als TE gezeigt und DEACTIVATED
    ich gelaube ich muss was an der Makefile was ändern aber ich weiss nicht was soll ich ändern?
    bei mir ist die mods auf 1 gesetzt habe versucht auf 3 aber nich gebracht
     
  9. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Doch natürlich hat das was gebracht, die dritte Karte wird te

    Einfache binäre Mathematik:

    Du hast drei Karten, der NT -Modus wird durch setzen des Bits der Karte auf 1 erreicht.

    Du willst

    1 2 3 (Bit-Nummer)
    NT TE NT

    1 2 4 (Bit-Wert) Damit ergibt sich 1 + 0 + 4 =5 also modes gleich 5 und nicht 3
     
  10. fridiy

    fridiy Neuer User

    Registriert seit:
    8 Okt. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    vielen Dank kombjuder es hat funktioniert.

    asterisk2:~ # cd /usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # modprobe zaptel
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # modprobe zaphfc modes=5
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # ztcfg -vvv

    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 3: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    Channel map:

    Channel 01: Clear channel (Default) (Slaves: 01)
    Channel 02: Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    Channel 04: Clear channel (Default) (Slaves: 04)
    Channel 05: Clear channel (Default) (Slaves: 05)
    Channel 06: D-channel (Default) (Slaves: 06)
    Channel 07: Clear channel (Default) (Slaves: 07)
    Channel 08: Clear channel (Default) (Slaves: 08)
    Channel 09: D-channel (Default) (Slaves: 09)

    9 channels configured.

    Changing signalling on channel 1 from Unused to Clear channel
    Changing signalling on channel 2 from Unused to Clear channel
    Changing signalling on channel 3 from Unused to HDLC with FCS check
    Changing signalling on channel 4 from Unused to Clear channel
    Changing signalling on channel 5 from Unused to Clear channel
    Changing signalling on channel 6 from Unused to HDLC with FCS check
    Changing signalling on channel 7 from Unused to Clear channel
    Changing signalling on channel 8 from Unused to Clear channel
    Changing signalling on channel 9 from Unused to HDLC with FCS check
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # cat /proc/zaptel/*
    Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [NT] layer 1 ACTIVATED (G3)" AMI/CCS

    1 ZTHFC1/0/1 Clear
    2 ZTHFC1/0/2 Clear
    3 ZTHFC1/0/3 HDLCFCS
    Span 2: ZTHFC2 "HFC-S PCI A ISDN card 1 [TE] layer 1 ACTIVATED (F7)" AMI/CCS

    4 ZTHFC2/0/1 Clear
    5 ZTHFC2/0/2 Clear
    6 ZTHFC2/0/3 HDLCFCS
    Span 3: ZTHFC3 "HFC-S PCI A ISDN card 2 [NT] layer 1 ACTIVATED (G3)" AMI/CCS

    7 ZTHFC3/0/1 Clear
    8 ZTHFC3/0/2 Clear
    9 ZTHFC3/0/3 HDLCFCS
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc #

    und asterisk start ohne fehler aber wenn ich linux runterfahre und neu starte bekomme ich immer diese fehler Meldungen

    [chan_zap.so] => (Zapata Telephony w/PRI)

    == Parsing '/etc/asterisk/zapata.conf': Found
    Mar 15 15:07:03 WARNING[6348]: chan_zap.c:1099 zt_open: Unable to specify channel 1: No such device or address
    Mar 15 15:07:03 ERROR[6348]: chan_zap.c:7208 mkintf: Unable to open channel 1: No such device or address
    here = 0, tmp->channel = 1, channel = 1
    Mar 15 15:07:03 ERROR[6348]: chan_zap.c:11892 setup_zap: Unable to register channel '1-2'
    Mar 15 15:07:03 WARNING[6348]: loader.c:414 __load_resource: chan_zap.so: load_module failed, returning -1
    Mar 15 15:07:03 WARNING[6348]: loader.c:499 load_modules: Loading module chan_zap.so failed!


    d.h wenn ich Linux neu starte muss ich erst bei jedem Start den Treiber neu laden d.h ich muss immer bevor ich asterisk starte den treiber neuladen so

    asterisk2:~ # cd /usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # modprobe zaptel
    asterisk2:/usr/src/asterisk/bristuff-0.3.0-PRE-1o/zaphfc # modprobe zaphfc modes=5

    danach kann ich asterisk -cvvvgv durchführen und wird ohne feheler gestartet
    was soll ich machen damit asterisk startet ohne problem oder beim neu start von linux startet mit.
    kann jemand mir helfen .
    MFG
     
  11. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Dazu gibt es fertige Scripts. Bei SUse könnte ich dir helfen, für den Rest musst du mal die Suche benützen oder google fragen.
     
  12. vWalter

    vWalter Neuer User

    Registriert seit:
    21 Jan. 2006
    Beiträge:
    107
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi,

    das hier in einer Deiner Startdateien - z.B. in der "boot.local", sollte prima funktionieren.
    (den modes- und den timer_card-parameter musst Du natuerlich anpassen)


    /sbin/modprobe zaphfc modes=1 timer_card=1
    sleep 1
    ztcfg -vvv
    sleep 1



    Gruss
    Walter





    .
     
  13. fridiy

    fridiy Neuer User

    Registriert seit:
    8 Okt. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo zusammen ich danke euch sher es hat funktioniert ihr seid echt super vielen Dank noch mal und besonders vielen dank an kombjuder und an vWalter