[Problem] [7390] iOS VPN: VPN Server antwortet nicht

das_ubersoldat

Neuer User
Mitglied seit
1 Sep 2010
Beiträge
158
Punkte für Reaktionen
0
Punkte
16
Hallo,

ich habe seit der Umstellung auf die neueste Fritz Fernzugang Einrichten Software immer das Problem, dass meine iOS Geräte immer die Meldung: "VPN Server antwortet nicht" anzeigen. Ich benutze Version 1.3 und die FritzBox hat die neueste Firmware Version. Mit der vorherigen Firmware lief es auch nicht.

Ich habe folgende 3 User (die ersten beiden funktionieren via Shrew, aber der iPad User funktioniert nicht). iPhone/iPad sind beide auf iOS 5.1

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "user1";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.1.203;
                remoteid {
                        user_fqdn = "user1";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = no;
                use_cfgmode = no;
                phase2localid {
                        ipnet {
                                ipaddr = 192.168.1.0;
                                mask = 255.255.255.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.1.203;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/pfs";
                accesslist = 
                             "permit ip 192.168.1.0 255.255.255.0 192.168.1.203 255.255.255.255";
        } {
                enabled = yes;
                conn_type = conntype_user;
                name = "user2";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.1.202;
                remoteid {
                        user_fqdn = "user2";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = no;
                use_cfgmode = no;
                phase2localid {
                        ipnet {
                                ipaddr = 192.168.1.0;
                                mask = 255.255.255.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.1.202;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/pfs";
                accesslist = 
                             "permit ip 192.168.1.0 255.255.255.0 192.168.1.202 255.255.255.255";
        } {
                enabled = yes;
                conn_type = conntype_user;
                name = "ipad";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.1.201;
                remoteid {
                        key_id = "ipad";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                xauth {
                        valid = yes;
                        username = "ipad";
                        passwd = "";
                }
                use_cfgmode = yes;
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.1.201;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 192.168.1.0 255.255.255.0 192.168.1.201 255.255.255.255", 
                             "permit ip any 192.168.1.201 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}
Den AVM Support habe ich auch schon kontaktiert, aber die sagen, dass sie die VPN Funktionalität nicht supporten.
 
Zuletzt bearbeitet:

frank_m24

IPPF-Urgestein
Mitglied seit
20 Aug 2005
Beiträge
17,571
Punkte für Reaktionen
1
Punkte
38
Code:
                accesslist = 
                             "permit ip 192.168.1.0 255.255.255.0 192.168.1.201 255.255.255.255", 
                             "permit ip any 192.168.1.201 255.255.255.255";
Vergleiche das noch mal mit den anderen Konfigutationen und der AVM Beispielkonfiguration. Meines Erachtens ist die 2. Zeile unnötig oder sogar kontraproduktiv. Hast du die eingefügt?
 

Novize

Moderator
Teammitglied
Mitglied seit
17 Aug 2004
Beiträge
21,177
Punkte für Reaktionen
150
Punkte
63
Und Du meinst, wir sollen obigen Wortbrei supporten, obwohl da nicht einmal ansatzweise auf eine korrekte Schreibweise geachtet wurde? In der Schriftform gibt es tatsächlich noch die Shift-Taste für halbwegs korrekte Groß- Kleinschreibung.
Besser doch bitte umgehend nach!
 

das_ubersoldat

Neuer User
Mitglied seit
1 Sep 2010
Beiträge
158
Punkte für Reaktionen
0
Punkte
16
Vergleiche das noch mal mit den anderen Konfigutationen und der AVM Beispielkonfiguration. Meines Erachtens ist die 2. Zeile unnötig oder sogar kontraproduktiv. Hast du die eingefügt?
Ich habe die Konfigurationsdateien nicht geändert. Die beiden Zeilen kommen von der AVM Software.
 
Zuletzt bearbeitet:

frank_m24

IPPF-Urgestein
Mitglied seit
20 Aug 2005
Beiträge
17,571
Punkte für Reaktionen
1
Punkte
38
Ich möchte mich der Bitte von Novize anschließen und fordere dich dringend auf, deine Beiträge in Bezug auf die Rechtschreibung zu korrigieren. Solange das nicht passiert, muss ich voraussetzen, dass du kein ernsthaftes Interesse an einer Lösung hast. Dann können wir den Thread auch schließen.
 

frank_m24

IPPF-Urgestein
Mitglied seit
20 Aug 2005
Beiträge
17,571
Punkte für Reaktionen
1
Punkte
38
Erlaubt der Internetzugang VPN Verbindungen? Möglicherweise wird da was blockiert. Besonders Mobilfunktarife gibt es, die VPN Nutzung blocken.
 

das_ubersoldat

Neuer User
Mitglied seit
1 Sep 2010
Beiträge
158
Punkte für Reaktionen
0
Punkte
16
Ja ich benutze eine Vodafone Firmenkarte: Witopia VPN und das Firmen VPN funktionieren einwandfrei.
 

BurningCrash

Aktives Mitglied
Mitglied seit
21 Jun 2007
Beiträge
1,764
Punkte für Reaktionen
0
Punkte
38
So sieht meine Config aus:

Code:
vpncfg {
connections {
enabled = yes;
conn_type = conntype_user;
name = "[COLOR="#FF0000"]BENUTZERNAME[/COLOR]";
always_renew = no;
reject_not_encrypted = no;
dont_filter_netbios = yes;
localip = 0.0.0.0;
local_virtualip = 0.0.0.0;
remoteip = 0.0.0.0;
remote_virtualip = 192.168.[COLOR="#FF0000"]X.XXX[/COLOR];
remoteid {
key_id = "[COLOR="#FF0000"]BenutzerNAME[/COLOR]";
}
mode = phase1_mode_aggressive;
phase1ss = "all/all/all";
keytype = connkeytype_pre_shared;
key = "[COLOR="#FF0000"]PASSWORT[/COLOR]";
cert_do_server_auth = no;
use_nat_t = yes;
use_xauth = yes;
use_cfgmode = no;
xauth {
valid = yes;
username = "[COLOR="#FF0000"]BENUTZERNAME[/COLOR]";
passwd = "[COLOR="#FF0000"]PASSWORT[/COLOR]";
}
phase2localid {
ipnet {
ipaddr = 0.0.0.0;
mask = 0.0.0.0;
}
}
phase2remoteid {
ipaddr = 192.168.[COLOR="#FF0000"]X.XXX[/COLOR];
}
phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
accesslist =
"permit ip any 192.168.[COLOR="#FF0000"]X.XXX[/COLOR] 255.255.255.255";
}
}
Alles in Rot durch deine Eingaben anpassen.
Die X.XXX durch die IP die du haben willst im LAN Wenn du verbunden bist. Bitte ausserhalb aus dem Bereich des DHCP-Server.

So läuft es bei mir mit VPN durch HotSpot's,Mobilfunk oder wo man sonst drin hängt..
 

das_ubersoldat

Neuer User
Mitglied seit
1 Sep 2010
Beiträge
158
Punkte für Reaktionen
0
Punkte
16
Danke. Erlaubt diese Konfiguration, dass der komplette Traffic (also auch Internettraffic) durchgeroutet wird? Oder erlaubt diese nur den Zugriff aufs LAN?
 

BurningCrash

Aktives Mitglied
Mitglied seit
21 Jun 2007
Beiträge
1,764
Punkte für Reaktionen
0
Punkte
38
ALLES wird geroutet.
Hatte mich einiges an Recherche in Google gekostet aber so funktioniert.
Was ich auch raus gefunden habe das es bis zu einer bestimmten Labor nicht ging wegen einem Fehler von AVM, den Sie offiziell nie eingestanden haben.
 
3CX

Neueste Beiträge

Statistik des Forums

Themen
235,932
Beiträge
2,067,976
Mitglieder
356,991
Neuestes Mitglied
Hflgk GB ja x