.titleBar { margin-bottom: 5px!important; }

7940/60 Umfeld-Umfrage

Dieses Thema im Forum "Cisco" wurde erstellt von cobra, 28 März 2005.

  1. cobra

    cobra Neuer User

    Registriert seit:
    15 Nov. 2004
    Beiträge:
    197
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT Project Manager
    Ort:
    JWD
    Hello All!

    Da wir im Moment an einer Installationsanleitung fuer SIP-Images auf dem Cisco7940/7960 arbeiten, und es widerspruechliche Erfahrungen gibt, moechte ich gerne von Euch wissen, wie es bei Euch ausschaut.
    Haupt-Knackpunkt ist die Frage, ob in der Config nun 'nat_enable:' und 'nat_received_processing:' auf 1 oder 0 stehen sollten.
    Dazu ist die Netzwerk-Umgebung natuerlich sehr wichtig. Also meine Fragen :

    SIP-Provider
    IP-Adresse : dynamisch oder statisch
    Router : mit/ohne NAT
    Port-Fwd aktiviert fuer welche Ports?
    nat_enable: 0 oder 1
    nat_address: freigelassen, oder DynDNS-Eintrag oder was sonst?
    nat_received_processing: 0 oder 1

    In meinem Falle heisst das:

    Provider : Sipgate
    IP-Adr : dynamisch (Standard-DSL)
    Router : NAT
    Port-Fwd : 5060, 16384-16388 auf's Phone
    nat_enable:1
    nat_address: dynDNS
    nat_received_processing:1

    Ich bitte um rege Teilnahme...

    Danke und besten Gruss
    Michael
     
  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    nat_enable: 0 duerfte wohl bei vielen Firewalls Probleme machen auch wenn kein NAT eingesetzt wird. Das Problem ist, dass bei nat_enable: 0 die Signalisierung asynchron laeuft. Das Telefon erwartet also die Antwort nicht auf dem gleichen Port von dem aus eine Nachricht verschickt wurde. Deshalb werden wohl die meisten Firewalls zurecht die Antwort blocken, wenn man nicht explizit den Port freischaltet. Mit nat_enable:1 funktioniert es zumindest bei uns.

    Die anderen beiden Parameter hab ich nicht angefasst. Ich glaube die sind in unserer Version noch gar nicht enthalten. :)

    Provider: sipgate
    IP-Adr: oeffentliche Adresse (statisch)
    Router: Linux-Kiste mit Firewall
    Port-Fwd: nix
    Parameter siehe oben :)
     
  3. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    Provider : Sipgate, Nikotel, pbx-network, gmx, PURtel
    IP-Adresse : (quasi) statisch (ish-Kabel)
    Router : NAT (symmetric)
    Port-FWD : 5070, 16384-16388 auf das Telefon
    nat_enable: 1
    nat_address: dynDNS (aber statischer Eintrag)
    nat_received_processing: 1
    FW-Version: 7.3

    @Maik
    Das mit dem "nat_enable" habe ich jetzt nicht wirklich verstanden! Auf welchem Port wird denn dann die Antwort erwartet? Das müsste dann doch auch irgendwo konfigurierbar sein ?!
    Ich habe bei mir zum Beispiel als voip_control_port die 5070 eingetragen, damit abgehend und ankommend Port 5070 benutzt wird. Ich wüsste nicht, wo ich sonst dran drehen könnte/sollte...

    Das Telefon hat direkt eine öffentliche IP-Adresse? So, daß die Linux-Büchse also nur Firewall spielt und kein NAT und Co macht, ja?!

    :!: Apropos: Die Firmware-Version könnte auch von Interesse sein
     
  4. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn nat_enable:0 gesetzt ist, werden die Nachrichten mit Port 5070 als Absenderport versendet sondern von einem zufaellig gewaehlten Port aus. Ich wuesste zu gerne mal, was sich die entwickler dabei gedacht haben, denn IMO macht das absolut keinen Sinn.

    Genau.

    Da bin ich mir nicht ganz sicher und ich finde auch gerade das Image nicht. Muesste ich mal nachsehen, wenn ich wieder ans Telefon komme. Aber soweit ich mich erinnere war es eine 6er Version.
     
  5. muecke77

    muecke77 Neuer User

    Registriert seit:
    5 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    SIP-Provider Sipgate, GMX, Puretel, FWD, Nikotel
    IP-Adresse : dynamisch T-DSL
    Router : WRT54G mit NAT
    Port-Fwd UDP 5060, 5004-5007
    nat_enable: 1
    nat_address: DynDNS
    nat_received_processing: 1

    - Muecke77