.titleBar { margin-bottom: 5px!important; }

A@H langsam in der Vermittlung

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von Pelo, 17 Jan. 2006.

  1. Pelo

    Pelo Neuer User

    Registriert seit:
    23 Okt. 2004
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    habe schon länger bemerkt, dass A@H ziemlich langsam in der Reaktionszeit ist. Wenn ich zum Beispiel die Mailbox abfrage kommt es immer zu einer 2-3 Sekundenverzögerung bevor die Box anspricht. Habe dieses Gestern mal (auf dem gleichen Rechner) mit SUSE 10 und einer normalen Asterisk installation probiert, die mit dem PBX-Manager konfiguriert wurde und alles lief flüssiger...

    Auch wenn ich eine interne Nummer wähle: Wenn ich beim Grandstream BT101 die Send Taste drücke, klingelt es bei der SUSE/PBX Manager Variante sofort und bei A@H erst 1-2 Sekunden Später...

    Gibt es in der Konfiguration eingebaute Bremsen oder ist da was anderes im Argen?

    Gruß

    Pelo
     
  2. Liquido

    Liquido Neuer User

    Registriert seit:
    13 Jan. 2006
    Beiträge:
    57
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    System-Engineer
    Hallo Pelo,

    ne da ist keine Bremse eingebaut. Die Verzögerung ergeben sich durch das verwendete AMP. AMP ist das Webinterface um einen Dialplan zu erstellen, dabei wird der Dialplan aber so aufgebaut das er zur Laufzeit verschiedene Prüfungen macht und gleichzeitig auch Anruferdaten in die MySql Datenbank schreibt.

    Bei mir im Büro konnte ich eine Verzögerung von genau 1 Mal klingen festellen, d.H. meine Asterisk Box auf einem Gentoo 3.2Ghz Rechner mit einem selbstgeschriebenen Dialplan klingelt sofort wärend mein Gentoo Asterisk AMP 400Mhz es einmal mehr klingelt lässt bis er die SIP Telefone läuten lässt.

    Die Frage wäre nun wie ist das Verhältnis wenn ich nun AMP auf dem 3.2 Ghz hätte und Handmade Dialplan auf dem 400Mhz Rechner.

    Vermutlich ist es beim PBX-Manager so, dass er weniger Prüfungen im Dialplan eingebaut hat und durch dies schneller einen Anruff beantworten kann.
     
  3. chriswal

    chriswal Neuer User

    Registriert seit:
    17 Dez. 2005
    Beiträge:
    46
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich hatte einen fehler in der dialparties.agi der eine verzögerung verursacht hat. das script macht eine telnet session auf die datenbank, und prüft den prompt. das script stimmte nicht mit dem prompt überein und verursachte dadurch eine verzögerung von ein paar sekunden. schau in der asterisk console ob er bei dir auch beim script kurz stehen bleibt und nach einer zeit weitermacht...wenn das der fall ist, brauchst du nur die abfrage im script auf den richtigen prompt wechseln.
     
  4. Pelo

    Pelo Neuer User

    Registriert seit:
    23 Okt. 2004
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmm es ist ein wenig schneller geworden... in der Tat liegt es an der dialparties.agi. (Guter Tip) Allerdings braucht A@H immer noch "ein wenig" länger um ein Verbindung herzustellen..

    Im Mailboxbetrieb sind extrem lange Wartezeiten:

    Erst kommt etwas was ich nicht identifizieren kann und dann kommt die "Mailbox" Ansage... dann ca. 3-5 Sekunden nichts - dann der Hinweis auf die Passworteingabe...
    (Bin jetzt nicht @home zum testen) oder kann man das Passwort schon früher eingeben??? Muss ich mal probieren nach der Arbeit...

    CU

    Pelo
     
  5. chriswal

    chriswal Neuer User

    Registriert seit:
    17 Dez. 2005
    Beiträge:
    46
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  6. chriswal

    chriswal Neuer User

    Registriert seit:
    17 Dez. 2005
    Beiträge:
    46
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habs jetzt mal ausprobiert. bei mir war eine lange pause zwischen ansage und passwort, nur weil die erkennung der nebenstelle nicht funktioniert hatte..ich musste bei meinem sip telefon die dtmf funktion umstellen. ausserdem muss man die eingabe mit # abschliessen, damit es schneller wird.