.titleBar { margin-bottom: 5px!important; }

Absturz des SOT bei Videowiedergabe

Dieses Thema im Forum "IP-TV" wurde erstellt von wynn, 15 Feb. 2007.

  1. wynn

    wynn Mitglied

    Registriert seit:
    4 Juli 2005
    Beiträge:
    245
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 wynn, 15 Feb. 2007
    Zuletzt bearbeitet: 15 Feb. 2007
    Hallo,

    die Version 3.0.13 des SOT-Clienten stürzt bei Videowiedergabe aus einem freigegebenen Ordner reproduzierbar ab (siehe Screenshot).

    Außerdem habe ich ein Problem festgestellt, daß in den Releasenotes schon mal als gefixt gemeldet wurde: Beim Abspielen von mp3 stockt die Wiedergabe des ersten Titels nach ca. zwei Sekunden und beginnt von Neuem. Beim Sprung zum nächsten Titel passiert das nicht.

    Beide Probleme sind zumindest in der Version 3.0.9 nicht aufgetreten.

    Ich poste mal den Debug Log mit, der allerdings keine Hinweise zur Fehlerursache enthält. Aber vielleicht kann mir jemand sagen was der Fehler beim Netzwerkmapping bedeutet. Die Freigabe funktioniert, bis auf die Tatsache, daß ich das "C" am Ende des Freigabenamens nicht mit eingegeben habe, also "Dateien" statt "DateienC" (vorletzte Zeile im Log, bei scanne Verzeichnis). Wenn ich "Daten" daraus mache wird das dann zu "DatenE".

    12:42:06->ActivateKonfig
    12:42:07->CheckInternetFiles
    12:42:07->ActivateMapDrives
    12:42:07->Mounte -- Quelle=\\vati\Dateien---Freigabe=Dateien--
    12:42:07->Fehler bei MapDrive Quelle=\\vati\Dateien Freigabe=Dateien Fehlercode=System.ComponentModel.Win32Exception: DeviceAlreadyRemembered
    bei OpenNETCF.Net.Network.MapDrive()
    bei SOTClient.ProgrammInit.ActivateMapDrives()
    bei SOTClient.ProgrammInit.InitProgramm()
    bei SOTClient.main.main_Load()
    bei System.Windows.Forms.Form.OnLoad()
    bei System.Windows.Forms.Form._SetVisibleNotify()
    bei System.Windows.Forms.Control.set_Visible()
    bei System.Windows.Forms.Application.Run()
    bei SOTClient.main.Main()
    DeviceAlreadyRemembered
    12:42:07->ActiveHttpInterfaceStyleSheet
    12:42:07->Starte Externe Programme
    12:42:07->ReadOnlineReleaseInfos
    12:42:07->-1
    12:42:07->OnlineReleaseVersion=0.3.0.13
    12:42:07->LocalReleaseVersion=0.3.0.13
    12:42:07->aktiviere NetworkKeepAlive
    12:42:09->NetworkKeepAlive->Start
    12:42:09->Starte Scan in: .\Netzwerk\
    12:42:09->Anzahl gefundener Verzeichnisse=0
    12:42:09->Scanne Verzeichnis: .\Netzwerk\DateienC
    12:42:09->NetworkKeepAlive->Ende
    cu
    wynn
     

    Anhänge:

  2. NEELIXThomas

    NEELIXThomas SOT-Team

    Registriert seit:
    31 März 2006
    Beiträge:
    2,150
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    stürzt er auch bei Videos ohne Umlaute im Dateinamen ab?
     
  3. wynn

    wynn Mitglied

    Registriert seit:
    4 Juli 2005
    Beiträge:
    245
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja, und zwar auch bei Videos die schon mal ganz gut liefen, bis auf ein paar kurze Ruckler.

    Was das Problem mit der Dateifreigabe angeht, so tritt der Fehler auf wenn der Client neu gestartet wird. "Freigabe bereits gemerkt" könnte man etwas frei übersetzen. Beim kompletten Neustart kommt die Meldung nicht. Was den angehängten Buchstaben angeht, so ist das vermutlich auf das Editieren der sot.ini zurückzuführen. Da soll man ja etwas vorsichtig sein, gerade mit <CR>. Das habe ich zwar nicht verwendet, aber evtl. schleicht sich das ja über irgendein Steuerzeichen des Windows-Editors ein

    cu
    wynn
     
  4. wynn

    wynn Mitglied

    Registriert seit:
    4 Juli 2005
    Beiträge:
    245
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Fehler geklärt. Eigene Schuld !

    Asche auf mein Haupt ! Ich habe wohl beim Installieren und Updaten etwas die Übersicht verloren und den TCPMP gelöscht bzw. nicht mit eingespielt.

    Andere Frage: Bis zu welcher Datenrate läuft der TCPMP ruckelfrei ? Ich nehme mit meiner WinTV-PVR mit VBR und 5500 MBit (Spitze bis 9000 MBit) auf und habe aller paar Sekunden kurze Aussetzer. Die Erhöhung des Puffers bringt auch nichts.

    Wie sind Eure Erfahrungen ?

    cu
    wynn
     
  5. Meatwad

    Meatwad Aktives Mitglied

    Registriert seit:
    1 Sep. 2006
    Beiträge:
    1,587
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    soviel wie die netzwerkkarte (100MBit/s) bzw die festplatte (bis 70MB/s) hergibt. halt immer das schwächste glied in der kette.

    bei wlan muss man halt aufpassen, wenn alles verkabelt ist sollte es eigentlcih keine probleme geben. höchstens mit der hardware in der box. aber dazu kann ich jetzt nichts genaueres sagen
     
  6. locodriver

    locodriver Neuer User

    Registriert seit:
    4 März 2007
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    s. Nick
    Ort:
    04451
    Streaming von NAS nach STB über WLAN noch nicht optimal

    Habe heute das Update aufgespielt - funzt einwandfrei. Dank an NEELIXthomas!

    Im Player will ich die Videos meiner NAS ansehen.
    Die ersten Versuche waren ziemlich ernüchternd. Dann habe ich in den Einstellungen des Players den Bufferingwert wie im Forum beschrieben von 2400 auf 15000 erhöht. Die Aussetzer waren dann nicht so oft, aber irgendwann holt die Wiedergabe den Pufferspeicher ein und dann ruckelt das Bild wieder.
    Wie weit kann man den Puffer vergößern, um einen Zweistundenfilm ohne Aussetzer sehen zu können? Könnte man einen solchen Puffer auf eine zweite Part. auf der SD-Card legen und während des Pufferladens einen "Wartebildschirm" anzeigen, damit Frau und Kind (als Normalnutzer) nicht stutzig werden, wenn die Wiedergabe noch nicht gleich startet?

    Ich habe mal verschiedene MPEG-Formate mit dem Benchmark des Players getestet (Aufnahmen mit WinDVD auf NAS gemacht - Bild am PC ruckelte z.T. stark, aber Aufnahmen waren o.k.):
    - 1/2 DVD (352*576, Audio 224, Video 5530) -> Geschw. 99,9%, Datenrate 4,1 Mbit/s,
    - PC-Auflösung (640*576, Audio 224, Video 11859) -> Geschw. 44%, Datenrate 3,8 Mbit/s
    Eigentlich müsste die halbe DVD-Auflösung fast ohne Ruckeln laufen (war aber noch zu oft), da sie fast 100% Geschwindigkeit erreicht. Oder man nimmt wohl noch eine etwas geringere Auflösung, aber ob das Ansehen dann noch Spass macht?

    Mein WLAN hat sehr guten oder excellenten Empfang lt. Systeminfos.

    Kann man das Streaming verbessern, indem man eine zweite Fritzbox als Repeater in das WLAN einbindet und die STB an diese zweite Fritzbox per LAN anschliesst?
    Wer hat damit schon Erfahrungen gesammelt?

    Uwe