[Problem] Agfeo ES516 mit ASIP-Systemtelefonen: Gesprächsabbrüche extern und intern

Snoere

Neuer User
Mitglied seit
20 Apr 2005
Beiträge
22
Punkte für Reaktionen
0
Punkte
1
Hallo zusammen,
in einer Arztpraxis läuft eine Agfeo ES516 mit Systemtelefonen. Die Praxis ist täglich immer wieder für einige Minuten nicht erreichbar. Gespräche brechen ab oder Rufe (eingehend und ausgehend) kommen nicht durch. Auch bei internen Gesprächen gibt es immer wieder Abbrüche und mehrminütige Blockaden.

Leider haben wir hier eine sehr ungünstige IT-Situation: der TK-Dienstleister ist eine absolute Pfeife* (mehr dazu in der Fussnote). Die Spezialisten für die ganze Praxis-IT (Software, Telematik etc) haben wieder von der TK-Anlage keine Ahnung und empfehlen nur Stargate.
Leider hat sich schon das Finden eines alternativen Dienstleisters als Problem heraus gestellt. Die offiziellen Agfeo Partner in der Stadt und Umgebung sind traditionelle Elektriker ohne tiefergehende Netzwerk-Erfahrung. Das scheint mir in unserem Fall ziemlich sinnlos zu sein. Ein Mitarbeiter des lokal wohl kompetenteste TK-Spezialisten mit Netzwerk-Kompetenz weigert sich derzeit den Auftrag anzunehmen und will, dass die TK-Anlage ein eigenes Netz bekommt.
Soweit so schlecht auf der Dienstleister Seite.

Dazu kommt ein sehr komplexes Setup: Telekom All-IP an Fritzbox 7590 -> Sophos XG 115 -> Agfeo ES516.
Die FB wird nur als DSL-Zugang genutzt, die Sophos schützt die Praxis IT.

Meine Rolle ist es eine Lösung für das Chaos zu finden und als "technik-sprechender" Mensch zwischen Null-Ahnung Anwendern und den Dienstleistern zu vermitteln bzw. zu koordinieren. Oder selbst eine Lösung zu finden.

Was ich bisher versucht habe:
  • Protokolle der FB kontrolliert: es gibt keine DSL- oder System-Probleme
  • Sophos als "exposed Host" in der FB eingetragen, zusätzlich auf Grund des Port-Bugs der Fritzbox die SIP-Ports zusätzlich weiter geleitet.
  • IP v6 deaktiviert - just in case...
  • Kontrolliert, ob in der FB Telefonnummern bzw. Telefonfunktionen aktiv sind.
  • Laut dem IT-Service ist die Agfeo in der Sophos komplett frei gegeben
  • Die Agfeo und die Systemtelefone sind auf dem aktuellen Firmware-Stand

  • Ich kenne mich mit Agfeo nicht aus und kann mich aus Zeitgründen nicht tief einarbeiten. Bei der Durchsicht der Konfiguration ist mir aufgefallen, dass die Systemtelefone über IP angebunden sind, aber es eine ISDN-Konfiguration gibt. Ist das so etwas wie ISDN-über-IP oder gehört die ISDN-Konfig raus? (siehe Anhang)
  • Kann man die obige Router-Kaskade sinnvoll zum Laufen bekommen oder ist das von vornherein zum Scheitern verurteilt? Welche alternativen Konfigurationen würdet ihr empfehlen?
  • Da nicht nur die extern Rufe betroffen sind: Was kann die Ursache sein?
  • Ideen was ich noch prüfen oder verändern kann?
Ich freue mich über alle Hinweise, da der Leidensdruck in der Praxis sehr groß ist.

--------------

* Anekdotisch: Ein paar der besonders tollen Aussagen des derzeitigen TK-"Spezialisten"
  • "Notfall? Rufen Sie mich um 9 Uhr nochmals an. Ich gehe erstmal frühstücken."
  • "Ihre Ausfälle liegen sicherlich an den Temperaturen, die Anlage wird zu warm" - Im TK-Schrank sind aber keine hohen Temperaturen, da wird nix wirklich warm...
  • "Ich kann nur bei schlechtem Wetter zu Ihnen kommen. Ich decke gerade mein Dach"
 

Anhänge

  • Geräte- + Anschlusseinstellungen (upload).png
    Geräte- + Anschlusseinstellungen (upload).png
    147.4 KB · Aufrufe: 9
  • Hardware Einstellungen 2021-11-16_15h36_44.png
    Hardware Einstellungen 2021-11-16_15h36_44.png
    46.8 KB · Aufrufe: 9
  • ISDN-Leitungen (upload).png
    ISDN-Leitungen (upload).png
    68.2 KB · Aufrufe: 8
  • VOIP Einstellungen 2021-11-16_15h36_01.png
    VOIP Einstellungen 2021-11-16_15h36_01.png
    47.4 KB · Aufrufe: 9
Zuletzt bearbeitet:

sunnyman

Mitglied
Mitglied seit
13 Jan 2006
Beiträge
697
Punkte für Reaktionen
71
Punkte
28
Hallo zusammen,
in einer Arztpraxis läuft eine Agfeo ES516 mit Systemtelefonen. Die Praxis ist täglich immer wieder für einige Minuten nicht erreichbar. Gespräche brechen ab oder Rufe (eingehend und ausgehend) kommen nicht durch. Auch bei internen Gesprächen gibt es immer wieder Abbrüche und mehrminütige Blockaden.
Mein dringender Rat: Sorge für einen Router, der keine Magie macht und für den geschäftlichen Einsatz vorgesehen ist, z. B. Lancom, Mikrotik, whatever.

Leider haben wir hier eine sehr ungünstige IT-Situation: der TK-Dienstleister ist eine absolute Pfeife* (mehr dazu in der Fussnote). Die Spezialisten für die ganze Praxis-IT (Software, Telematik etc) haben wieder von der TK-Anlage keine Ahnung und empfehlen nur Stargate.
Leider hat sich schon das Finden eines alternativen Dienstleisters als Problem heraus gestellt. Die offiziellen Agfeo Partner in der Stadt und Umgebung sind traditionelle Elektriker ohne tiefergehende Netzwerk-Erfahrung. Das scheint mir in unserem Fall ziemlich sinnlos zu sein. Ein Mitarbeiter des lokal wohl kompetenteste TK-Spezialisten mit Netzwerk-Kompetenz weigert sich derzeit den Auftrag anzunehmen und will, dass die TK-Anlage ein eigenes Netz bekommt.
Ist eine durchaus berechtigte Forderung und aber auch schnell gemacht. VLAN-fähiger Switch und fertig.
Dazu kommt ein sehr komplexes Setup: Telekom All-IP an Fritzbox 7590 -> Sophos XG 115 -> Agfeo ES516.
Ähm, nein. Das ist überhaupt nicht komplex sondern absoluter Alltag :)
Aber auch hier würde ich dringend von einer FaceTube-Plasteschachtel abraten die professionellem Equipment vorgesetzt wird.
Die FB wird nur als DSL-Zugang genutzt, die Sophos schützt die Praxis IT.
Wie du weiter unten schreibst, stimmt das so ja nicht. Die Fritzbox hat ihre eigene, nicht abschaltbare Firewall und auch grundsätzlich ihre eigenen Ideen, was mit SIP-Traffic zu geschehen hat. Dazu kommen noch tolle Features wie Smart Home, die selbst im abgeschalteten Zustand ständig Broadcast-Pakete ins Netz brüllen.
In einem professionellen Router könnte man das alles abschalten und man könnte sich drauf verlassen dass es auch wirklich aus ist.

Kann die Sophos nicht einfach direkt PPPoE machen? Dann Vigor DSL-Modem dran und weg mit der Fritzbox.
Meine Rolle ist es eine Lösung für das Chaos zu finden und als "technik-sprechender" Mensch zwischen Null-Ahnung Anwendern und den Dienstleistern zu vermitteln bzw. zu koordinieren. Oder selbst eine Lösung zu finden.

Was ich bisher versucht habe:
  • Protokolle der FB kontrolliert: es gibt keine DSL- oder System-Probleme
Muss nichts heißen.
Muss nicht funktionieren.
  • IP v6 deaktiviert - just in case...
*seufz*
  • Kontrolliert, ob in der FB Telefonnummern bzw. Telefonfunktionen aktiv sind.
Das muss nicht heißen dass sie nicht trotzdem in den Verkehr auf 5060 eingreift, NAT macht hier viel Spaß.
  • Die Agfeo und die Systemtelefone sind auf dem aktuellen Firmware-Stand

  • Ich kenne mich mit Agfeo nicht aus und kann mich aus Zeitgründen nicht tief einarbeiten. Bei der Durchsicht der Konfiguration ist mir aufgefallen, dass die Systemtelefone über IP angebunden sind, aber es eine ISDN-Konfiguration gibt. Ist das so etwas wie ISDN-über-IP oder gehört die ISDN-Konfig raus? (siehe Anhang)
  • Kann man die obige Router-Kaskade sinnvoll zum Laufen bekommen oder ist das von vornherein zum Scheitern verurteilt? Welche alternativen Konfigurationen würdet ihr empfehlen?
  • Da nicht nur die extern Rufe betroffen sind: Was kann die Ursache sein?
  • Ideen was ich noch prüfen oder verändern kann?
Ich freue mich über alle Hinweise, da der Leidensdruck in der Praxis sehr groß ist.
Getreu dem Motto "Wenn du Hufe hörst, denk an Pferde, nicht an Zebras!": Fang bei den einfachsten Dingen an.
Tausche bspw. auf Verdacht mal die kritischen Patchkabel.
Prüfe die Verkabelung im Rack resp. Dosen, ggf. alle Verdrahtungen die komisch aussehen nachtackern.
Ansonsten muss herausgefunden werden, was genau eigentlich passiert. Wenn die Störungen auch intern auftreten, sollten Firewall und Fritzbox erstmal nicht der Grund sein.
Möglicherweise hat die Agfeo "einen Hau weg" und startet immer wieder durch? -> Kauf eine Ersatzanlage und setze die testweise ein. Wenn die nicht der Grund ist, kann man die meist +/- 0 wieder verticken.
Generell könnt's aber auch helfen auf Verdacht mal das Netzteil zu tauschen.

Wie sieht die Switch-Situation aus? Billig-Switche oder schlicht defekte Switche oder eine Kombination aus verschiedenen Herstellern die einfach nicht zusammen wollen kann auch zu bizarren Effekten im Netzwerk führen.

Du musst erstmal sehen den Fehler möglichst genau einzugrenzen, am besten wäre es natürlich, wenn du ihn gut provozieren kannst. Ansonsten: tracen, tracen, tracen. Ich würde mich zwischen die Agfeo und das Netz hängen, ggf. per Switch mit Port Mirroring. Und parallel dazu vielleicht dauerhaft pingen und das ebenfalls mit aufzeichnen.
Ein managed Switch würde z. B. auch Link Loss protokollieren, damit kann man auch gut herausfinden ob sie die Agfeo (oder andere Komponenten) einfach mal "ausklinken".

Wo registriert sich die Agfeo denn? Direkt bei der Telekom oder läuft das über die Fritzbox? Ich nehme an, die Agfeo macht SIP und nicht S0?

Wo sitzt der Kunde denn (PLZ-Bereich)? Vielleicht gibts ja hier ja jemanden der nicht allzu weit weg ist.

Ansonsten auch mal direkt Agfeo kontaktieren, vielleicht können sie auch noch einen Spezialisten vermitteln.
 

sawlling

Neuer User
Mitglied seit
13 Feb 2019
Beiträge
78
Punkte für Reaktionen
8
Punkte
8
Dazu kommt ein sehr komplexes Setup: Telekom All-IP an Fritzbox 7590 -> Sophos XG 115 -> Agfeo ES516.
Die FB wird nur als DSL-Zugang genutzt, die Sophos schützt die Praxis IT.

Meine Rolle ist es eine Lösung für das Chaos zu finden und als "technik-sprechender" Mensch zwischen Null-Ahnung Anwendern und den Dienstleistern zu vermitteln bzw. zu koordinieren. Oder selbst eine Lösung zu finden.

Was ich bisher versucht habe:
  • Protokolle der FB kontrolliert: es gibt keine DSL- oder System-Probleme
  • Sophos als "exposed Host" in der FB eingetragen, zusätzlich auf Grund des Port-Bugs der Fritzbox die SIP-Ports zusätzlich weiter geleitet.
  • IP v6 deaktiviert - just in case...
  • Kontrolliert, ob in der FB Telefonnummern bzw. Telefonfunktionen aktiv sind.
  • Laut dem IT-Service ist die Agfeo in der Sophos komplett frei gegeben
  • Die Agfeo und die Systemtelefone sind auf dem aktuellen Firmware-Stand

  • Ich kenne mich mit Agfeo nicht aus und kann mich aus Zeitgründen nicht tief einarbeiten. Bei der Durchsicht der Konfiguration ist mir aufgefallen, dass die Systemtelefone über IP angebunden sind, aber es eine ISDN-Konfiguration gibt. Ist das so etwas wie ISDN-über-IP oder gehört die ISDN-Konfig raus? (siehe Anhang)
  • Kann man die obige Router-Kaskade sinnvoll zum Laufen bekommen oder ist das von vornherein zum Scheitern verurteilt? Welche alternativen Konfigurationen würdet ihr empfehlen?
  • Da nicht nur die extern Rufe betroffen sind: Was kann die Ursache sein?
  • Ideen was ich noch prüfen oder verändern kann?
Ich freue mich über alle Hinweise, da der Leidensdruck in der Praxis sehr groß ist.


Moin Snoere,

Der Aufbau FritzBox -> Sophos -> Internes Netz ist durchaus üblich. Ich habe erstmal nichts gegen so eine FritzBox, es gibt aber grade für Arztpraxen viele Voraussetzungen. So sagte mir ein CGM/Turbomed-Mitarbeiter mal, dass nur Lancom zertifiziert sei für den Praxisbetrieb. Ob das stimmt und ob das sinnvoll ist, sei dahin gestellt.
Exposed Host mache ich grundsätzlich immer, ist aber auch nicht unbedingt nötig.

Hast du vielleicht einfach IP-Adress Konflikte? Gibt es entsprechende Reservierungen für TK Anlage und Telefone.

Klick in der Agfeo mal auf auf "SIP-Konten" unterhalb von PROVIDER-DATEN
Wenn dort was eingetragen ist, müsste man nur unter "Rufe von Extern" kontrollieren, ob die ES die ISDN Ports "abhorcht". Wahlweise kannst du mal den Deckel aufmachen und schauen, ob etwas an den S0-Ports angeschlossen ist. Da kommen aber noch etliche Variablen dazu... hat die Praxis evtl neben der FritzBox noch andere Geräte die per ISDN angeschlossen sein könnten? -> Bspw einen alten NTBA oder eine Digibox...
Grade wenn alt-Verträge noch laufen, man aber nicht auf die Nummer, respektive auf die Sprachkanäle verzichten möchte, ist das ein Konstrukt, was man auch immer wieder sieht.

Wie hast du denn, ohne Ahnung von Agfeo zu haben, kontrolliert, ob die Firmware aktuell ist? Bzw, was ist denn der Stand?

Wie äußern sich die Abbrüche? Starten die Telefone neu? Zeigen die noch das laufende Gespräch im Display, aber man hört nix mehr? Werden vielleicht Headsets verwendet und es sind einfach nur die Batterien leer?

Ansonsten vielleicht mal die Verkabelung prüfen.. .woher ziehen die Systemtelefone ihren Strom? POE Injektoren? POE Switch? Dort vielleicht mal Gegentauschen.

Wie @sunnyman schrieb, eine Austausch-Anlage kaufen ist zwar ein guter Ansatz, jedoch ist die 516 abgekündigt. Es wird also nur Restbestände oder gebrauchte Anlagen geben. Agfeo selbst hält nur Anlagen für RMA Anfragen vor. Man könnte dazu allerdings mal im Log der Agfeo schauen. Auch auf den Telefonen erscheint ein entsprechender Text während eines Neustarts... vorausgesetzt es handelt sich um Agfeo Systemtelefone.

Viele Grüße aus Flensburg,

Sawlling
 

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
4,023
Punkte für Reaktionen
392
Punkte
83
Auch bei internen Gesprächen gibt es immer wieder Abbrüche und mehrminütige Blockaden.
Auch wenn Du vor Ort bist oder im alltäglichen Betrieb? In Arzt-Praxen passieren gerne auch große Uploads in Form von Röntgenbildern und Patienten-Akten. Wenn dann Sprache (RTP) nicht bevorzugt (priorisiert) wird, bleiben die RTP-Pakete lokal auf der Strecke. Kann gut sein, dass die XG115 oder der genutzte Switch dahinter die Systemtelefonie der AGFEO nicht automatisch richtig als Sprache erkennt. Das nennt sich QoS. Ist im Detail super kompliziert und vermutlich die Ursache, warum der eine Dienstleister ein „eigenes Netz“ haben möchte.

Wenn Du die Situation gezielt auslösen kannst oder die Erlaubnis hast mal einen ganzen Tag mitzuschneiden, können wir Dir helfen das aufzubauen bzw. die Mitschnitte dann auszuwerten.
Die Praxis ist täglich immer wieder für einige Minuten nicht erreichbar.
Man müsste diesen Moment abpassen und den Daten-Verkehr mitschneiden, also ob die SIP-INVITE auf dem WAN der FRITZ!Box ankommen (normalerweise ist das die Schnittstelle „1. Internetzugang“). Und dann was mit dem SIP-INVITE passiert, also im LAN der FRITZ!Box bzw. WAN der Sophos. Im LAN der Sophos und im WAN der AGFEO. Kann auch sein, dass Ihr Eure maximale Anzahl an Telefonverbindungen in dem Moment aufgebraucht habt.

Wie Du siehst, kann die Ursache alles Unmögliche sein. Es können auch mehrere, verschiedene Fehler mit ganz anderen Ursachen sein. Spricht was Großes dagegen, dass der neue Dienstleister anfangen darf?
Welche alternativen Konfigurationen würdet ihr [probieren]?
a) AGFEO nicht direkt bei der Telekom Deutschland sondern als „IP-Telefon(e)“ in der FRITZ!Box registrieren. Die FRITZ!Box bei Telekom Deutschland als Telefonie-Anbieter anmelden, also die Telefonie-Ebene. Vorsicht: Anzahl gleichzeitiger Leitungen.
oder
b) AGFEO nicht direkt bei der Telekom Deutschland sondern als „ISDN-Telefon“ in der FRITZ!Box anschließen. Die FRITZ!Box bei Telekom Deutschland als Telefonie-Anbieter anmelden, also die Telefonie-Ebene. Vorsicht: Anzahl gleichzeitiger Leitungen.
oder
c) AGFEO nicht hinter die Sophos sondern direkt an die FRITZ!Box anschließen, also die Ethernet-Ebene. Voricht: Das dürfte für Dich nicht so einfach sein, weil vermutlich die Systemtelefone keine eigenen Ethernet-Kabel bzw. eigenes VLAN haben.
oder
d) Wie sunnyman schrieb die FRITZ!Box durch ein reines DSL-Modem ersetzen und allein die Sophos machen lassen, also die Router-Ebene.
oder
e) Sophos rauswerfen, also die Router-Ebene

Die Alternativen A bis E kannst Du zum Test machen, also neben den Öffnungszeiten umstecken, umkonfigurieren und testen. Was Du auch testen kannst, ob wie von sunnyman das NAT-Binding irgendwo zu früh zugeht: Das kannst Du sogar erstmal von einem normalen Computer aus dem Intranet heraus testen, siehe diesen Post …
ADSL, Vectoring oder Super-Vectoring?
Wann ging denn das los, weiß das die Belegschaft noch in etwa? Vielleicht lässt sich so ein Zusammenhang finden.
 

sunnyman

Mitglied
Mitglied seit
13 Jan 2006
Beiträge
697
Punkte für Reaktionen
71
Punkte
28
a) AGFEO nicht direkt bei der Telekom Deutschland sondern als „IP-Telefon(e)“ in der FRITZ!Box registrieren. Die FRITZ!Box bei Telekom Deutschland als Telefonie-Anbieter anmelden, also die Telefonie-Ebene. Vorsicht: Anzahl gleichzeitiger Leitungen.
oder
Die Lösung, den VoIP-Datenstrom auf dem Router zu terminieren, ist durchaus generell sinnvoll, um NAT-Schmerzen zu vermeiden. Gerade wenn die Anlage abgekündigt ist, wird ihr SIP-Stack keine Updates mehr bekommen, und so könnte es in den nächsten Jahren passieren, dass sie sich nicht mehr richtig am Amt registieren kann, wenn es da Umstellungen geben sollte.
Insofern könnte es sinnvoll sein, die WAN-seinite Terminierung bei einem Gerät zu machen, das noch mit Updates versorgt wird.
Als professionelle(re)s Gerät würde sich hier ein Lancom aus der VoIP-Serie anbieten.
b) AGFEO nicht direkt bei der Telekom Deutschland sondern als „ISDN-Telefon“ in der FRITZ!Box anschließen. Die FRITZ!Box bei Telekom Deutschland als Telefonie-Anbieter anmelden, also die Telefonie-Ebene. Vorsicht: Anzahl gleichzeitiger Leitungen.
... und Verlust von HD-Telefonie.
 
Zuletzt bearbeitet:

Snoere

Neuer User
Mitglied seit
20 Apr 2005
Beiträge
22
Punkte für Reaktionen
0
Punkte
1
Vielen Dank für den vielen Input. War heute ein sehr langer Tag, daher kann ich gerade nicht auf alles eingehen. Ich schaue mir eure Vorschläge aber alle nochmals in Ruhe durch.

Manches erklärt sich dadurch, dass ich nur als Koordinator tätig werde. So will der IT-Dienstleister nix von einem externen Modem wissen. Die Auswahl der Firewall fällt ebenfalls in seine Zuständigkeit.

Ihr sagt, dass eine solche Kette mit zwei Routern üblich ist, aber für mich klingt das alles unnötig komplex und in manchen eurer Antworten (und diversen Foren-Posts hier) klingt ja schon durch, dass die Fritzbox ein gewisses Eigenleben hat und daher auch einen unberechenbaren Anteil an den Problemen haben kann. Für mich wäre es daher logisch gewesen, keine Router-Kaskade zu betreiben. Aber gut, wenn der Dienstleister nicht will, kann ich das nicht ändern.

Eure Vorschläge in Bezug auf FB als VOIP Endpunkt/VOIP-Provider schaue ich mir noch in Ruhe an.

Beim Netz aufräumen bin ich noch nicht durch. Durch die ganzen Grippe und Corona Impfungen ist in der Praxis gerade Hochbetrieb, da bleiben für mich nur wenige Zeitfenster, um in Ruhe zu arbeiten. Die Anlage steht leider in einem Schrank im Impfzimmer.

Der Einwand zum Firmware Stand der Agfeo ist berechtigt. Bei einem zweiten Blick auf meine Screenshots sehe ich, dass nur bei den ASIP Telefonen "aktuell" angezeigt wird. Bei der Anlage selbst fehlt eine Statusmeldung - das hatte ich falsch in Erinnerung. Auf der Homepage ist der letzte Firmware-Stand ebenfalls nicht zu sehen. Die Firmware ist die 3.0g vom 26.3.21. Das letzte Update war wohl im Juni.

Die Frage, wann es genau mit den Probleme los ging konnte mir niemand mehr beantworten - das war natürlich mein Einstieg gewesen. Ich habe auch nicht herausbekommen, ob auch das Internet betroffen ist. da widersprechen sich die Frauen. Es ist auch schwer, genaue Fehlerbeschreibungen zu bekommen. Ich habe es einmal live erlebt, als die Ärztin zum Empfang rüber rufen wollte und ihr Telefon tot war. Nach einer Wartezeit geht es dann wieder von allein.

Zu den Protokollen:
In den FB Logs sehe ich, dass es keine DSL Abbrüche gibt. Ich sehe auch, ob sich die Box neu startet. Da auch interne Gespräche abbrechen, sehe ich keinen Zusammenhang mit der DSL-Leitung. Die Telekom hat die Leitung wohl schon mehrfach geprüft (gut, die erwischen selten sporadische Fehler).
Anschluss ist VDSL 100. Die Praxis liegt in einem gut ausgebauten Gebiet, Störungen habe ich in der FB nicht erkennen können.

In den Logs der Agfeo ist mir gar nix aufgefallen.

Ich versuche mal mit dem IT-Dienstleiste zu klären, ob sie Mitschnitte machen können oder auf Sophos Ebene noch Diagnose-Möglichkeiten haben.
So, mehr geht heute nicht mehr (und morgen wird es wieder so spät werden, dass ich nur noch ins Bett fallen werde).
 

sawlling

Neuer User
Mitglied seit
13 Feb 2019
Beiträge
78
Punkte für Reaktionen
8
Punkte
8
Firmware: 3.0g

Das sagt schonmal einiges aus. Daraus kann man schließen, das die verwendete ES516 ein Upgrade-Kit verbaut hat. Aktuelle Firmware wäre die 3.2a. Sprachkanäle hast du dadurch 8 Stück zur Verfügung.

Bei den Logs der Agfeo TK muss man aufpassen, man muss im oberen Teil die entsprechenden Werte auswählen. Standart-mäßig sieht, man glaube ich, nur die Anmeldungen auf dem Webinterface. Du müsstest dann auf System bzw. SIP klicken (wenn den SIP nach extern genutzt wird... ist mir aus deiner Antwort leider nicht klar).

Die Sophos kann "Mitschnitte" machen, ob euer Dienstleister diese dann auswerten kann, wäre die andere Frage.
 

sunnyman

Mitglied
Mitglied seit
13 Jan 2006
Beiträge
697
Punkte für Reaktionen
71
Punkte
28
Ihr sagt, dass eine solche Kette mit zwei Routern üblich ist, aber für mich klingt das alles unnötig komplex
Das mag damit zusammenhängen, dass es zwei Geräte sind, die keinen deckungsgleichen Funktionsumfang haben. Genauso gut könnte man ja sagen "Warum hast du denn einen Kugelschreiber UND einen Bleistift dabei? Das ist doch unnötig komplex!"

Fritzbox ein gewisses Eigenleben hat und daher auch einen unberechenbaren Anteil an den Problemen haben kann.
Es fängt allein schon dort an, dass die Fritzbox, insbesondere das betreffende Modell, ausdrücklich für den Privathaushalt gedacht ist.
Dennoch wird gerade die Fritzbox leider sehr gern von ITlern, aber insbesondere von klassischen Telefönern eingesetzt, weil sie so schön einfach zu installieren ist.
Bei nicht-Spielzeug-Setups möchte man eigentlich immer mindestens zwei VLANs haben, nämlich eines für VoIP und eines für den Rest. Da kann man die Fritzbox schon knicken, da sie keine VLANs kann, und, wie gesagt, manche Dinge eben sehr abstrahiert und "endverbraucherfreundlich" löst, wo man sie in einem professionellen Setup gerne aber mal konkret konfigurieren können möchte (bspw. QoS).
Zu den Protokollen:
In den FB Logs sehe ich, dass es keine DSL Abbrüche gibt. Ich sehe auch, ob sich die Box neu startet. Da auch interne Gespräche abbrechen, sehe ich keinen Zusammenhang mit der DSL-Leitung.
So sehe ich das auch. Das Setup in Richtung Amt bietet zwar durchaus Fallstricke, aber da offenbar interne Telefonie auch ausfällt, würde ich auch erstmal "inhäusig" nach Fehlerquellen suchen.

Da es im ersten Ansatz so zu sein scheint, dass Fritzbox und Agfeo nicht neu starten, würde ich tatsächlich wie von @sonyKatze angesprochen mal prüfen ob möglicherweise IP-Adresskonflikte auftreten können. Könnte es z. B. sein, dass im Netz mehrere DHCP-Server aktiv sind (einfachstes Beispiel: Agfeo und Fritzbox) mit überlappenden Adressbereichen? Oder gibt es statisch konfigurierte IP-Adressen, die in DHCP-Adressbereichen liegen?

Ansonsten würde ich mir die Switche(s) und beteiligte Netzwerkdosen zur Brust nehmen. Patchkabel können sehr gut kaputt sein, ohne dass man es ihnen auch nur im geringsten ansehen könnte.
Und so ein einzelner Draht von so nem Patchpanel-Port/Netzwerkdose, der nicht mehr so 100%ig ist oder sich gar ab und an mit einer anderen Ader kurzschließt, kann ebenfalls tolle Effekte erzeugen.

Und es wäre immer noch gut, wenn du uns verrätst, wo du dich bzw. der Arzt sich befindet, vielleicht lässt sich ja noch was vermitteln.
 
Zuletzt bearbeitet:

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
4,023
Punkte für Reaktionen
392
Punkte
83
Zu den Protokollen …
Nur damit kein Missverständnis entstand. Ich meinte mit Mitschnitten dies … wenn Du zwischen Sophos und AGFEO mitschneiden willst, bietet sich die von sunnyman erwähnte Lösung an: konfigurierbarer Switch und in dem Port-Mirroring aktivieren. So kannst Du live bzw. laufend mitschneiden, ohne irgendwas am Netz umstellen zu müssen; lediglich während dem Mitschnitt die Kabel umstecken und ein Computer muss mitlaufen.
wann es genau mit den Probleme los ging konnte mir niemand mehr beantworten
Das ist gar nicht so negativ, denn es bedeutet normalerweise, dass es schon mal lief bzw. keine große Änderung in Zusammenhang gebracht wird (Umstellung auf All-IP oder ging noch nie, etc.). Dann würde auch ich erstmal die Hardware anschauen, also zum Beispiel jedes Telefon in die Hand nehmen und kurz am Ethernet-Kabel ziehen. Genau so bei AVM, Sophos und Switch an jedem Ethernet-Kabel kurz ziehen. Manchmal gehen versehentlich an den Westernsteckern der Wiederhaken kaputt (lasch oder bricht gang ab). Dann meinst man zwar das Kabel steckt, aber in Wirklichkeit hat es einen Wackler. Vielleicht hat auch irgendwer beim Putzen versehentlich ein Ethernet-Kabel falsch eingesteckt und ein Switching-Loop erzeugt … ansonsten das was sunnyman schrieb, ob vielleicht irgendwo eine Ethernet-Leitung aufgescheuert ist. Wenn die Verkabelung zu versteckt ist, kann das auch manch konfigurierbarer Switch testen.
 

Snoere

Neuer User
Mitglied seit
20 Apr 2005
Beiträge
22
Punkte für Reaktionen
0
Punkte
1
Nochmals vielen Dank für die vielen konstruktiven Rückmeldungen hier. Ich bin gerade arbeitsmäßig völlig auf Anschlag, deshalb hatte ich noch keine Zeit zur Rückmeldung und kann jetzt auch nicht im Detail auf eure Rückmeldung eingehen. Ich habe mir aber alles durchgelesen und

Da es oben als Vorschlag kam, habe ich habe vor kurzem einen Großteil der IT "aufgeräumt": Geräte ordentlich aufgehängt, Kabel zur TK ersetzt, die TK testweise auf den Hauptswitch gelegt und mir einen Überblick über den gesamten Aufbau verschafft. Die ganze TK hing an einem Consumer-Switch (GS108) und der Switch war mit einem billigen Flachband-Netzwerkkabel verbunden. Im Empfang hat irgendein helles Licht die LAN-Kabel mit einer Kupplung verlängert - das konnte ich mangels Material und Zeit nicht lösen. Da die Agfeo in einem anderen Raum steht und auch die Telefone in den Behandlungszimmern betroffen sind, scheinen die Kupplungen als Fehlerquelle auszuscheiden.
Leider haben die bisherigen Maßnahmen keine Besserung gebracht. Der GS108 sowie die Patchkabel zur Agfeo waren nicht verantwortlich. Es kommt immer noch zu mehrminütigen Ausfällen, sowohl intern, als auch nach/von extern. Jetzt könnte der zentrale Switch (HP, leider das Modell nicht notiert) Aussetzer haben, aber dann müsste die ganze IT betroffen sein. QoS-Probleme würde ich derzeit ausschließen. Die Praxis scheint nach meinem bisherigen Kenntnisstand, keine großen Datenmengen zu bewegen. So bleibt für mich der Verdacht, dass die Agfeo nicht mehr richtig funktioniert.
Leider komme ich hier nur sehr langsam weiter, weil die Praxis gerade mit Impfungen völlig ausgelastet ist und die TK-Anlage leider im Impfzimmer steht. D.h. es ist recht schwierig einen Zeitpunkt zu finden, an dem ich dort rein kann.

Da es gefragt wurde: Die Praxis sitzt in Tübingen. Soweit ich sehe, gibt es hier nur eine Firma, die TK macht und gleichzeitig Netzwerkerfahrung hat. Und diese Firma wollte bisher den Auftrag nicht übernehmen. Aber wenn ihr zuverlässig Partner im Raum Tübingen kennt, freue ich mich über Tipps..
 

ip-phoneforum72

Mitglied
Mitglied seit
31 Okt 2020
Beiträge
204
Punkte für Reaktionen
22
Punkte
18
Da du ja irgendwie nichtmal recht weiterkommen möchtest (keine umfassende Fehlerbeschreibung, kein Netzwerkmitschnitt etc) und der liebe Doktor ja anscheinend auch durchaus weiterhin bereit ist Geld auszugeben (resp. Deine erfolglosen Versuche bezahlt), mache es dir erstmal einfach:

rüste die Agfeo auf die aktuellste FirmwareVersion nach und sorge somit dafür, dass du da wieder auch vom Hersteller vernünftigen Support einfordern kannst.

danach dann bitte eine ausführliche Beschreibung dessen, was genau wie nicht geht und einen Netzwerkmitschnitt (auf der Agfeo) machen.

und, denke daran, dass die Agfeo auf der Webseite nur arg einfache Ereignisse protokolliert.

die ausführlichen Logs sind nur im Backup vorhanden (sofern mitgesichert).

ich würde auch mal testweise für ein paar Tage die Agfeo einfach mal aus dem Sophos Netz nehmen und nur an die FritzBox hängen. Dann siehst du recht schnell, ob’s von der Sophos kommt.

In jedem Fall dann keine (!) Portweiterleitungen zur Agfeo einrichten.

Ansonsten wird’s, ehrliche Empfehlung, vermutlich auch „in zig Tagen“ nichts.

R.

pS: in einer deine Screenshots ist der ISDN Anachluss (das Symbol) „ausgegraut“. Somit ist der gar nicht mehr aktiv. Ist an dem Port denn überhaupt noch ein Anschlusskabel angeschlossen? Abziehen!
 
Zuletzt bearbeitet:
  • Like
Reaktionen: sunnyman

Snoere

Neuer User
Mitglied seit
20 Apr 2005
Beiträge
22
Punkte für Reaktionen
0
Punkte
1
Da du ja irgendwie nichtmal recht weiterkommen möchtest
Klar, deshalb schreibe ich ja hier... :)
(keine umfassende Fehlerbeschreibung, kein Netzwerkmitschnitt etc)
Zu den Fehlerbeschreibungen habe ich etwas geschrieben. Mehr kann ich nicht sagen. Ich war noch nie persönlich beim Ausfall dabei.
Zu den Netzwerkmitschnitten: Ich habe erst einmal mit den Basics angefangen. In meinen Augen macht es keinen Sinn Aufwand zu betreiben, wenn die Basis noch nicht stimmt. Zuerst ging es mal darum auf der untersten Ebene aufzuräumen und einen Überblick zu bekommen. Und alleine das war schon zeitaufwändig. Immerhin gibt es jetzt keine übereinandergestapelten Switches und Geräte mehr und der Switch im Empfang hängt auch nicht mehr an den zu kurzen Kabeln in der Luft...
und der liebe Doktor ja anscheinend auch durchaus weiterhin bereit ist Geld auszugeben (resp. Deine erfolglosen Versuche bezahlt),
Wie schon geschrieben: Ich versuche eigentlich qualifizierte Spezialisten zu finden und springe nur ein, bis wir jemand gefunden haben. Außerdem hatte von den (durchaus kompetenten) Profis niemand Zeit und Lust sich um die Basics zu kümmern. Deren Vor-Ort Termine sind sehr eng getaktet.
mache es dir erstmal einfach:

rüste die Agfeo auf die aktuellste FirmwareVersion nach und sorge somit dafür, dass du da wieder auch vom Hersteller vernünftigen Support einfordern kannst.
In der Anlage ist der extrem unwillige Verkäufer der Anlage als Servicepartner hinterlegt. Die herunterladbare Firmware ist alt. Neue Versionen gibt es für "Normalos" nicht. Die verfügbare Firmware ist von 2020 und daneben steht deutlich:
Die aktuelle Firmware erhalten Sie über Ihren qualifizierten AGFEO Fachhändler!

danach dann bitte eine ausführliche Beschreibung dessen, was genau wie nicht geht und einen Netzwerkmitschnitt (auf der Agfeo) machen.
Bisher habe ich nur die Rückmeldung "Gespräche brechen ab, keine internen Gespräche möglich, Patienten kommen nicht durch". Es mit bisher leider nicht gelungen, den Mitarbeiterinnen genauere Beschreibungen zu entlocken. Ich habe es ein paar Mal versucht. Sobald das Telefon weg ist bricht bei denen Stress aus.

und, denke daran, dass die Agfeo auf der Webseite nur arg einfache Ereignisse protokolliert.

die ausführlichen Logs sind nur im Backup vorhanden (sofern mitgesichert).
Ah, danke. Ich bin - wie schon gesagt - kein Agfeo Spezialist und will es eigentlich auch nicht werden. Ich schau mir das beim nächsten Mal nochmals an.
ich würde auch mal testweise für ein paar Tage die Agfeo einfach mal aus dem Sophos Netz nehmen und nur an die FritzBox hängen. Dann siehst du recht schnell, ob’s von der Sophos kommt.
Daran habe ich auch schon gedacht. Allerdings ist hinter der Sophos ein anderer IP-Range und es wird TAPI genutzt. Ich frage sie aber nochmals, ob sie nicht testweise auf TAPI verzichten können. Wie gesagt: Die Arbeitsbedingungen sind derzeit durch die ganze Impferei extrem erschwert. Die Arbeitstage sind sehr lang und ich bekomme nur selten einen freien Zeitraum, um an die Anlage ran zu kommen.
In jedem Fall dann keine (!) Portweiterleitungen zur Agfeo einrichten.
Klar, aber danke für den Reminder. ;)
Ansonsten wird’s, ehrliche Empfehlung, vermutlich auch „in zig Tagen“ nichts.
Yep. Da die Anlage gebraucht erworben wurde und der "Servicepartner" keinerlei Hilfe bringt, rate ich auch zu einem Neustart mit einer neuen zuverlässigeren Firma. Allerdings wird es wohl eher auf einen Anlagenwechsel raus laufen. Die bisher angefragten Fachleute hatten keine Lust in die bestehende Geschichte einzusteigen.
pS: in einer deine Screenshots ist der ISDN Anachluss (das Symbol) „ausgegraut“. Somit ist der gar nicht mehr aktiv. Ist an dem Port denn überhaupt noch ein Anschlusskabel angeschlossen? Abziehen!
ISDN ist abgeklemmt.
 

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
4,023
Punkte für Reaktionen
392
Punkte
83
keinen Sinn Aufwand zu betreiben, wenn die Basics noch nicht stimmt
Grummel … viele konfigurierbare Switche bieten über deren Web-Oberfläche bereits ganz gute Diagnose-Werkzeuge. Wenn Du nicht vom Fach bist bzw. noch keine Erfahrung mit dem speziellen Switch hast, kannst Du das daheim im eigenen Netz bereits üben bzw. Szenarien durchspielen (Loop, Kabel-Wackler, …). Das ist das Eine.

Zum Anderen, dem Mitschnitt: Besonders wenn Du das Fehlerbild noch nicht erlebt hast, wäre ein Mitschnitt sinnvoll – der Computer läuft einfach ein paar Tage mit. Ethernet bzw. IP verkraftet wirklich viel.

Daher (lediglich) die empfohlenen Sicht-, Zieh- und Loop-Prüfungen.
Jetzt könnte der zentrale Switch […] Aussetzer haben, aber dann müsste die ganze IT betroffen sein.
Muss nicht. Telefonie ist UDP und Echtzeit. TCP-Verbindungen reparieren sich recht gut. Aber das müsstest Du testen können, indem Du – wie ip-phoneforum72 schrieb – Sophos und Switch umgehest, also direkt die AGFEO umstöpelst.
Consumer-Switch […] billiges Flachband-Netzwerkkabel
Nicht in die Esoterik abgleiten … wie geschildert, Ethernet und IP sind solch robuste Standards, dass man an solchen Dingen nichts festmachen sollte. Was wir, jedenfalls ich, sagen wollte: Die Kabel dürfen nicht aufgewetzt sein und die Western-Stecker müssen noch ihre Nase haben. Auch darf keine Schleife existieren (Loop). Wenn dann überall sauber mindestens Fast-Ethernet ausgehandelt wird, bist Du gut dabei. Ideal wäre natürlich überall Gigabit-Ethernet und sternförmige anstatt verschachtelte, also eine strukturierte Verkabelung. Aber das wäre lediglich ideal … ein solches Fehlen erklärt nicht die von den Nutzern beschriebenen Symptome.
 
Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via