.titleBar { margin-bottom: 5px!important; }

Annatel Frankreich

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von olaf_TT, 3 Jan. 2006.

  1. olaf_TT

    olaf_TT Mitglied

    Registriert seit:
    15 März 2005
    Beiträge:
    302
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Forum,
    ich habe ein Problem mit dem SIP Provider Annatel aus Frankreich.
    Laut dem Asterisk bin ich mit dem Provider registriert es kommt aber immer nur ein besetzt wenn ich die Nummer anrufe. Abgehend funktioniert es ohne Probs. Wenn ich es mit SJPhone teste habe ich das selbe Problem. Mit X-LITE funktioniert es aber...
    Was kann ich hier falsch machen?
    Ein SIP Debug im Asterisk und auch TCPdump zeigt das Annatel den Ruf nicht zum Asterisk signalliesiert.
    Also läuft da schon was bei der Anmeldung falsch... Aber was?

    Danke für Hilfe!
    olaf_TT
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielleicht ein Problem mit der IP? Ist "externip" bzw "externhost" richtig gesetzt? Falls Du "externhost" nutzt, wird dann auch die externe IP richtig aufgelöst (nicht dass Du in der "hosts"-Datei die Domain mit der internen Ip verknüpft hast, oder so). Läuft das Port-Forwarding richtig?
     
  3. olaf_TT

    olaf_TT Mitglied

    Registriert seit:
    15 März 2005
    Beiträge:
    302
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,
    also ich denke das kann nicht das Problem sein, da auf der Maschine noch 7 andere SIP Accounts ohne Probleme kommend und gehend laufen.

    sip.conf:

    [general]
    context=sip-in
    port=5060
    bindaddr=0.0.0.0
    localnet=192.168.125.0/255.255.128.0
    externip=193.24.x.x
    srvlookup=yes
    nat=yes
    language=de
    disallow=all
    allow=ulaw
    allow=alaw
    maxexpirey=180
    defaultexpirey=160
    tos=reliability

    register => 26233170367xxx:xxxxxx@sip.annatel.net/33170367xxx

    [annatel]
    type=friend
    fromuser=26233170367xxx
    username=26233170367xxx
    secret=xxxxxx
    fromdomain=sip.annatel.net
    host=sip.annatel.net
    nat=yes
    canreinvite=no
    disallow=all
    allow=alaw
    context=sip-in
    dtmfmode=rfc2833
    callerid="xxx" <33170367xxx>
    qualify=200


    extensions.conf:

    [sip-in]
    exten => s,1,Wait(0.1)
    exten => s,2,ResponseTimeout(2)
    exten => s,3,WaitExten(1)

    exten=>33170367536,1,Dial(OH323/284@192.168.125.2)

    exten => t,1,Goto(timeout,t,1)
    exten => i,1,Goto(timeout,i,1)


    Sieht doch alles gut aus, oder?

    Gruß
    olaf_TT
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Schau mal mit Sip debug nach, was annatel für Sip-Software einsetzt.
    Ich habe hier massiv Registrierungsprobleme mit Sip EXpress router (0.9.0 (i386/linux).
     
  5. olaf_TT

    olaf_TT Mitglied

    Registriert seit:
    15 März 2005
    Beiträge:
    302
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi kombjuder,
    also sip debug sagt mir:

    Server: Sip EXpress router (0.8.14 (i386/linux))

    Und wie macht sich das Prob bei dir bemerkbar?
    Wie schon geschrieben:
    ein sip show registry sagt mir das ich verbunden bin.
    Abgehend läuft es ja auch nur ankommend ist sofort besetzt...
     
  6. olaf_TT

    olaf_TT Mitglied

    Registriert seit:
    15 März 2005
    Beiträge:
    302
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ES GEHT!!!

    Ich habe "insecure=very" gesetzt und auf einmal lief es...
     
  7. olaf_TT

    olaf_TT Mitglied

    Registriert seit:
    15 März 2005
    Beiträge:
    302
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Aha...
    Hier nochmal die Erklärung:
    (www.voip-info.org)

    Insecure (asterisk 1.0.9 and earlier)

    very: ignore authentication (user/password)
    yes: ??


    Example

    insecure=very

    insecure=yes ; To match a peer based by IP address only and not port
    insecure=very ; To allow registered hosts to call without re-authenticating

    Typically used to allow incoming calls (e.g. from FWD) while having a type=friend entry defined with username and password.
     
  8. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hat sich in der Zwischenzeit in soweit geklärt, dass die eigentliche Ursache * 1.2 ist und dort nicht meht type=friend sondern type=peer eingetragen sein muss. Komischerweise betrifft das bisher nur SipExpress. Andere Providersoft läuft auch mit der Einstellung friend. Ausserdem hat sich insecure= geändert.