.titleBar { margin-bottom: 5px!important; }

Anrufer hört kein Freizeichen bei Anwahl von Festnetznummern

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von What's_up?, 3 Nov. 2004.

  1. What's_up?

    What's_up? Neuer User

    Registriert seit:
    29 Okt. 2004
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0

    HALLO ZUSAMMEN !

    Konfiguration:
    Asterisk in DMZ hinter NAT Router mit fester öffentlichen IP. Telefone und Soft Clients in separatem Netzwerksegment (trusted net). Zwischen den zwei Netzwerksegmenten wird geroutet.

    Problem:
    Wenn ich eine Festnetzrufnummer anwähle, dann bekomme ich dem Anschein nach während des Verbindungsaufbaus am anrufenden Telefon eine Freizeichen signalisiert. Ein Cisco 7960 zeigt im Display in dieser Zeit: „Ringing Destination (in 180)“.
    Direkt daraufhin bekomme ich, wenn der PSTN Call bei der angerufenen Festnetznummer signalisiert wird, die Meldung im Cisco Telefon „Session Progress (in 182)“. Und aus dem anrufenden Telefon kommt solange nichts, bis die Gegenstelle abnimmt oder ein Timout zum Tragen kommt.
    Dies hatte mich in der ersten Euphorie nicht gestört, doch ist das im täglichem Gebrach sehr unpraktisch, weil man doch häufig den Gesprächsanfang verpasst. Zudem ist die User Akzeptanz so sehr gering.

    Komisch – kein Problem bei Mobilfunkrufnummern:
    Wenn ich eine Mobilfunkrufnummer in selber Konstellation anrufe, bleibt der Status auf „Ringing Destination (in 180)“ am anrufenden Telefon und ich bekomme bis zum Connect korrekt ein Freizeichen am anrufenden Telefon signalisiert. Anscheinend kommt das Freizeichen von der Asterisk oder dem Telefon selber, das habe ich noch nicht analysiert.

    Fehlereingrenzung:
    SIP Provider: Selber Effekt bei nikotel, web.de, sipsnip
    Telefone: Selber Effekt, ob Cisco 7960 oder X-Lite
    Rufnummern: Selber Effekt mit allen getesteten deutschen Fest- und Mobilfunkrufnummern
    Firewall / Portforwarding: Wenn ich einen SIP Client im trusted net von der Asterisk auf z.B. nikotel direkt konfiguriere, dann klappt es auch mit der Freizeichensignalisierung einwandfrei. Also kann das an der Firewall, FW Firmware, FW Config oder Portforwarding der Firewall auch nicht liegen.
    Problemverursacher: Da bleibt nur noch die Asterisk


    Frage:
    Welche Parameter in den Config Files der Asterisk beeinflussen dieses Verhalten?
    Da würde ich mich über Input sehr freuen.

    Vielen Dank und viele Grüße
    Dirk
     
  2. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    als Parameter zu dial:
     
  3. What's_up?

    What's_up? Neuer User

    Registriert seit:
    29 Okt. 2004
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi rajo,

    >>passing no audio from the called channel(s) until one answers
    hatte ich zuvor schon gelesen, jedoch nicht die notwendigen Achtung geschenkt.

    Ich habe extensions.conf schnell geändert und siehe da, es geht! :lol:.

    Vielen Dank für Deine Hilfe!

    Dirk