Anrufer hört keinen Klingelton (Telekom All-IP)

mikelm

Neuer User
Mitglied seit
5 Sep 2015
Beiträge
20
Punkte für Reaktionen
0
Punkte
1
Asterisk 16.18.0, FreePBX 15.0.17.55 auf RaspberryPI

Hallo,
ich habe neuerdings das Problem, dass Anrufer keine Klingelton hören, nur absolute Stille.
Ich habe schon verschiedenste Einstellungen probiert, jedoch ohne Erfolg. (Google findet da auch keine eindeutige Lösungen für solche Probleme).
Bei internen Anrufen klingelt es.
Wenn ich in den Inbound Routes Force Answer auf True setze, rauscht es wenigstens beim Anrufer. Mit/ohne Signal RINGING ändert nichts am Verhalten.
Ich leite eingehende Anrufe auf eine Klingelgruppe um, ich hatte aber zum Testen auf eine Nebenstelle umgestellt, auch ohne Erfolg.

Welche Einstellungen sollte ich probieren bzw. wie komme ich dem Problem auf die Schliche?
 

B612

Aktives Mitglied
Mitglied seit
30 Jan 2021
Beiträge
1,806
Punkte für Reaktionen
302
Punkte
83
ich habe neuerdings das Problem, dass Anrufer keine Klingelton hören, nur absolute Stille.
Den Klingelton könnte ein Anrufer auch nur dann hören wenn er in der Nähe des angerufenen Telefon(anschlusses) wäre. Ich vermute du meinst der Anrufer hört keinen Freiton?
 
Zuletzt bearbeitet:

mikelm

Neuer User
Mitglied seit
5 Sep 2015
Beiträge
20
Punkte für Reaktionen
0
Punkte
1
Ja, der Ton, wenn nicht besetzt ist.
 

B612

Aktives Mitglied
Mitglied seit
30 Jan 2021
Beiträge
1,806
Punkte für Reaktionen
302
Punkte
83
Zuletzt bearbeitet:

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
27,021
Punkte für Reaktionen
732
Punkte
113
Womit hat es denn funktioniert, bevor du das Problem hattest?
 

gehtdoch

Mitglied
Mitglied seit
3 Feb 2019
Beiträge
267
Punkte für Reaktionen
21
Punkte
18
Wie sonyKatze schon geschrieben hat - das solltest Du genauer analysieren, um sicherzustellen, wo das Problem konkret liegt. Ein Trace (hier mit sngrep als Beispiel für den eingehenden Callleg eines etwas längeren Gesprächs mit pjsip als aktuelle Referenz für einen einfachen eingehenden Telekom ALL-IP Call (bei anderen Providern oder auch nur chan_sip sieht das teilweise anders aus - aber der hier relevante, eingerahmte Punkt sollte gleich sein - der jeweils konkrete Call-Flow ist auch abhängig von der Gegenstelle - da kann auch mal ein 183 mit im Boot sein - 0.0.0.0 beduetet übrigens Asterisk als Server)):

inbound-call.png

Ich kann mich dumpf daran erinnern, dass ich zu chan_sip Zeiten dieses Problem auch mal hatte (in speziellen Konstellationen - z.B. in Verbindung mit Follow me oder Klingelgruppe). In den Inbound-Routes musste unter erweitert "Signal ringing" aktiviert werden. Ist im Zusammenhang mit pjsip in den genannten Konstellationen aber nicht mehr nötig. Du kannst auch versuchen, für die betroffene Nebenstelle bei den Dial Options noch ein "r" dazu zumachen.

Das alles setzt natürlich voraus, dass die sonstige Konfiguration korrekt ist und auch netzwerktechnisch keine Fehler vorliegen.

Es gibt da auch noch ein anderes bekanntes Problem mit dem Ringback bei ausgehenden Calls (das heißt, man hört selbst kein Freizeichen, obwohl es beim Angerufenen klingelt). Hier ist das Problem, dass in manchen Fällen vom Angerufenen nur ein 183 ohne SDP kommt, womit Asterisk per default nicht korrekt umgeht. Bsp. hierfür:

outbound-call.png
[Edit Novize: Riesenbilder gemäß der Forumsregeln auf Vorschau verkleinert]

Hier kommt glücklicherweise noch ein 180 Ringing hinterher (das war bzw. ist evtl. aber nicht immer so - da kann man sich nicht darauf verlassen). Daher gibt es einen zusätzlichen pjsip-Switch in Asterisk, ignore_183_without_sdp (weitere Erläuterungen siehe hier). Der funktioniert aber nur, wenn hinterher tatsächlich noch das 180 Ringing kommt. Ich für mich habe da einen eigenen Patch, der aus dem 183 ohne SDP ein 180 Ringing macht - das ist die sichere Variante.
 
Zuletzt bearbeitet von einem Moderator:

mikelm

Neuer User
Mitglied seit
5 Sep 2015
Beiträge
20
Punkte für Reaktionen
0
Punkte
1
Hallo,

es gab ja Antworten. (Anscheinend habe ich die Benachrichtigung übersehen).
Ich habe zwischenzeitlich Inband Progress auf "Nein" gesetzt, alles ohne Auswirkungen.

Eine neue Erkenntnis habe ich: Anscheinend hängt das fehlende Freizeichen mit den Rufgruppen zusammen. Rufe ich eine Nebenstelle direkt an, kommt das Freizeichen. (komisch, das hatte ich vor einiger Zeit schon einmal getestet) Beim Anrufen einer Rufgruppe mit dem Handy kommt das Freizeichen nicht.

Und noch eine Besonderheit: Wenn ich vom eigenen Voip Anschluss mich selber anrufe (also vom Voip Anschluss die eigene Nummer (mit Ortsvorwahl) anrufe), dann kommt das Freizeichen. (auch bei der Rufgruppe). Aber von fremden Telekom Anschlüssen kommt das Freizeichen nicht.

Ich versuche mal, die Verbindung mit sngrep zu loggen. (Danke nochmals an @gehtdoch für die Anleitung dazu aus meiner vorigen Frage hier im Forum)
 
Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via