.titleBar { margin-bottom: 5px!important; }

Asterisk 1.2.4 und spandsp-0.0.2pre25

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von mtrakz, 8 Feb. 2006.

  1. mtrakz

    mtrakz Neuer User

    Registriert seit:
    4 Jan. 2006
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #1 mtrakz, 8 Feb. 2006
    Zuletzt bearbeitet: 8 Feb. 2006
    Hallo Zusammen,

    ...nach dem ich mittlerweile meinen Asterisk 1.2.4 (bristuff-0.3.0-PRE-1k.tar.gz) installiert und konfiguriert habe währe jetzt der Patch für eingehende Faxe nötig!

    Ich werde nach dieser Anleitung vorgehen -> http://www.soft-switch.org/installing-spandsp.html und die oben genannte Version benutzen wenn nichts dagegen spricht... und da geht´s schon los!? ;-)

    Wie in der Anleitung zu lesen ist wir libtiff in der Version 3.5.7., 3.6.0 oder 3.7.1 benötigt (um sicher zu "laufen")!
    Ich benutze ein Debian Sarge 3.1 und dort ist libtiff in der Version 4 dabei (so wie es aussieht)!

    Meine Fragen:
    1.) Hat schon jemand ein Asterisk + spanDSP erfolgreich am "laufen" und wenn ja mit welcher libtiff-Version bzw. geht libtiff4?
    2.) Muss ich noch etwas anderes beachten?

    Ziel soll es irgendwann sein Fax zu empfangen und per Mail an einen user zu schicken!

    Vielen Dank jetzt schon für hoffentlich viele Nachrichten ;-)

    Gruß
    Joachim
     
  2. mtrakz

    mtrakz Neuer User

    Registriert seit:
    4 Jan. 2006
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Also, ich hab das jetzt einfach mal so gemacht wie beschrieben... -> alles OK (soweit ich das beurteilen kann -> keine Errors!)

    Danach musste ich chan_capi nochmals installieren weil * die Karte nicht mehr gefunden hat... - komisch

    Jetzt bekomme ich aber follgende Meldungen beim start von * :

    Code:
    Feb  8 20:28:32 NOTICE[2682] cdr.c: CDR simple logging enabled.
    Feb  8 20:28:33 WARNING[2682] loader.c: /usr/lib/asterisk/modules/app_rxfax.so: undefined symbol: t30_completion_code_to_str
    Feb  8 20:28:33 WARNING[2682] loader.c: Loading module app_rxfax.so failed!
    
    bzw.

    Code:
    Feb  8 20:30:03 NOTICE[2707] cdr.c: CDR simple logging enabled.
    Feb  8 20:30:05 WARNING[2707] loader.c: /usr/lib/asterisk/modules/app_txfax.so: undefined symbol: t30_completion_code_to_str
    Feb  8 20:30:05 WARNING[2707] loader.c: Loading module app_txfax.so failed!
    
    ich musste beide Applikationen in der modules.conf deaktivieren damit asterisk wieder durchstartet... - bin ratlos!

    Kann mir jemand helfen!?! Was hab ich falsch gemacht! :-(
     
  3. PaL

    PaL Neuer User

    Registriert seit:
    2 Mai 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Den Fehler hatte ich am anfang auch. Ich hatte erst spandsp-0.3 installiert und dann das 0.2er, weil das neuer war. Leider entfernt das 0.2er paar files nicht ordentlich und drum musst du das dann machen. Also alles was sich nach spandsp anhört.

    Hoffe das hilft.

    PS.: Sry für rechtschreibfehler und alles kleinschreibung - ist schon bissl spät.
     
  4. mtrakz

    mtrakz Neuer User

    Registriert seit:
    4 Jan. 2006
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Danke! :)

    Ich hatte auch mit verschiedenen Versionen herumgespielt! Die Dateienwerden wohl nicht richtig überschrieben!

    Nach de ich die von spanDSP erzeigetn Links bzw. Dateien gelöscht + nochmals kompiliefrt hatte ging alles gut!

    Gruß
    Joachim
     
  5. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    0