.titleBar { margin-bottom: 5px!important; }

asterisk, fedora core3, isdn karte mit hfc-chipsatz

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von nirvana1000, 19 Dez. 2004.

  1. nirvana1000

    nirvana1000 Neuer User

    Registriert seit:
    26 Nov. 2004
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi,
    habe linux fedora core 3 installiert und mit yum update auf den neuesten stand gebracht. weiterhin habe ich die kernel source dateien installiert und einen symblink gesetzt /usr/src/linux-2.6 -> /usr/src/redhat/SOURCE

    danach habe ich mir die aktuellen bristuff dateien von junghanns besorgt und installiert. inkl. asterisk wird alles voll automatisch gezogen und installiert.

    wechsele ich in den Ordner /usr/src/bristuff/zaphfc und gebe make loadNT ein, bekomme ich folgenden Fehler:

    [root@asterisk zaphfc]# make loadNT
    make -C /usr/src/linux-2.6 SUBDIRS=/usr/src/bri-stuff.0.1.0-RC4a/zaphfc modules
    make[1]: Entering directory `/usr/src/redhat/SOURCES'
    make[1]: *** No rule to make target `modules'. Stop.
    make[1]: Leaving directory `/usr/src/redhat/SOURCES'
    make: *** [linux26] Error 2

    hat jemand eine idee was ich falsch mache ?

    gruss thomas
     
  2. nirvana1000

    nirvana1000 Neuer User

    Registriert seit:
    26 Nov. 2004
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    syblink falsch gesetzt

    hi, ich nochmal ...

    der syblink war falsch gesetzt, sorry

    linux-2.6 -> /lib/modules/2.6.9-1.681_FC3/build

    dafür bekomme ich jetzt folgende fehler:

    /usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.c:896: warning: use of cast expressions as lvalues is deprecated
    /usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.c:896: warning: use of cast expressions as lvalues is deprecated
    Building modules, stage 2.
    MODPOST
    *** Warning: "zt_register" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_transmit" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_receive" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_ec_chunk" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_unregister" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    CC /usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.mod.o
    LD [M] /usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko
    make[1]: Leaving directory `/lib/modules/2.6.9-1.681_FC3/build'


    thomas
     
  3. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Re: syblink falsch gesetzt

    ...ich seh keine Fehler.... nur Warnings :)
    Solange da nirgends ein dicker Error drin auftaucht, ist das zwar unschoen, aber nicht weiter tragisch.
     
  4. nirvana1000

    nirvana1000 Neuer User

    Registriert seit:
    26 Nov. 2004
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    nachdem ich die rpms erstmal deinstalliert habe, wweil die vorher auf dem system waren, habe ich den install befehl im bristuff ordner nochmal gestartet, läuft soweit auch alles prima durch, sobald ich dann nach anleitung den treiber laden will kommt folgende fehlermeldung:

    [root@asterisk zaphfc]# make load
    make -C /usr/src/linux-2.6 SUBDIRS=/usr/src/bri-stuff.0.1.0-RC4a/zaphfc modules
    make[1]: Entering directory `/lib/modules/2.6.9-1.667/build'
    Building modules, stage 2.
    MODPOST
    *** Warning: "zt_register" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_transmit" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_receive" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_ec_chunk" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_unregister" [/usr/src/bri-stuff.0.1.0-RC4a/zaphfc/zaphfc.ko] undefined!
    make[1]: Leaving directory `/lib/modules/2.6.9-1.667/build'
    modprobe zaptel
    FATAL: Module zaptel not found.
    make: *** [loadlinux26] Error 1

    kann mir jemand weiterhelfen ?

    danke thomas
     
  5. nirvana1000

    nirvana1000 Neuer User

    Registriert seit:
    26 Nov. 2004
    Beiträge:
    83
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    oh man, hab nen alten treiber installiert, weil auf der junghanns.net seite der oberste link nicht aktualisiert wurde, also mal auf den button downloads klicken, dann kommen ganz viele auch alte versionen vom bristuff und chan_capi treiber.

    trozdem blick ich hier immer noch nicht durch, hat jemand denn nicht mal ne simple anleitung, um eine hfc-isdn karte, mit einem grandstream sip-telefon auf fedora core3 ans laufen zu kriegen, gefrust thomas ...