Asterisk + FLI4L Router + Sipgate + X-Lite !! HILFE !!

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Habe da ein Kleines Problem mit dem Router.

Ist ein FLI4L (Linux One Disk Router).

Habe die Ports schon auf den Asterisk Server weitergeleitet.
tcp 5060- 5062
tcp 8000- 8020
tcp 10000- 10000
udp 5004- 5007
udp 8000- 8020
udp 10000- 20000

Im Sipgate Konto bin ich auch online.
Bekomme aber keine Verbindung nach draußen mit Tone (Nur Verbindung) laut Rufliste von Sipgate.
Kann mich auch nicht anrufen. Asterisk meldet nichts im Status Monitor.
... Asterisk -vvvr ...

(Habe mit X-Lite schon eine Verbindung zu Sipgate mit Tone und Anrufbar bekommen)

Wenn jemand auch einen FLI4l Router benutzt und dieses Problem mit SIP und NAT / Firewall schon in den griff bekommen hat wäre ich über Infos bezüglich den Settings sehr dankbar.

Kann unter den PC´s mit X-Lite über den Asterisk Telefonieren ... auch über den eingebauten ISDN AVM Fritz Karten Gate ins Festnetz. Nur das mit dem Sipgate.de geht nicht so.

PS: Danke ... Habe schon zuviele Nächte probiert ohne Erfolg.

MfG Dirk Walde
 

rajo

Admin-Team
Mitglied seit
31 Mrz 2004
Beiträge
1,958
Punkte für Reaktionen
0
Punkte
36
versuch statt

tcp 5060- 5062

das ganze mal mit udp... denn SIP läuft idR über udp (wenn man es auch über tcp machen kann)
 

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Warum nur die UDP Ports??

Die Sipconfig vom Asterisk lauscht doch auf dem TCP 5060 oder ???

Sip.conf

[general]
port = 5060 ; Port to bind to (SIP is 5060)

oder habe ich da was falsch verstanden.

MfG Dirk Walde

PS: Werde gleich mal die TCP Weiterleitung der 5060 bis 5062 rausnehmen.

??? Wer hat einen FLI4L mit Asterisk und Sipgate, Nikotel oder so am laufen ???
 

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
sip.conf ist 5060 UDP!
 

obelix

Mitglied
Mitglied seit
6 Apr 2004
Beiträge
345
Punkte für Reaktionen
0
Punkte
0
hallo Walde,

also ich habe zwar kein fli4l aber unter anderen einen IPCop. Und da habe ich 5060UDP freigegeben. Und das geht.

OBELIX
 

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Hallo Obelix

Welche Ports TCP u. UDP hast du weitergeleitet an den Asterisk im IPCOP (Linux System).
Und welchen Sip Anbieter hast du ?

PS: Habe jetzt soviel über sip.conf gelesen das ich nicht mehr weiss was richtig sein könnte ( Grins *** ). Wie sieht bei dir das General aus?

.. und was ist jetzt richtig habe sowohl NAT=1 o. NAT=2 u. auch NAT=NO NAT=YES gelesen. (NAT muß aktiv sein ist klar =YES o. =2 ist hier die Frage).
 

obelix

Mitglied
Mitglied seit
6 Apr 2004
Beiträge
345
Punkte für Reaktionen
0
Punkte
0
jau ich habe 5060UDP für SIP und 5036 UDP für IAX. SIP-Anbieter habe ich SipGate

NAT=YES wenn Du hinterm Router bist.

dat läuft klasse.

naja die ganze Config ist nun so gross dass ich sie nicht posten werde.

aber wenn Du möchtest schicke ich die ein paar demo-Configs von meiner CD


OBELIX
 

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Habe den TCP 5060-5062 aus der Weiterleitung rausgenommen und bekomme immer noch bei Sipgate.de die Info das ich Online bin. Kann auch raus Telefonieren ... Aber ohne Ton. Kann aber auch nicht angerufen werden. Also immer noch das selbe wie am Anfang.

** Hier mal der Log vom Asterisk beim raus Telefonieren. **

asterisk:~# asterisk -vvvr
-- Executing Dial("SIP/5200-c2f6", "SIP/[email protected]") in new stack
-- Called [email protected]
-- SIP/8002045-7f94 answered SIP/5200-c2f6
-- Attempting native bridge of SIP/5200-c2f6 and SIP/8002045-7f94
== Spawn extension (default, 110000, 1) exited non-zero on 'SIP/5200-c2f6'


** Hier mal das sip.conf **

[general]
port = 5060 ; Sipport
bindaddr = 0.0.0.0 ; Addresse für den SIP Kanal
context = default ; Hier wird den einzelnen Benutzern der Kontext default zugewiesen.
srvlookup = yes ; Enable DNS SRV lookups on outbound calls
tos=lowdelay ; hier durch wird das Routing verbessert und somit auch die Sprachqualität.
maxexpirey=3600
defoultexpirey=120
disallow=all ; sperrt alle codecs
allow=ulaw ; erlaubt alle codecs
allow=alaw
allow=ilbc
allow=gsm
net=yes


register => 8002045:**Password**@sipgate.de/8002045 ; Hier registrieren sie ihren Asteriskserver bei einem anderen Dienst.


[8002045] ; Sipgate ist ihr Account für Gespräche ins Festnetz.
type=friend
username=8002045
fromuser=8002045
secret=**Password**
context=default
host=sipgate.de
fromdomain=sipgate.de
canreinvite=no
nat=yes
dtmfmode=rfc2833
 

rollo

IPPF-Promi
Mitglied seit
5 Jul 2004
Beiträge
8,288
Punkte für Reaktionen
1
Punkte
38
Setze mal in die sip.conf unter [General] ein:

externip=<Deine externe IP oder Dyndns Domain>

net=yes soll wohl nat=yes heissen

Im sipgate Accountteil kann nat=no stehen. Das bezieht sich auf die Gegenstelle und die läuft nicht mit NAT.

Bezüglich UDP TCP kann ich mich meinen Vorpostern anschliessen. UDP reicht völlig aus, TCP NAT hilft nix.

Die RTP Portrange würde ich in der rtp.conf und im NAT nur so gross machen wie nötig. 10000 Ports ist ein bischen viel.

jo
 

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
Oh mei :)

nat=yes hilft alleine NULL.
Machmal bei Sipgate Peer nat=yes qualify=yes und bei [general] defaultexpirey=20.

Walde auch wenn Du ganz neu bist hier, bitte benütze mal die Suchfunktion, dann stösst Du z.B auf folgendes:
FAQ von Rajo (sieh Forum Announcement) bzw. SIP+NAT+Asterisk Thread.

Du musst in sip.conf externip=xxx.dyndns.org bzw. feste IP definieren,
wenn Dein Asterisk HINTER einem NAT Router steht.

Ansonsten gibts nur One-Way Audio.

Ich ertappe mich gern zu empfehlen RTFM = Read the fucking Manual (mindestens die paar Asterisk Threads hier im Forum), aber als neues Mitglied haben wir natürlich etwas mehr Geduld :)

Schaumal auch hier : www.voip-info.org/wiki-asterisk
 

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Habe alles Ausprobiert und Eingerichtet.

externip: ... Dyndns.dk ... Ist richtig **Grins**
Ports auf und zu. usw.

Habe nur einen komischen geschmack bei den Infos von Asterisk
Da beim SIP SHOW REGISTRY nichts erscheint ?

asterisk*CLI> sip show registry
Host Username Refresh State

asterisk*CLI> sip show peers
Name/username Host Mask Port Status
5200/5200 192.168.113.10 (D) 255.255.255.255 5060 Unmonitored
8002045/8002045 217.10.79.9 255.255.255.255 5060 OK (128 ms)

MfG Dirk

PS: Habe die Handbücher "The Asterisk Handbook Ver.2" "Uni. Chemnitz Asterisk Studienarbeit" .... usw. Ausgedruckt hier liegen ... und auch fast alles gelesen was mit dem SIP zu tun hat.
 

Walde

Neuer User
Mitglied seit
4 Jul 2004
Beiträge
43
Punkte für Reaktionen
0
Punkte
0
Sorry bekomme doch ne Info

asterisk*CLI> sip show registry
Host Username Refresh State
217.10.79.9:5060 8002045 120 Registered
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,877
Beiträge
2,027,683
Mitglieder
351,002
Neuestes Mitglied
trabbimatti1