.titleBar { margin-bottom: 5px!important; }

Asterisk mit 2 HFC Karten + bristuff-0.3.0-PRE-1i

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von btn-hitman, 30 Jan. 2006.

  1. btn-hitman

    btn-hitman Neuer User

    Registriert seit:
    20 Jan. 2006
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    habe da mal wieder ein Problem.
    Hatte die Asterisk mit 2 HFC Karten per Modem / HiSax Treibern geladen, jedoch hatte ich zeitweise ein grosses Echo drin.
    Nun habe ich versucht die ganze Geschichte neu aufzusetzen und habe mir den Bristuff-0.3.0-PRE-1i galaden.
    Kernel Patchen und Treiber laden scheint ohne Probleme geklappt zu haben.
    Nur leider nimmt die Asterisk keine Rufe mehr an, und kann nun auch nicht mehr rauswählen. Beide Karten hängen an einem internen S0 Bus einer Telefonanlage von Agfeo.

    Code:
    ztcfg -v
    
    Zaptel Configuration
    ======================
    
    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    
    6 channels configured.
    
    Code:
    /etc/zaptel.cfg
    # hfc-s pci a span definition
    # most of the values should be bogus because we are not really zaptel
    loadzone=nl
    defaultzone=nl
    
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    
    span=2,1,3,ccs,ami
    bchan=4-5
    dchan=6
    
    Code:
    /etc/asterisk/zapata.conf
    ; Zapata telephony interface
    ;
    ; Configuration file
    
    [channels]
    ;
    ; Default language
    ;
    language=en
    ;
    ; Default context
    ;
    ;
    switchtype = euroisdn
    
    ; p2mp TE mode
    signalling = bri_cpe_ptmp
    
    ; p2p TE mode
    ;signalling = bri_cpe
    
    ; p2mp NT mode
    ;signalling = bri_net_ptmp
    
    ; p2p NT mode
    ;signalling = bri_net
    
    pridialplan = dynamic
    prilocaldialplan = local
    nationalprefix = 0
    internationalprefix = 00
    
    echocancel=yes
    echotraining = 100
    echocancelwhenbridged=yes
    immediate=yes
    group = 1
    context=demo
    channel => 1-2
    channel => 4-5
    

    Die Fehlermeldung bei einem Outgoing Call sieht so aus:

    Code:
    Asterisk Ready.
    *CLI>     -- Accepting AUTHENTICATED call from 192.168.x.xx:
           > requested format = alaw,
           > requested prefs = (unknown|unknown|h263|unknown),
           > actual format = ulaw,
           > host prefs = (),
           > priority = mine
        -- Executing Dial("IAX2/1000-1", "ZAP/g1/46|30|tr") in new stack
        -- Requested transfer capability: 0x00 - SPEECH
        -- Called g1/46
        -- Channel 0/1, span 1 got hangup, cause 42
        -- Zap/1-1 is circuit-busy
        -- Hungup 'Zap/1-1'
    
    Kann mir jemand helfen ?

    Gruß
    H. Höfler
     
  2. btn-hitman

    btn-hitman Neuer User

    Registriert seit:
    20 Jan. 2006
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problem gelöst

    Alles klar hat sich schon erledigt.
    Musste nur noch einmal die Kiste rebooten, dann hat alles funktioniert.

    Trotzdem Danke.
    H. Höfler