.titleBar { margin-bottom: 5px!important; }

Asterisk nimmt eingehende Anrufe nicht entgegen

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von kmpoppe, 23 Okt. 2005.

  1. kmpoppe

    kmpoppe Neuer User

    Registriert seit:
    23 Okt. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin !

    Ich habe mir unter Suse 9.2
    asterisk-1.0.9 mit chan_capi-0.5.4 kompiliert.

    Alles schön und gut, aber wenn ich asterisk starte bekomme ich in /var/log/asterisk/messages diese netten Meldungen:

    Code:
    Oct 23 22:25:59 NOTICE[14373]: chan_capi.c:3271 load_module: Unused contr1
    Oct 23 22:26:00 WARNING[14373]: Autodial: Unable to open file
    Ich kann mit beiden Meldungen nicht so richtig etwas anfangen, weil ích mir nicht vorstellen kann an welcher Schraube ich noch drehen muss.

    Das ärgerliche ist, dass asterisk keinen Anruf entgegennimmt, obwohl ich die incomingmsn auf 52 gesetzt habe, eine interne Rufnummer von meiner Telefonanlage (die 51 ist von HylaFax belegt, welches übrigens hervorragend funzelt, und nein, auch ohne ein laufendes hylafax und c2faxrecv gehts net).

    /etc/asterisk/capi.conf:
    Code:
    [general]
    nationalprefix=0
    internationalprefix=00
    rxgain=0.8
    txgain=0.8
    ;ulaw=yes        ;set this, if you live in u-law world instead of a-law
    
    ; interface sections ...
    
    [ISDN1]          ;this example interface gets name 'ISDN1' and may be any
                     ;name not starting with 'g' or 'contr'.
    ;ntmode=yes      ;if isdn card operates in nt mode, set this to yes
    isdnmode=msn     ;'MSN' (point-to-multipoint) or 'DID' (direct inward dial)
                     ;when using NT-mode, ptp should be set in any case
    msn=52
    incomingmsn=52   ;allow incoming calls to this list of MSNs/DIDs, * == any
    ;controller=0    ;ISDN4BSD default
    ;controller=7    ;ISDN4BSD USB default
    controller=1     ;capi controller number to use
    group=1          ;dialout group
    ;prefix=0        ;set a prefix to calling number on incoming calls
    softdtmf=on      ;enable/disable software dtmf detection, recommended for AVM cards
    relaxdtmf=on     ;in addition to softdtmf, you can use relaxed dtmf detection
    accountcode=     ;Asterisk accountcode to use in CDRs
    context=demo  ;context for incoming calls
    holdtype=hold    ;when Asterisk puts the call on hold, ISDN HOLD will be used. If
                     ;set to 'local' (default value), no hold is done and Asterisk may
                     ;play MOH.
    immediate=no   ;immediate start of pbx with extension 's' if no digits were
                     ;received on incoming call (no destination number yet)
    ;echosquelch=1   ;_VERY_PRIMITIVE_ echo suppression
    ;echocancel=yes  ;EICON DIVA SERVER (CAPI) echo cancelation
                     ;(possible values: 'no', 'yes', 'force', 'g164', 'g165')
    echocancelold=yes;use facility selector 6 instead of correct 8 (necessary for older eicon drivers)
    ;echotail=64     ;echo cancel tail setting
    ;bridge=yes      ;native bridging (CAPI line interconnect) if available
    ;callgroup=1     ;Asterisk call group
    ;deflect=1234567 ;deflect incoming calls to 1234567 if all B channels are busy
    devices=2        ;number of concurrent calls on this controller
                     ;(2 makes sense for single BRI, 30 for PRI)
    /etc/asterisk/modules.conf:
    Code:
    [modules]
    autoload=yes
    ;
    ; If you want, load the GTK console right away.
    ; Don't load the KDE console since
    ; it's not as sophisticated right now.
    ;
    noload => pbx_gtkconsole.so
    ;load => pbx_gtkconsole.so
    noload => pbx_kdeconsole.so
    ;
    ; Intercom application is obsoleted by
    ; chan_oss.  Don't load it.
    ;
    noload => app_intercom.so
    ;
    ; Explicitly load the chan_modem.so early on to be sure
    ; it loads before any of the chan_modem_* 's afte rit
    ;
    load => chan_modem.so
    load => res_musiconhold.so
    ;
    ; Explicitly load chan_capi.so and features
    ;
    load => chan_capi.so
    load => res_features.so
    ;
    ;
    ; Load either OSS or ALSA, not both
    ; By default, load OSS only (automatically) and do not load ALSA
    ;
    noload => chan_iax2.so
    noload => chan_alsa.so
    noload => chan_oss.so
    ;
    ; Module names listed in "global" section will have symbols globally
    ; exported to modules loaded after them.
    ;
    [global]
    chan_modem.so=yes
    chan_capi.so=yes
    
    Wenn jemand eine Idee hat, wodran das liegen könnte, wäre ich über schnelle Hilfe sehr dankbar! Falls noch irgendwelche configs zur Problemlösung benötigt werden, bitte schreiben!

    Regards

    Kai M Poppe
     
  2. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du schreibst, dass Du chan_capi 0.5.4 verwendest, aber Deine capi.conf ist fuer 0.6. Das passt nicht zusammen, denn die Eintraege haben sich geaendert.

    Armin