.titleBar { margin-bottom: 5px!important; }

asterisk + sipgate -> leeres fax

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von another-way, 14 Feb. 2005.

  1. another-way

    another-way Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich hab grad mal asterisk mit spandsp kompiliert und versucht ein fax über sipgate zu versenden.
    der fax piep kommt... nur das eigentliche fax was übertragen wird ist komplett weiss

    folgendes spuckt asterisk aus

    Code:
           > Channel SIP/sipgate-fcd0 was answered.
           > Lauching TxFax(/tmp/faximage.tif|caller) on SIP/sipgate-fcd0
    File name is '/tmp/faximage.tif'
    Changed from phase 0 to 2
    Slow carrier up
    Slow carrier down
    Slow carrier up
    <<< NSF: 20 20 81 80 80 c0 04
    NSF without final frame tag
    <<< CSI: 40 39 33 33 38 32 20 32 36 34 37 33 20 39 34 2b 20 20 20 20 20
    CSI without final frame tag
    Remote fax gave CSI as: "+49 37462 28339"
    <<< DIS: 80 00 ee f8 44
    DIS with final frame tag
    In state 10
    DIS:
    Preferred octets: 256
    Can receive fax
    Supported data signalling rates: V.27ter, V.29 and V.17
    R8x7.7lines/mm and/or 200x200pels/25.4mm OK
    2D coding OK
    Scan line length: 215mm
    Recording length: A4 (297mm) and B4 (364mm)
    Receiver's minimum scan line time: 0ms at 3.85 l/mm: T7.7 = T3.85
    Error correction mode
    T.6 coding
    DCS:
    Selected data signalling rate: V.29, 9600bps
    2D coding OK
    Scan line length: 215mm
    Recording length: A4 (297mm)
    Minimum scan line time: 0ms
    Start sending document
    Start tx document - compression 2
    Standard mode
    Changed from phase 2 to 4
    Sending ident
    >>> TSI: 43 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20
    >>> DCS: 83 00 84 70
    HDLC underflow in state 3
    Changed from phase 4 to 6
    Changed from phase 6 to 3
    Slow carrier up
    <<< CFR: 84
    CFR with final frame tag
    In state 4
    Trainability test succeeded
    Start tx page
    Page 1 of /tmp/faximage.tif
    842 rows/3968 bytes to send
    Changed from phase 3 to 6
    Changed from phase 6 to 4
    Start tx page
    >>> EOP: 2f
    HDLC underflow in state 14
    Changed from phase 4 to 3
    Slow carrier up
    <<< RTN: 4c
    RTN with final frame tag
    In state 14
    Changed from phase 3 to 4
    >>> DCN: fb
    HDLC underflow in state 2
    Disconnecting
    Changed from phase 4 to 7
    Changed from phase 7 to 8
    
    hat vielleicht jemand ne idee woran das liegen könnte??
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das ist aber ärgerlich! Wie sieht das mit den codecs aus? Wurde zur übertragung alaw oder ulaw gewählt? Sonst wird das mangels Qualität der Übertragung wohl nix!
     
  3. another-way

    another-way Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    dann sollte zumindest nen übertragungsfehler kommen....
    nachdem das fax raus is lässt sich asterisk auch net mehr beenden und fährt sich fest....
     
  4. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    hmm... bug in spandsp? fehler in der libtiff? inkompatible * / spandsp-versionen?
     
  5. another-way

    another-way Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja die punkte gingen mir auch schon durch den kopf....
    welche spandsp is denn fürdie neueste cvs vom * kompatibel bzw gibts da schon eine?
     
  6. another-way

    another-way Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hab nun neues spandsp installiert... nun bleibt er zumindesmehr hängen

    trotzdem leeres fax :(

    edit: zu früh gefreut... das teil fährt sich nach wie vor fest
    zusätzlich kommt nen segmenttion fault
     
  7. another-way

    another-way Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mittlerweilehabe ihc mir ne neue libtiff gezogen... empfangen geht nun
    nur leider geht das senden noch immer nicht :(

    asterisk spuckt folgendes aus

    Code:
        -- Attempting call on SIP/03746228339@sipgate for application txfax(/tmp/faximage.tif) (Retry 1)
           > Channel SIP/sipgate-86ac was answered.
           > Lauching txfax(/tmp/faximage.tif) on SIP/sipgate-86ac
    DIS with final frame tag
    In state 9
    Start tx document
    FTT with final frame tag
    In state 4
    XCN with final frame tag
    In state 4
    Feb 15 14:23:13 NOTICE[7954]: pbx_spool.c:242 attempt_thread: Call completed to SIP/03746228339@sipgate
    
    
    keiner ne idee?


    edit:

    jetzt schaffe ich es mittlerweile durch ständiges probieren das 3cm des ersten faxes ankommen, dann aber die übertragung abbricht.

    wie zwinge ich asterisk dazu bei sip verbindungen nen speziellen codec zu nehmen?
    mit allow=ulaw?? das hab ich gemacht dennoch kommt es zu ü-fehlern