Asterisk + Sipgate ohne Nat spinnt

Emmy

Neuer User
Mitglied seit
19 Aug 2004
Beiträge
38
Punkte für Reaktionen
0
Punkte
0
Hallo!

Ich versuche hier meinen Sipgate-Account mit Asterisk einzurichten. Ich kann auch auf Festnetzanschlüsse raustelefonieren und angerufen werden, aber wenn ich einen anderen Sipgate-User anrufen will gibts "483 too many Hops". Auch das kleine "Telefon Angemeldet" Icon auf der Sipgate-Site bleibt grau.

Ich hab in den Logs folgende 2 auffälligen Nachrichten gefunden:

Code:
Sip read:
SIP/2.0 482 Loop Detected
Via: SIP/2.0/UDP 217.83.23.53:5060;branch=z9hG4bK451accf3
From: "asterisk" <sip:[email protected]>;tag=as6e9a08bc
To: <sip:217.10.79.9>;tag=b11cb9bb270104b49a99a995b8c68544.8839
Call-ID: 268d5dcc4ecd8bc84e992b04045c[email protected]
CSeq: 102 OPTIONS
Server: Sip EXpress router (0.8.12-tcp_nonb (i386/linux))
Content-Length: 0
Warning: 392 217.10.79.9:5060 "Noisy feedback tells:  pid=19450 req_src_ip=217.83.23.53 req_src_port=5060 in_uri=sip:217.10.79.9 out_uri=sip:217.10.79.9 via_cnt==1"
Code:
Sip read:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 217.83.23.53:5060;branch=z9hG4bK1e8f695e;rport=5060
From: <sip:*******@sipgate.de>;tag=as6f511e39
To: <sip:*******@sipgate.de>;tag=b11cb9bb270104b49a99a995b8c68544.d76e
Call-ID: [email protected]
CSeq: 106 REGISTER
WWW-Authenticate: Digest realm="sipgate.de", nonce="4124a0b633c5d2eb9bfa5f482fbe38774c38926e"
Server: Sip EXpress router (0.8.12-tcp_nonb (i386/linux))
Content-Length: 0
Warning: 392 217.10.79.9:5060 "Noisy feedback tells:  pid=19456 req_src_ip=217.83.23.53 req_src_port=5060 in_uri=sip:sipgate.de out_uri=sip:sipgate.de via_cnt==1"
(warum taucht bei "Call-ID" die interne IP des Routers auf?)

Es tauchen auch jede Menge Meldungen auf die Zeigen dass sich
der * korrekt bei Sipgate registriert.
sip show registry und peers zeigen Registered bzw. OK an.

Meine sip.conf:

Code:
;
; SIP Configuration for Asterisk
;
[general]
port=5060
bindaddr=0.0.0.0
localnet=192.168.1.0/24         ; Lokales Intranet
externip=xxx.dyndns.org   ; Dyndns-Account für die Externe IP
realm=xxx.dyndns.org
canreinvite=no
maxexpirey=3600                 ; Max length of incoming registration we allow
defaultexpirey=90               ; Default length of incoming/outoing registration

;disallow=all                   ; Disallow all codecs
allow=alaw
allow=ulaw                      ; Allow codecs in order of preference
allow=ilbc
allow=gsm
allow=all

nat=no
context=sipclients              ; Default context for incoming calls
srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
;pedantic = yes                 ; Enable slow, pedantic checking for Pingtel
tos=lowdelay                    ; IP QoS parameter, either keyword or value

;notifymimetype=text/plain      ; Allow overriding of mime type in NOTIFY
;videosupport=yes               ; Turn on support for SIP video

; Format for the register statement is:
;       register => user[:secret[:authuser]]@host[:port][/extension]

register => <sip-nr>:<sip-pw>@sipgate.de/sipgate-in
register => <uni-user>:<uni-pw>@stud.uni-saarland.de/unisip-in


[sipgate-out]
nat=no
type=friend
username=<sip-nr>
fromuser=<sip-nr>
fromdomain=sipgate.de
host=sipgate.de
auth=md5,plaintext
secret=<sip-pw>
insecure=very
canreinvite=no
qualify=yes

[martin]
nat=no
type=friend
username=martin
mailbox=martin
secret=<kphone-pw-aufm-dicken-PC>
host=dynamic
canreinvite=no
dtmfmode=rfc2833
amaflags=default
fromuser=martin
fromdomain=xxx.dyndns.org
context=sipclients

Meine (IMHO relevanten) einträge in der extensions.conf:

Code:
[sipclients]
exten => s,1,Wait(1)
exten => s,2,Answer
exten => s,3,Dial(SIP/martin,10)
exten => s,4,Goto(anrufbeantworter,s,3)
exten => s,5,Hangup

exten => t,1,Hangup
;exten => T,1,Hangup

exten => _0X.,1,Dial,CAPI/@<meine-msn>:${EXTEN:1}
exten => _0X.,2,Hangup

; uni-durchwahl für lau
exten => _1XXXX,1,Dial(SIP/${EXTEN:1}@rz.uni-saarland.de)
exten => _1XXXX,2,Hangup

exten => _2.,1,Dial(SIP/${EXTEN:1}@sipgate-out)
exten => _2.,2,Hangup

exten => _[3-9].,1,Congestion
exten => _[3-9].,2,Hangup

; eingehende
exten => sipgate-in,1,Dial(SIP/martin,10)
exten => sipgate-in,2,Goto(anrufbeantworter,s,1)
exten => unisip-in,1,Dial(SIP/martin,10)
exten => unisip-in,2,Goto(anrufbeantworter,s,1)


[anrufbeantworter]
exten => s,1,Wait,10
exten => s,2,Answer
exten => s,3,PlayBack(anrufbeantworter)
exten => s,4,Voicemail(smartin)
exten => s,5,Hangup


[festnetz]
exten => s,1,Wait(1)
exten => s,2,Dial(SIP/martin,15)
exten => s,3,Goto(s-${DIALSTATUS})

exten => s-NOANSWER,1,Goto(anrufbeantworter,s,1)
exten => s-CHANAVAIL,1,Goto(anrufbeantworter,s,1)

exten => s,4,Goto(anrufbeantworter,s,2)
exten => s,5,Hangup
exten => s,103,Goto(anrufbeantworter,s,1) ; hier soll chanavail hin wenn SIP/martin nicht erreichbar

[default]
include => festnetz
Wie gesagf, die Kiste ist auch DSL-Router, d.h. NAT-Probleme scheiden von vornherein raus (es sei denn mein Kphone will direkt raus, aber das sollte ja das canreinvite=no verhindern) Geöffnet nach aussen sind Ports 5060 und 7070-8050 (auch in der rtp.conf eingetragen)
Wo kommt das unauthorized her? wie bekomm ich das loop detected weg?

Ciao & vielen Dank für eure Tips

Martin
 

Emmy

Neuer User
Mitglied seit
19 Aug 2004
Beiträge
38
Punkte für Reaktionen
0
Punkte
0
Hi!

Hatte "realm=..." erst eben nachträglich reingemacht, hat nix geändert. Aber ich machs mal wieder raus.

Ciao

Martin
 

deepnight

Neuer User
Mitglied seit
10 Jun 2004
Beiträge
119
Punkte für Reaktionen
0
Punkte
0
versuch mal die NAT auf on zu stellen, auch wenn du keinen router dahinter hast, aus eigener erfahrung weis ich das * mit NAT ziemlich kämft, vielleicht bringts ja was.
 

Emmy

Neuer User
Mitglied seit
19 Aug 2004
Beiträge
38
Punkte für Reaktionen
0
Punkte
0
Hab ich mal gemacht, ohne Erfolg. Habs wieder zurück auf no gestellt.

Ciao

Martin
 

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
Ändere mal Sip.conf in:
Code:
[sipgate-out] 
type=friend 
username=<sip-nr> 
fromuser=<sip-nr> 
fromdomain=sipgate.de 
host=sipgate.de 
secret=<sip-pw> 
insecure=very 
canreinvite=no 

[martin] 
type=friend 
username=martin 
mailbox=martin 
secret=<kphone-pw-aufm-dicken-PC> 
host=dynamic 
canreinvite=no 
dtmfmode=rfc2833 
amaflags=default 
fromuser=martin 
context=sipclients
 

Emmy

Neuer User
Mitglied seit
19 Aug 2004
Beiträge
38
Punkte für Reaktionen
0
Punkte
0
Hab ich mal gemacht, hat sich nix geändert.

Mir ist nochwas komisches aufgefallen:
Wenn ich bei kphone anstatt die IP des *-Servers den Hostnamen im internen Netz eintrage, kann ich mich nicht registrieren, der Asterisk schickt einen 401er. Mit der IP ist das kein Problem.

Ciao

Martin
 

Zurzeit aktive Besucher

Keine Mitglieder online.
3CX

Statistik des Forums

Themen
235,322
Beiträge
2,059,267
Mitglieder
355,938
Neuestes Mitglied
mmorgen