.titleBar { margin-bottom: 5px!important; }

Asterisk startet nicht mit capi!

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von Matepl, 12 Okt. 2005.

  1. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe jetzt asterisk unter debian. Habe alles installiert und wenn ich starten will mit asterisk -cvvv kriege ich diese Meldung:

    ==Parsing '/etc/asterisk/capi.conf' : found
    NOTICE[4295]: chan_capi.c2636 load_module:CAPI not installed!
    WARNING[4295]: loader.c:345 ast_load_ressource: chan_capi.so: load_module failed ,returning -1
    WARNING[4295]: chan_capi.c:2811 unload_module:Unable to unregister from CAPI!
    == Unregistered channel type 'CAPI'
    WARNING[4295]: loader.c:391 load.modules:loading module chan.capi.so failed!


    Capi habe ich aber installiert.
    in module.conf habe ich nur geändert:

    load => chan_capi.co

    [global]
    chan_capi.co=yes

    mit oder ohne geht es nicht :(:(:(:( Was kann das sein? bitte hilft mir! mfg matepl
     
  2. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Dieser Fehler sagt, dass CAPI auf deinem System nicht zur Verfuegung steht:
    - hast die /dev/capi20 ?
    - Ist der ISDN Treiber fuer Deine Karte gestartet ?
    - was sagt 'capiinfo' ?

    Armin
     
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Das muss in beiden Fällen chan_capi.so und nicht .co heissen
     
  4. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für Hilfe :) Also capi20 konnte ich nich finden.
    Ich kenne mich mit debian nicht so gut aus.
    Kannst du schreiben was ich für den Treiber und capiinfo eingeben muss??
    mfm matepl
     
  5. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Debian kenne ich nicht so gut, aber es kommt darauf an welche ISDN-Karte Du hast. capiinfo muesste in einem Paket capi4linux/capiutils dabei sein.

    Armin
     
  6. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe mich einfach mit chan_capi.so verschrieben,aber nur im Forum:) Asterisk kann ich ja nur starten wenn ich capi uninstalliere, aber dass brauche ich!! :/
    Ich wiess nicht was ich weiter machen soll. Unter welchem system läuft Asterisk am bestens? Oder habt ihr noch Ideen was ich mit debian machen soll???? :(
     
  7. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also, machen wir es doch mal anders. Poste hier mal bitten die Ausgabe von "lsmod".
    Dann solltest Du überprüfen, ob die Pakete:
    "isdnactivecards capiutils libcapi20-2 libcapi20-dev" installiert sind. Notfalls einfach:
    "apt-get install isdnactivecards capiutils libcapi20-2 libcapi20-dev"
    eingeben. Sollten diese Pakete schon installiert sein, werden sie einfach übergangen.
     
  8. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    obelix:~# lsmod
    Module Size Used by
    ipv6 229892 10
    isofs 33976 0
    st 35740 0
    sg 34976 0
    evdev 9088 0
    pcspkr 3816 0
    parport_pc 33348 0
    parport 37320 1 parport_pc
    tulip 42528 0
    aic79xx 254044 0
    pci_hotplug 30640 0
    intel_agp 20512 1
    hisax_fcpcipnp 11008 0
    hisax_isac 8212 1 hisax_fcpcipnp
    hisax 483280 2 hisax_fcpcipnp,hisax_isac
    crc_ccitt 2432 1 hisax
    isdn 128204 1 hisax
    slhc 7040 1 isdn
    agpgart 31784 1 intel_agp
    capability 4872 0
    commoncap 7168 1 capability
    psmouse 17800 0
    genrtc 9332 0
    ext3 109672 2
    jbd 54552 1 ext3
    de4x5 43552 0
    ds 17796 0
    yenta_socket 19200 0
    pcmcia_core 63028 2 ds,yenta_socket
    sr_mod 15780 0
    sd_mod 20480 2
    ide_cd 38176 0
    cdrom 35740 2 sr_mod,ide_cd
    ide_disk 16768 3
    ide_generic 1664 0
    pdc202xx_new 10012 0
    aec62xx 10012 0
    alim15x3 11404 0
    amd74xx 13340 0
    atiixp 8472 0
    cmd64x 11548 0
    cs5520 6408 0
    cs5530 6664 0
    cy82c693 4996 0
    generic 4608 0
    hpt34x 5760 0
    ns87415 4936 0
    opti621 4740 0
    pdc202xx_old 15388 0
    rz1000 3200 0
    sc1200 8456 0
    serverworks 12308 0
    siimage 12032 0
    sis5513 15240 0
    slc90e66 8200 0
    triflex 5380 0
    trm290 4740 0
    via82cxxx 12956 0
    floppy 54992 0
    usb_storage 59328 0
    piix 12448 1
    ide_core 125028 28 ide_cd,ide_disk,ide_generic,pdc202xx_new,aec62xx,alim15x3,amd74xx,atiixp,cmd64x,cs5520,cs5530,cy82c693,generic,hpt34x,ns87415,opti621,pdc202xx_old,rz1000,sc1200,serverworks,siimage,sis5513,slc90e66,triflex,trm290,via82cxxx,usb_storage,piix
    fbcon 27524 70
    vga16fb 12456 1
    vgastate 8576 1 vga16fb
    usbserial 27112 0
    usbhid 28864 0
    usbkbd 6912 0
    uhci_hcd 29328 0
    usbcore 104164 7 usb_storage,usbserial,usbhid,usbkbd,uhci_hcd
    aic7xxx 176088 1
    scsi_mod 115148 7 st,sg,aic79xx,sr_mod,sd_mod,usb_storage,aic7xxx
    unix 26036 0
    font 8576 1 fbcon
    vesafb 6688 0
    cfbcopyarea 3840 2 vga16fb,vesafb
    cfbimgblt 3200 2 vga16fb,vesafb
    cfbfillrect 3712 2 vga16fb,vesafb[/quote]


    Und den anderen Befehl habe ich auch ausgeführt. Ich glaibe hat noch was dazu installiert. Aber bis jetzt hat noch nichts gebracht. Mfg matepl
     
  9. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du benutzt für Deine ISDN-Karte nicht den Capi sondern Hisax. Außerdem ist kein Kartentreiber installiert! So klappt bestenfalls chan_modem.
    Was hast Du für ne ISDN-Karte?
     
  10. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AVM ISDN Fritz!Card PCI
     
  11. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Dann würde ich mal die Hisax-Treiber entladen und dafür den Capi-Treiber laden. Und natürlich den Kartentreiber. Folgende Module müsen geladen sein:
    capi
    capifs
    fcpci
    kernelcapi

    wobei es sein kann, dass einige Module schon automatisch geladen werden, wenn du das Modul "capi" lädst. fcpci sollte geladen werden, wenn Du capiinit aufrufst.
     
  12. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wie macht man das mit den Treibern? :oops: mit linux fange ich gerade an. und die module? wo soll ich die laden? module.conf?? Am bestens wäre es für mich wenn du die befehle für mich schreiben könntest :lol:
     
  13. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es gibt zwei Möglichkeiten...
    a) manuell:

    rmmod -f hisax_fcpcipnp
    rmmod -f hisax_isac
    rmmod -f hisax

    modprobe capi
    (nachsehen ob capifs geladen wirde, wenn nicht dann:)
    modprobe capifs
    (nachsehen ob kernelcapi geladen wirde, wenn nicht dann:)
    modprobe kernelcapi
    capiinit

    b) mit modconf

    kann man mit "apt-get install modconf" installieren. Und dann mit "modconf" (als root) starten. fcpci muss natürlich wieder mit capiinit installiert werden.
     
  14. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    leider hat es nicht geholfen. asterisk startet weiter nicht. und die selbe meldung kriege ich. :(
     
  15. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast Du dich mit lsmod vergewisert, dass alle notwendigen Module geladen wurden?
     
  16. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja, guck mal nach:


    Code:
    obelix:~# lsmod
    Module                  Size  Used by
    capidrv                29748  0
    ipv6                  229892  10
    c4                     18948  0
    b1pci                   9856  0
    b1dma                  15748  1 b1pci
    b1                     22656  3 c4,b1pci,b1dma
    capi                   17728  0
    kernelcapi             46624  6 capidrv,c4,b1pci,b1dma,b1,capi
    capifs                  6024  2 capi
    st                     35740  0
    sg                     34976  0
    evdev                   9088  0
    pcspkr                  3816  0
    rtc                    12088  0
    parport_pc             33348  0
    parport                37320  1 parport_pc
    tulip                  42528  0
    aic79xx               254044  0
    pci_hotplug            30640  0
    intel_agp              20512  1
    crc_ccitt               2432  0
    isdn                  128204  1 capidrv
    slhc                    7040  1 isdn
    agpgart                31784  1 intel_agp
    capability              4872  0
    commoncap               7168  1 capability
    psmouse                17800  0
    ext3                  109672  2
    jbd                    54552  1 ext3
    de4x5                  43552  0
    ds                     17796  0
    yenta_socket           19200  0
    pcmcia_core            63028  2 ds,yenta_socket
    sr_mod                 15780  0
    sd_mod                 20480  2
    ide_cd                 38176  0
    cdrom                  35740  2 sr_mod,ide_cd
    ide_disk               16768  3
    ide_generic             1664  0
    pdc202xx_new           10012  0
    aec62xx                10012  0
    alim15x3               11404  0
    amd74xx                13340  0
    atiixp                  8472  0
    cmd64x                 11548  0
    cs5520                  6408  0
    cs5530                  6664  0
    cy82c693                4996  0
    generic                 4608  0
    hpt34x                  5760  0
    ns87415                 4936  0
    opti621                 4740  0
    pdc202xx_old           15388  0
    rz1000                  3200  0
    sc1200                  8456  0
    serverworks            12308  0
    siimage                12032  0
    sis5513                15240  0
    slc90e66                8200  0
    triflex                 5380  0
    trm290                  4740  0
    via82cxxx              12956  0
    floppy                 54992  0
    usb_storage            59328  0
    piix                   12448  1
    ide_core              125028  28 ide_cd,ide_disk,ide_generic,pdc202xx_new,aec62xx,alim15x3,amd74xx,atiixp,cmd64x,cs5520,cs5530,cy82c693,generic,hpt34x,ns87415,opti621,pdc202xx_old,rz1000,sc1200,serverworks,siimage,sis5513,slc90e66,triflex,trm290,via82cxxx,usb_storage,piix
    fbcon                  27524  70
    vga16fb                12456  1
    vgastate                8576  1 vga16fb
    usbserial              27112  0
    usbhid                 28864  0
    usbkbd                  6912  0
    uhci_hcd               29328  0
    usbcore               104164  7 usb_storage,usbserial,usbhid,usbkbd,uhci_hcd
    aic7xxx               176088  1
    scsi_mod              115148  7 st,sg,aic79xx,sr_mod,sd_mod,usb_storage,aic7xxx
    unix                   26036  10
    font                    8576  1 fbcon
    vesafb                  6688  0
    cfbcopyarea             3840  2 vga16fb,vesafb
    cfbimgblt               3200  2 vga16fb,vesafb
    cfbfillrect             3712  2 vga16fb,vesafb

    Fehlt nur fcpci. aber die habe ich mit capiinit installiert.Soll das so sein?
     
  17. Matepl

    Matepl Neuer User

    Registriert seit:
    6 Okt. 2005
    Beiträge:
    34
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  18. MassiveBlue

    MassiveBlue Neuer User

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi! Benutzt du zufällig Debian Etch/Testing?