.titleBar { margin-bottom: 5px!important; }

Asterisk startet nicht

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von bonnz, 31 Aug. 2005.

  1. bonnz

    bonnz Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab mal wieder ein kleines Problem mit meinem Sternchen ;)

    Jedenfalls will er nicht starten und bricht mit der Meldung:

    [app_dial.so]Aug 31 09:44:28 WARNING[1076783744]: loader.c:242 ast_load_resource: /usr/lib/asterisk/modules/app_dial.so: undefined symbol: ast_bridge_call
    Aug 31 09:44:28 WARNING[1076783744]: loader.c:374 load_modules: Loading module app_dial.so failed!

    ab. Hat jemand ne Ahnung woran das liegt? Das Modul app_dial existiert, daran liegt es nicht.

    Danke schonmal für Eure Hilfe!
     
  2. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @bonnz

    res_features in modules.conf eintragen.

    Gruß
    britzelfix
     
  3. bonnz

    bonnz Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi britzelfix,

    erstmal Danke für Deinen Tipp, er startet jetzt und die Fehlermeldung ist weg. Kannst Du mir auch erklären warum das so ist? ;)

    Leider bekomme ich jetzt zwei andere Meldungen (die Asterisk aber zum Glück net vom Starten abhalten):

    Sep 1 02:40:39 WARNING[1076783744]: pbx.c:2936 ast_merge_contexts_and_delete: Requested contexts didn't get merged
    Sep 1 02:40:43 NOTICE[1093446576]: chan_sip.c:7653 sip_poke_noanswer: Peer 'sipgate_out' is now UNREACHABLE!
     
  4. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @bonnz

    ja, weil app_dial.so eine linux-dll ist und die Routine benötigt hat die
    sich in einem anderen Modul befindet.
    Ich habe einfach mit grep gesucht wo sie referenziert ist und res_features
    gefunden. RTFM.

    Läuft es jetzt schon?

    Gruß
    britzelfix
     
  5. bonnz

    bonnz Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bin halt mit Linux noch net wirklich so vertraut uns somit komm ich net auf sowas wie mit grep suchen, sorry.

    Also Asterisk selber lief und mein Testuser konnte sich auch am Sever anmelden. Weiter bin ich noch net gekommen da heute so viel anderes anlag.