.titleBar { margin-bottom: 5px!important; }

Aussetzer in beim Sprachempfang (CAPI->SIP)

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von mamue, 27 Jan. 2005.

  1. mamue

    mamue Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    71
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    wenn ich angerufen werden oder jemanden anrufe, also ein Gespräch zu stande kommt, höre ich nach kurzer Zeit viele Aussetzer. Die Sprache klingt zerhackt, so als sei es eine ganz miserable Funkverbindung.
    Ich verwende x-lite als SIP client und wähle mich raus über Fritz-CAPI unter SuSE9.2. Die * Version ist 1.0 (SuSE).
    Ich bekomme beim Starten von * die Meldung:
    Hängen die beiden Meldungen zusammen, habe ich kein timing device, weil ich keine Soundkarte habe? Hat das überhaupt etwas mit meinem Problem zu tun?
    Ich bin mir leider nicht einmal sicher, ob das ein SIP oder CAPI Problem ist.

    Weiß jemand Rat?

    Danke,
    mamue

    Code:
    capi.conf:
    [general]
    nationalprefix=0
    internationalprefix=00
    rxgain=1.0
    txgain=1.0
    
    [interfaces]
    msn=94----
    incomingmsn=*
    controller=1
    softdtmf=1
    accountcode=
    context=default
    echosquelch=1
    echocancel=yes
    echotail=64
    callgroup=1
    devices=2
    
    sip.conf:
    Code:
    [general]
    context=default                 ; Default context for incoming calls
    port=5060                       ; UDP Port to bind to (SIP standard port is 5060)
    bindaddr=0.0.0.0                ; IP address to bind to (0.0.0.0 binds to all)
    srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
    
    disallow=all                    ; First disallow all codecs
    allow=gsm                     ; GSM consumes far less bandwidth than ulaw
    allow=ulaw                      ; Allow codecs in order of preference
    allow=alaw
    
    extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [globals]
    CONSOLE=Console/dsp                             ; Console interface for demo
    IAXINFO=guest                                   ; IAXtel username/password
    TRUNK=Zap/g2                                    ; Trunk interface
    TRUNKMSD=1                                      
    
    [default]
    exten => _99N.,1,Dial(CAPI/94----:${EXTEN:2},30,r)
    exten => _99N.,2,Congestion
    ;Nummer wurde per Hand maskiert: ----
    exten => 94----,1,Wait(1)
    exten => 94----,2,SetLanguage(de)
    exten => 94----,3,Dial(SIP/5471,20,r)
    exten => 94----,4,Voicemail2(u942110)
    exten => 94----,5,Hangup
    exten => 94----,104,Voicemail2(b942110)
    exten => 94----,105,Hangup
    
     
  2. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    bringen 'echocancel=no und ';echosquelch=1' einen Unterschied (ist bei mir aus bzw. default)?
     
  3. mamue

    mamue Neuer User

    Registriert seit:
    4 Sep. 2004
    Beiträge:
    71
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe das jetzt mal getestet - seit ich * habe, führe ich des öfteren Selbstgespräche ;). Das scheint jetzt ganz gut zu funktionieren, den Grund dafür sehe ich aber nicht.

    Danke,
    mamue