.titleBar { margin-bottom: 5px!important; }

Benutzernamen bei Tiscali - was ist mit dem @

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von nico.ach, 10 Sep. 2005.

  1. nico.ach

    nico.ach Neuer User

    Registriert seit:
    10 Sep. 2005
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich moechte mich mit

    register => [email protected]:p[email protected]/tisphone

    bei Tiscali anmelden. Leider klappt das aber nicht und ich bekomme jedes mal ein 401 Unauthorized. Ich vermute, dass das @ im Benutzername Schwierigkeiten macht. Was meint ihr dazu?

    Die Sip-Config schaut so aus:

    Code:
    [general]
    
    bindaddr =83.129.169.92
    localnet = 192.168.1.0/24
    externhost = foo.dyndns.org
    externip = foo.dyndns.org
    port = 5060
    context = default
    maxexpirey = 3600
    defaultexpirey = 1200
    srvlookup = yes
    tos = 0x18
    disallow = all
    allow = gsm
    allow = alaw
    allow = ulaw
    allow = g729
    
    register => [email][email protected]:[email protected][/email]/tisphone
    
    [tisphone]
    host = sip.tiscali.de
    realm = tiscali.de
    fromuser = foo.bar
    fromdomain = tiscali.de
    user = foo.bar
    username = foo.bar
    secret = Passwort
    qualify = no
    nat = yes
    allow = ulaw
    allow = gsm
    allow = g729
    type = friend
    insecure=very;
    tos=0x18
    dtmfmode=info
    
    

    Wenn ich oben bei bindaddr 0.0.0.0 verwende, dann bekomme ich eine Fehlermeldung, dass ich Tiscali Access Produkte verwenden soll. Gibt es da eine andere Lösung?

    Vielen Dank,
    Nico
     
  2. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,284
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
  3. nico.ach

    nico.ach Neuer User

    Registriert seit:
    10 Sep. 2005
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi jo,

    also mit [email protected]:p[email protected]/[email protected] geht es auch nicht.

    Der Benutzername lautet ja eigentlich [email protected]. Bei der Ausgabe von sip debug faellt auf, dass die From:-Zeile so ausschaut:

    From: <sip:[email protected]>;tag=as21622ce7

    Und da ist es ganz unerheblich ob ich als username [email protected] oder foo.bar verwende. Nach Auskunft der technischen Hotline lautet der Benutzername auf jeden Fall [email protected]. Kann ich das @ nicht irgendwie escapen?
     
  4. nico.ach

    nico.ach Neuer User

    Registriert seit:
    10 Sep. 2005
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Komische Geschichte:

    Nachdem nun vor dem Linux-Router eine Fritz!Box Fon WLAN steht und das NAT uebernimmt, funktioniert die Geschichte ohne Probleme. Hab lediglich von Port 5060 auf 5061 gewechselt.

    Grüße,
    Nico