.titleBar { margin-bottom: 5px!important; }

Box meldet sich nach 30min beim VoIP ab! Was tun??

Dieses Thema im Forum "FRITZ!Box Fon: Telefonie" wurde erstellt von susanne, 7 Feb. 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Abhilfe schaft nur ein Neustart!!, denn selbst bei Eingabe des Befehl "voipd -R " ist die Box wieder bei den Tel-Prov. angemeldet, aber sie findet keinen Codex mehr.
    Wie bekommt man schnell Abhilfe?
     
  2. erik

    erik IPPF-Promi

    Registriert seit:
    30 Nov. 2004
    Beiträge:
    4,476
    Zustimmungen:
    10
    Punkte für Erfolge:
    38
    Etwas mehr Input führt zu etwas mehr Output. So wie Du es jetzt beschreibst, tippe ich auf Betrieb hinter einem Router.
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hi.
    Was für eine Antwort erwartest du? Button auf der Weboberfläche drücken?

    Die Box meldet sich beim Provider an. Und sagt ihm, dass die Registrierung 30min gültig ist.
    Da nach 30min kein reregister kommt, bist du halt nicht mehr angemeldet!
    Jetzt kannst du die ttl von 30min auf 24h stellen. Dann bist du halt 24h angemeldet.
    Und wenn die Box das nicht von alleine macht, musst du eben nachhelfen, wie auch immer...
    Geht das eigentlich bei der ATA? Wenn ja, warum?

    Am schnellsten bekommt man Abhilfe, wenn man die Fritz als DSL-Router betreibt. Sorry :)

    @erik
    Sie hätte vielleicht den Link auf ihren Problemthread posten sollen:
    http://www.ip-phone-forum.de/forum/viewtopic.php?p=80253#80253
    Ist leider etwas unübersichtlich geworden.

    MfG Oliver
     
  4. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Oliver, dein wissen in Ehren, aber warum deine ironische Reaktion!?
    "Was für eine Antwort erwartest du? Button auf der Weboberfläche drücken? "
    "Am schnellsten bekommt man Abhilfe, wenn man die Fritz als DSL-Router betreibt. Sorry"

    Denn wie du selbst schon festgestellt hast, ist der besagte Thread sehr unübersichtlich & die Chance der andere Profis die Problematik lesen eher unwarscheinlich.

    Und genau aus diesem Grund habe ich mich für die Eröffnung dieses Threads entschieden. Denn dein Lösungsweg muss ja nicht der einzigste sein!!!!! Wenn ich bedenke das es bis vor 3 Wochen keinen Lösung gab die FritzBox WLAN hinter einem anderem Router zu betreiben & Installation einer älteren Firmware war vor kurzen noch unmöglich.

    Und jetzt frag ich dich, wie lange wird schon an der FritzBox geforscht - sprich wie lange hat somit das finden von verschiedenen Möglichkeiten gedauert.

    Was will ich damit sagen, ganz einfach ich finde das Problem der Abmeldung für mehr als unschön & gehe davon aus das es auch dafür verschiedene Lösungswege gibt. Und damit ist dieser Thread mehr als gerechtfertigt!
     
  5. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,266
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    Susanne, Dein Input ist in der Tat etwas mager. Informationen zur Konfiguration und der eingesetzen Firmware helfen sicher das Problem einzugrenzen.

    Ich hatte mal ein ähnliches Problem mit der Box hinter einem Router. Ich habe dann mit einem cronjob alle 10 minuten voipd -R angestossen.

    jo
     
  6. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich "benutze" das mod. 23-iger von haveaniceday & dieses nochmlas mod. nach Markus => siehe http://www.ip-phone-forum.de/forum/viewtopic.php?p=80253#80253.

    Und somit läuft die Fritz hinter einem Router.

    Mich würde ja Eingangs interessieren, warum die Abmeldung vom VoIP Provider nur bei Einsatz der Fritz hinter einem anderen Router gemacht wird!? Nur um eure Lösungsvorschläge besser verstehen zu können.

    So nun zum Thema, Oliver machte den Vorschlag in der voip.cfg ttl=30m auf 24 Stunden zu stellen.
    Dein Vorschlag ist nun über cronjob aller 10min den Befehl voipd -r zu starten.

    Was von beiden ist denn die bessere Lösung?!

    Das Grundproblem ist das eure Vorschläge mit Sicherheit gut sind, aber ich
    keinen Plan von Cron habe & genau dies sollte man ja bei beiden Vorschlägen beherrschen.




    Edith!!!!!!!!!, leider scheint bei mir der Aufruf voipd -R auch nicht zu reichen, die Telnetausgabe sagt zwar korrekte Anmeldung, aber irgenwie scheint die Box keinen Zufriff auf die Codex zu haben. (wenn ich die telnet Ausg. korrekt verstehe)
    Hier ist mal der Ausschnitt.

    Sep 9 02:24:21 voipd[430]: query_local_ipaddress: 0.0.0.0
    Sep 9 02:24:21 voipd[430]: >>> Request: REGISTER sip:1und1.de
    Sep 9 02:24:21 voipd[430]: <<< Status: 200 OK
    Sep 9 02:24:21 voipd[430]: sip:49XXXXXXXXXXXXXXX@84.140.134.61:28875: REGISTER complete (next in 1620 seconds)
    Sep 9 02:24:28 voipd[430]: incoming(4:appl=2 plci=0x204 ncci=0x0 incoming): 11 49XXXXXXXXXXXXXXX <- 1
    Sep 9 02:24:28 voipd[430]: >>> Request: REGISTER sip:1und1.de
    Sep 9 02:24:28 voipd[430]: <<< Status: 401 Unauthorized
    Sep 9 02:24:28 voipd[430]: query_local_ipaddress: 0.0.0.0
    Sep 9 02:24:28 voipd[430]: >>> Request: REGISTER sip:1und1.de
    Sep 9 02:24:28 voipd[430]: <<< Status: 200 OK
    Sep 9 02:24:28 voipd[430]: sip:49XXXXXXXXXXXXXXX@84.140.134.61:28875: REGISTER complete (next in 1620 seconds)
    Sep 9 02:24:28 voipd[430]: add_suport_for_audio_codec: codec PCM not found
    Sep 9 02:24:28 voipd[430]: add_suport_for_audio_codec: codec PCU not found
    Sep 9 02:24:28 voipd[430]: >>> Request: INVITE sip:49XXXXXXXXXX@1und1.de
    Sep 9 02:24:31 voipd[430]: >>> Request: INVITE sip:49XXXXXXXXXXXXX@1und1.de
     
  7. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Was steht denn in der Codec Zeile deiner voip.cfg?
    Ist da beim ändern vielleicht was verlorengeganen?
    Telefonieren über voip geht noch?

    Meiner Meinung nach ist der voipd -R der bessere Vorschlag, da das auch funktioniert, wenn die externe Ip sich ändert.
    Bei query_local_ipaddress steht normalerweise die externe IP, da aber hinter Router, hat die Box keine?

    MfG Oliver
     
  8. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, telefonieren über VoiP funktioniert wunderbar, aber wie gesagt nur die ersten 30min nach einem reboot der Box.

    Und wie gesagt nach dem Befehl voipd -R ist die Anmeldung wieder o.k., aber die Box findet keinen Codex mehr.

    "Sep 9 02:24:28 voipd[430]: add_suport_for_audio_codec: codec PCM not found
    Sep 9 02:24:28 voipd[430]: add_suport_for_audio_codec: codec PCU not found "
     
  9. staudtm

    staudtm Neuer User

    Registriert seit:
    15 Jan. 2005
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Susanne,
    nach einigen Tagen Faschingsurlaub bin ich wieder da und schalte mich hier mal wieder ein.
    Das Problem mit der Registrierung beim SIP-Server hatte ich auch von Anfang an. Deshalb habe ich auch die MOD-Version von Haveaniceday installiert. Dort ist nämlich ein "crond" (-Daemon) enthalten. Mit dem kann man zeitgesteuert Programme aufrufen. Und genau das mache ich mit dem Aufruf von "voipd- R" alle 25 Min. . Dazu musst Du eine Zeile in der /var/flash/debug.cfg" einfügen. Wie das geht weisst Du? Ansonsten poste ich das heute Abend hier.
    Markus
     
  10. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi, Markus, es wäre Super wenn du es heute abend posten könntest. Danke

    Dann steht bloss noch das Problem, dass nach einem Aufruf von VoIP -R die Box die Codex nicht mehr findet.


    Code:
    voipcfg {
            dnsport = 7077;
            rtpport_start = 7078;
            ua1 {
                    enabled = yes;
                    username = "xxxxxxxxxxxxxX462UITCGBLLNSKNMSLP2PJOZRSHQKYGAAA";
                    authname = "";
                    passwd = "xxxxxxxxxxxxEJ2J2XVPFNGATGQJQ5TBV3KYNMUG622MEISHA6ZYSAAA";
                    registrar = "sipgate.de";
                    ttl = 30m;
                    sipping_enabled = no;
                    sipping_interval = 280s;
                    name = "xxxxxxxxxxxxx";
                    authenticatemode = authenticate_mode_none;
                    infodtmfnotsupported = no;
                    register_failwaitmax = 30m;
                    stunserver = "";
                    stunserverport = 3478;
            }
            ua2 {
                    enabled = yes;
                    username = "xxxxxxxxxxxxxxRDMQDY4M4MVKJT132PGR4A1QLFVBVPQ5Z5ZSNOYHLCYHYAAA";
                    authname = "";
                    passwd = "xxxxxxxxxxxxxxxxxNSEKYDUEQVSP1NUOW5NOORXDFKTMKXA52H2R5KBWROUTJUPZUMRSPP5DM5AAA";
                    registrar = "1und1.de";
                    ttl = 30m;
                    sipping_enabled = no;
                    sipping_interval = 280s;
                    name = "xxxxxxxxxxxxx";
                    authenticatemode = authenticate_mode_none;
                    infodtmfnotsupported = no;
                    register_failwaitmax = 30m;
                    stunserver = "";
                    stunserverport = 3478;
            }
            ua3 {
                    enabled = yes;
                    username = "xxxxxxxxxxxxxxxxxFABEXWW16HGWYW465R215SGTF4IOPY5X5II3UDMGFCL5DCAAA";
                    authname = "";
                    passwd = "xxxxxxxxxxxxxxx";
                    registrar = "freenet.de";
                    ttl = 30m;
                    sipping_enabled = no;
                    sipping_interval = 280s;
                    name = "xxxxxxxxxxx";
                    authenticatemode = authenticate_mode_allow;
                    infodtmfnotsupported = no;
                    register_failwaitmax = 30m;
                    stunserver = "";
                    stunserverport = 3478;
            }
            ua4 {
                    enabled = yes;
                    username = "xxxxxxxxxxxxxxxxUPICHFG4DVUHOACAJGDUDB3HXSDJZMB3AAA";
                    authname = "";
                    passwd = "xxxxxxxxxxxxxxxxBCEYNGPAHAQLLRB1HFRPTAGWDCIA4GX4VUNYCYBGPVLAD544YFT5YAAA";
                    registrar = "sip-gmx.net";
                    ttl = 30m;
                    sipping_enabled = no;
                    sipping_interval = 280s;
                    name = "xxxxxxxxxxxxx";
                    authenticatemode = authenticate_mode_allow;
                    infodtmfnotsupported = no;
                    register_failwaitmax = 30m;
                    stunserver = "";
                    stunserverport = 3478;
            }
            ua5 {
                    enabled = yes;
                    username = "xxxxxxxxxxxx4QJRXFJLKSOJEABNYTEEKGYQY1ID3C35AAA";
                    authname = "";
                    passwd = "xxxxxxxxxxxKKQZSLP3CPQVMKDD1QVA5CZE4TNBVXZJKVBLFSTHO3AAA";
                    registrar = "1und1.de";
                    ttl = 30m;
                    sipping_enabled = no;
                    sipping_interval = 280s;
                    name = "xxxxxxxxxxx";
                    authenticatemode = authenticate_mode_allow;
                    infodtmfnotsupported = no;
                    register_failwaitmax = 30m;
                    stunserver = "";
                    stunserverport = 3478;
            }
            use_audiocodecs = yes;
            audiocodecs = "G729", "G726-24", "G726-32", "G726-40", "PCM", "PCU";
            verbose = no;
            sip_prio = 0;
            rtp_prio = 0;
            dyn_codecs = yes;
            rtpstream {
                    voice_activity_detection {
                            enabled = no;
                            vad_threshold = 10000;
                    }
                    generate_noise {
                            on_packetloss = no;
                            on_capi_underrun = yes;
                    }
                    jitter {
                            auto_on = yes;
                            in_ms = 50;
                            in_packets = 0;
                    }
                    tx_packetsize_in_ms = 0;
            }
    }
    
    
    // EOF
    #
    
     
  11. staudtm

    staudtm Neuer User

    Registriert seit:
    15 Jan. 2005
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das mit den Codecs kann ich nicht so richtig glauben. Mal abgesehen von den Zeilen im LOG: funktioniert den das Telefonieren nach Aufruf von "voipd -R" nicht mehr?
    Markus
     
  12. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Anrufen ja, aber ich höre weder das klingeln noch kann ich mit dem angerufenen Sprechen!
    Manchmal geht auch garnichts nach der 30min. Abmeldung siehe =>

    Code:
    Sep  8 14:42:44 voipd[430]: add_suport_for_audio_codec: codec PCM not found
    Sep  8 14:42:44 voipd[430]: add_suport_for_audio_codec: codec PCU not found
    Sep  8 14:42:44 voipd[430]: >>> Request: INVITE sip:vvvvvvv@freenet.de
    Sep  8 14:42:46 voipd[430]: >>> Request: INVITE sip:xxxxxxxx@freenet.de
    Sep  8 14:42:46 voipd[430]: >>> Request: CANCEL sip:xxxxxxxxx@freenet.de 
    Und so sieht es nach einem Reboot aus =>


    Ich sehe gerade die Zeilen die Zeilen
    Code:
    Sep  8 14:42:44 voipd[430]: add_suport_for_audio_codec: codec PCM not found
    Sep  8 14:42:44 voipd[430]: add_suport_for_audio_codec: codec PCU not found  
    existieren auch dort.
    Aber dann geht es weiter mit
    "
    Code:
    Sep  8 14:04:31 voipd[430]: >>> Request: INVITE sip:49xxxxxxxx@1und1.de
    Sep  8 14:04:31 voipd[430]: <<< Status: 100 trying -- your call is important to " 
    Wenn ich das richtig deute sagt diese Zeile aus, dass der angerufene Anschluss antwortet. Also muss der Fehler doch woanders liegen!

    Aber poste bitte trotzdem mal deinen Lösungsvorschlag, vielleicht reicht es ja, wenn durch eine Erneuerung der Anmeldung die Box nie abgemeldet war.
     
  13. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hier steht ja auch PCM und PCU? Hast du das von Hand geändert, oder mit einem Patch von haveaniceday?
    Da muss PCMA und PCMU hin. Und das mit den dyn_codecs würde ich auf no setzten, da die Box die Codecs sonst selbst wählt. (Keine Ahnung wie.)

    MfG Oliver
     
  14. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja die sind von haveaniceday.
     
  15. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Seltsam, dass das noch keiner bemerkt hat, er hat es sogar in seinem Post falsch geschrieben!? (Copy&Paste/Post)

    Hab noch das hier gefunden:
     
  16. erik

    erik IPPF-Promi

    Registriert seit:
    30 Nov. 2004
    Beiträge:
    4,476
    Zustimmungen:
    10
    Punkte für Erfolge:
    38
    Nun verstehe ich bloß nicht, warum meine FBF ata ganz ohne Modifikationen registriert bleibt, ohne daß ich irgend etwas dafür tun muß. Der Router wird jede Nacht von 01.59 Uhr bis 02.00 Uhr abgeschaltet, um Zwangstrennung und Reset der Nat-Tabelle zu erreichen, die FBF bleibt registriert, solange man sie nicht vom Strom abklemmt. Lediglich nach einem Neustart der Box muß ich einmal den Hörer abnehmen, damit sich die Box erneut registriert.
     
  17. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    @erik
    Kannst du mal ein syslog posten?
    So mit 2 bis 3 Registrierungen...

    MfG Oliver
     
  18. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke, aber leider kann ich mit dieser Beschreibung nicht viel anfangen.
    Sind das die Befehler die ich nacheinander eingeben muss? Was kommt bei den Sternchen rein?


    Welchen Codex würdest du empfehlen?
     
  19. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Entweder editierst du die voip.cfg per Hand, und machst aus dem PCM und PCU -> PCMU und PCMA.
    Oder du nimmst einen anderen Patch von haveaniceday, oder du wartest ab bis er den Patch korrigiert und nimmst dann den...

    Zum cron: Das hier muss in die debug.cfg
    Code:
    15,45 7-23 * * * voipd -R > /tmp/crontab.log 
    
    Die Zeile mit dem cat <<EOP > /var/... müsste schon drinstehen.
     
  20. susanne

    susanne Aktives Mitglied

    Registriert seit:
    23 Dez. 2004
    Beiträge:
    1,861
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nö steht noch nicht drin: cat <<EOP > /var/.

    # cat /var/flash/debug.cfg
    /usr/sbin/telnetd &
    route add default gw 192.168.0.1
    voipd -R
    echo 8,2>/var/led

    Was kommt bei den Sternchen hin?
     
Status des Themas:
Es sind keine weiteren Antworten möglich.