Call failed: 404 Not Found mit x-lite und Asterisk

WildThing

Neuer User
Mitglied seit
22 Okt 2004
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Hallo alle zusammen,
wie am Titel schon zu erkennen ist habe ich ein Problem mit x-lite und meinem Asterisk.

Ich bekomme alle Anrufe, die über meine SIP-ID reinkommt, über den Asterisk geroutet.
Sobald ich aber versuche einen externen Call oder aber auch einen internen Call zu starten bekomme ich den Fehler "Call failed: 404 Not Found".

Ich habe hier im Forum gesucht bin aber nicht fündig geworden. Vielleicht kann mir ja jemand auf die Sprünge helfen.

Meine Konfiguration:
Suse 9.0
Asterisk Version 1.0.1
X-Lite unter Windows XP


SIP.CONF
[general]
context=default
port=5060
bindaddr=0.0.0.0
disalow=all
allow=gsm
allow=ulaw
allow=alwa
register => SIP-ID:p[email protected]/SIP-PROVIDER

[sipgate]
type=friend
username=SIP-IP
secret=PW
host=sipgate.de
fromuser=SIP-IP
fromdomain=sipgate.de
nat=yes
context=inbound
canreinvite=no
insecure=yes

[1234]
type=friend
username=1234
secret=PW1234
host=dynamic
dtmfmode=rfc2833
context=outbound

[4711]
type=friend
username=4711
secret=PW4711
host=dynamic
dtmfmode=rfc2833
context=outbound

[hr:258daac59f]

EXTENSIONS.CONF
[inbound]
exten => SIP-PROVIDER,1,Dial(SIP/1234,60)
exten => SIP-PROVIDER,2,Congestion
exten => SIP-PROVIDER,102,Busy

[1234]
exten => 1234,1,Dial(SIP/${EXTEN},60)
exten => 1234,2,Busy

[4711]
exten => 4711,1,Dial(SIP/${EXTEN},60)
exten => 4711,2,Busy

[outbound]
exten => _9.,1,Dial(SIP/${EXTEN:1}@sipgate,60)
exten => _9.,2,Congestion
exten => _9.,102, Busy

[hr:258daac59f]

X-Lite Proxy Settings
Username:1234
Authorization User:1234
Password:pW1234
Domain/Realm: Astersik IP
SIP Proxy: Astersik IP
Out Bound Prox: Astersik IP

[hr:258daac59f]

Danke im vorraus! (ich hoffe auf keine tippfehler)
Gruß Swen

Edit 22.10.2004 Änderung in Extensions.conf
 

CoAXx

Neuer User
Mitglied seit
9 Feb 2005
Beiträge
123
Punkte für Reaktionen
0
Punkte
16
Hallo,
ich habe exakt das gleiche Problem. Asterisk meldet om Log dass sich x-lite registriert, aber wenn ich mit xlite etwas wähle, sagt asterisk gar nichts und X-Lite gibt nur die 404er Meldung aus :(
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,901
Beiträge
2,027,943
Mitglieder
351,037
Neuestes Mitglied
st3phan