.titleBar { margin-bottom: 5px!important; }

Caller-ID des MWI setzen?

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von ike, 15 Sep. 2005.

  1. ike

    ike Aktives Mitglied

    Registriert seit:
    18 Apr. 2005
    Beiträge:
    1,004
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich hatte eben mit MWI und dem Snom190 so meine Erfahrungen gesammelt.

    Jedesmal, wenn ich die "Mailbox"-Taste gedrückt habe, bekam ich einen Fehler: "Not found: Unknown"

    Die Erklärung: Wenn man die Mailbox-Taste drückt, wird die Caller-ID angerufen, mit der der MWI gesendet wurde - und das scheint "Unknown" zu sein. Dies entspricht dem Eintrag "callerid" in der sip.conf. Wird dieser Eintrag geändert, wird der MWI unter dieser ID gesendet.

    Der Eintrag aus der sip.conf wird doch sicherlich immer genommen, wenn keine Caller-ID angegeben wurde. Wie aber gibt man bei MWI eine an?

    Ich wüsste im Moment nicht mal entfernt, wo ich nachschauen müsste.

    Wie kann ich das ändern?
     
  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    In neueren Versionen gibt es die Option vmexten. Bei älteren Versionen kannst du einfach die Extension anlegen, die die Telefone anrufen wollen und an die VoiceMail weiterleiten.
     
  3. Guard-X

    Guard-X Aktives Mitglied

    Registriert seit:
    14 Mai 2005
    Beiträge:
    2,497
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Aurich
    Hi ike,

    trage mal folgendes in deiner extensions.conf ein (im gleichen Kontext wie dein Telefon):

    exten => asterisk,1,VoiceMailMain()

    Das wird für MWI und SNOM 190/220/360 usw. benötigt!

    mfg Guard-X
     
  4. ike

    ike Aktives Mitglied

    Registriert seit:
    18 Apr. 2005
    Beiträge:
    1,004
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sehe ich es richtig, dass das erst bei der CVS-Version geht? http://www.voip-info.org/tiki-index.php?page=Asterisk+phone+snom

    Naja, dann muß ich also die Extension "Unknown" anlegen. Sieht natürlich blöde aus.

    Ich muß mal sehen, ob ich die Option "callerid" nicht missbrauchen kann. Wird die nur benötigt, wenn über SIP Gespräche ohne CID ankommen?

    Wir haben ja den Inbound ausschließlich über ISDN. Würde da die Einstellung überhaupt benutzt werden?

    Wenn nicht, dann könnte ich die Caller-ID doch eigentlich ungestraft auf z.B. "Mailbox" setzen, richtig?
     
  5. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das setzen der callerid wird dir hier überhaupt nix bringen. Der Parameter bewirkt nur, dass die CallerID von Anrufen, die von SIP-Usern ausgehen überschrieben wird (unabhängig davon ob sie bisher gesetz war oder nicht).

    Die Mailboxbenachrichtigung ist aber kein Anruf und geht auch von keinen SIP-User aus.
     
  6. ike

    ike Aktives Mitglied

    Registriert seit:
    18 Apr. 2005
    Beiträge:
    1,004
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Auch wenn es seltsam klingt. Es bringt wirklich was. Ich habe das ja ausprobiert. Das Snom ruft tatsächlich die Extension an, die per "callerid" in der sip.conf gesetzt wurde.

    Das kannst Du selber (falls Du Windows einsetzt) testen, indem Du Dir das Snom Softphone runterlädst. Das zeigt im Display sogar die Caller-ID an. "Mailbox von: ...@ip.des.asterisk.servers"

    Und genau diese dort angegebene Extension wird angerufen.

    Zu meinem System: Ich setze Asterisk@Home mit dem Bristuff-Patch ein.

    Wenn ich den callerid-Parameter auskommentiere, wird "Asterisk" als Absender benutzt.
     
  7. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wo genau steht in deiner Config dieser callerid-Parameter? Unter general oder beim User?

    Das von dir beschriebene verhalten klingt eher danach, dass der Parameter fromuser beim sip-User gesetzt wurde. Das hätte dan aber auch den Nachteil, dass alle Anrufe zu diesem User den eingesetzten Wert als CallerID hätten.
     
  8. tkrause_de

    tkrause_de Neuer User

    Registriert seit:
    16 Juni 2005
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Schau doch mal in SIP Logfiles das SNOM Telefons nach irgendwelchen NOTIFY Meldungen. Falls diese gar nicht ankommen ist es ein Asterisk Problem - andernfalls ein SNOM Problem. Die Meldung sieht so aus:

    Received from udp:10.1.1.35:5060 at 16/9/2005 14:09:26:910 (481 bytes):

    NOTIFY sip:618@10.1.1.36:5064;line=vits3vxr SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.35:5060;branch=z9hG4bK6f50305d
    From: "asterisk" <sip:asterisk@10.1.1.35>;tag=as2cc5ccb3
    To: <sip:618@10.1.1.36:5064;line=vits3vxr>
    Contact: <sip:asterisk@10.1.1.35>
    Call-ID: 4f191e4c1a4b1fa6439497520708888e@10.1.1.35
    CSeq: 102 NOTIFY
    User-Agent: Asterisk PBX
    Event: message-summary
    Content-Type: application/simple-message-summary
    Content-Length: 42

    Messages-Waiting: no
    Voice-Message: 0/2


    extension.conf
    Bei mir funktioniert folgendes prima:
    ; Fürs SNOM
    exten => asterisk,1,VoiceMailMain(${CALLERIDNUM})
    ; Mailbox von extern abfragen
    exten => 621,1,VoiceMailMain(s<mbox num>)

    und im SNOM würde ich bei Leitung X - Anrufbeantworter: asterisk eintragen, damit die Taste am Telefon auch funktioniert wenn keine neuen Nachrichten da sind.
     
  9. ike

    ike Aktives Mitglied

    Registriert seit:
    18 Apr. 2005
    Beiträge:
    1,004
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Taste gibt's aber nicht beim Snom 190, oder?

    BTW: Seitdem ich das "callerid=Unknown" entfernt habe, kommt auch der Rückruf für die TAPI von "asterisk" und nicht mehr von "Unknown".

    Der Eintrag müsste unter "general" gewesen sein, ich habe heute leider nicht nachgeschaut.