.titleBar { margin-bottom: 5px!important; }

CAPI wird nicht geladen, Asterisk startet nicht

Dieses Thema im Forum "Linux allgemein" wurde erstellt von nullehoppe, 6 März 2005.

  1. nullehoppe

    nullehoppe Neuer User

    Registriert seit:
    4 Jan. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab den * auf 3 versch. PCs versucht zu installieren, auf zweien gibts Probleme. Hab die Version von folgender seite genommen: http://www.asterisk.de.ms/
    So wies aussieht wird CAPI nicht geladen. Hab schon mehrere ISDN-Karten (FritzPCI, ISA) probiert, bekomm aber jedesmal denselben Fehler.
    Hier ein Auszug aus der Logdatei:
    Code:
    Mar  7 00:21:45 asterisk kernel: capifs: Rev 1.1.4.1
    Mar  7 00:21:45 asterisk kernel: capi20: started up with major 68
    Mar  7 00:21:45 asterisk kernel: kcapi: capi20 attached
    Mar  7 00:21:45 asterisk kernel: capi20: Rev 1.1.4.2: started up with major 68 (middleware+capifs)
    Mar  7 00:21:45 asterisk kernel: fcclassic: AVM FRITZ!Card Classic driver, revision 0.2
    Mar  7 00:21:45 asterisk kernel: fcclassic: (fcclassic built on May 25 2004 at 09:41:43)
    Mar  7 00:21:45 asterisk kernel: fcclassic: Loading...
    Mar  7 00:21:45 asterisk kernel: fcclassic: Driver 'fcclassic' attached to stack
    Mar  7 00:21:45 asterisk kernel: kcapi: driver fcclassic attached
    Mar  7 00:21:45 asterisk kernel: fcclassic: Loaded.
    Mar  7 00:21:46 asterisk kernel: invalid operand: 0000
    Mar  7 00:21:46 asterisk kernel: CPU:    0
    Mar  7 00:21:46 asterisk kernel: EIP:    0010:[ext3:__insmod_ext3_S.bss_L1152+686074/169326733]    Tainted: P
    Mar  7 00:21:46 asterisk kernel: EFLAGS: 00010202
    Mar  7 00:21:46 asterisk kernel: eax: 00000058   ebx: c56e1ed8   ecx: 00000054   edx: 00000005
    Mar  7 00:21:46 asterisk kernel: esi: c56e1f08   edi: c56e1f08   ebp: c56e1e60   esp: c56e1e48
    Mar  7 00:21:46 asterisk kernel: ds: 0018   es: 0018   ss: 0018
    Mar  7 00:21:46 asterisk kernel: Process capiinit (pid: 270, stackpage=c56e1000)
    Mar  7 00:21:46 asterisk kernel: Stack: c7cede68 00001199 c0148059 c7cf0800 00001199 0000003f c56e1e80 c88e6b56
    Mar  7 00:21:46 asterisk kernel:        00000054 c88e476c 00001199 c7cf0800 c01482b6 c7cf0800 c56e1eb0 c88e476c
    Mar  7 00:21:46 asterisk kernel:        00000054 c7b6af40 c7cf0800 c560a654 c56e1ed8 bffffd4c c560a3a0 c0148023
    Mar  7 00:21:46 asterisk kernel: Call Trace:    [get_new_inode+53/248] [ext3:__insmod_ext3_S.bss_L1152+686134/169326673] [ext3:__in
    Mar  7 00:21:46 asterisk kernel:   [unlock_new_inode+31/32] [proc_get_inode+93/304] [capi:__insmod_capi_O/lib/modules/2.4.21-i586-c
    Mar  7 00:21:46 asterisk kernel:   [sys_ioctl+539/564] [error_code+52/64] [system_call+51/64]
    Mar  7 00:21:46 asterisk kernel:
    Mar  7 00:21:46 asterisk kernel: Code: 0f 45 d0 83 c4 f8 8d 45 fc 50 52 e8 66 ff ff ff 89 c2 31 c9
    Versuche ich "capiinit" einzugeben, bekomme ich die Meldung Speicherzugriffsfehler.
    Hier noch ein Auszug der Ausgabe wenn ich versuche Asterisk zu starten:
    Code:
    Asterisk Dynamic Loader Starting:
      == Parsing '/etc/asterisk/modules.conf': Found
     [res_musiconhold.so] => (Music On Hold Resource)
      == Parsing '/etc/asterisk/musiconhold.conf': Found
      == Registered application 'MusicOnHold'
      == Registered application 'WaitMusicOnHold'
      == Registered application 'SetMusicOnHold'
     [chan_capi.so] => (Common ISDN API for Asterisk)
      == Parsing '/etc/asterisk/capi.conf': Found
    Mar  7 00:57:42 NOTICE[1024]: chan_capi.c:2626 load_module: CAPI not installed!
    Mar  7 00:57:42 WARNING[1024]: loader.c:313 ast_load_resource: chan_capi.so: load_module failed, returning -1
    Mar  7 00:57:42 WARNING[1024]: chan_capi.c:2801 unload_module: Unable to unregister from CAPI!
      == Unregistered channel type 'CAPI'
    Mar  7 00:57:42 WARNING[1024]: loader.c:359 load_modules: Loading module chan_capi.so failed!
    asterisk:~#
    
    Wie gesagt, Problem tritt auf 2 unterschiedlichen PCs mit unterschiedlicher Hardware auf, auf dem dritten PC läufts.

    Hat jemand ne Idee?
    Danke schonmal
     
  2. HoppaZ

    HoppaZ Neuer User

    Registriert seit:
    13 Apr. 2005
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Was möchtest du denn nu?
    Installation von der Capi oder asterisk starten.

    1. Welche Distribution?
    2. Wie hast du die Treiber installiert?
    3. Welcher Kernel?
     
  3. CaptainCrunch

    CaptainCrunch Neuer User

    Registriert seit:
    8 Apr. 2005
    Beiträge:
    169
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Anscheinend macht das Filesystem (in dem Fall ext3) Probleme. Ob das jetzt in direkter Linie etwas mit der FritzCard zu tun hat, lässt sich aus der Ferne schlecht beurteilen.
    Warum nutzt du nicht einfach eine "richtige" Distribution für diesen Zweck?

    Mal ganz nebenbei gefragt: Auch wenn's schon "eingedeutschte" Distributionen gibt, die speziell auf den * ausgelegt sind, wie wär's denn mal mit einer "richtigen", die auch vernünftig gepflegt wird? Basis könnte z.B. wunderbar Debian Sarge sein...
     
  4. dizi73

    dizi73 Neuer User

    Registriert seit:
    15 Feb. 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Network Architect
    Ort:
    BHM
    Hatte das gleich Problem mit FritzCard pnp

    Habe das Problem mit der Fritzcard pnp auch gehabt. Die Treiber fuer die FritzCrad pci funktionieren bei mir ganz gut. Ich denke, die Treiber fuer die "alte" Freitzcard pnp passen einfach nichtmehr zum Kernel.

    Hast Du denn in Deiner config die richtige Karte ausgewaehlt?

    Gruss dizi
     
  5. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Der AVM-Treiber sollte eigentlich für alle AVM-Karten funzen. Muss man bei den alten ISA-Karten nicht noch ne Adresse der Karte mit angeben, und die PnP Karten nicht noch vorher konfigurieren. DA gibt es (zu mindest bei debian) doch ein extra Paket (isapnpDingsbums, oder so).
    Musste ich mal bei einem alten Rechner mot ner PnP-Soundkarte nutzen. Bei der FrizzCard-Pnp kann das ja auch nich so viel anders sein. Ist ja das gleiche System.