Chan_capi modul im asterisk start fehlerhaft

TheDeath

Neuer User
Mitglied seit
17 Aug 2004
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
Ich such seit 2 Tagen nach hinweise zu meinem fehler, aber es gibt zwar ähnliche fehler, aber diese helfen mir in dem fall leider nicht .. ich hab ein bischen herumgewerkelt, und habe Asterisk, chan_capi, capi4ktools, den treiber der fritzcard installiert ..

modprobe fcpci
modprobe capi
capiinit
capiinfo

läuft alles wunderbar ... aber dann wollte ich "asterisk -vvvc" starten .. und nach ein paar erfolgreichen modul-ladungen kam das:

[res_parking.so] => (Call Parking Resource)
== Parsing '/etc/asterisk/parking.conf': Found
-- Registered extension context 'parkedcalls'
-- Added extension '701' priority 1 to parkedcalls
-- Added extension '702' priority 1 to parkedcalls
-- Added extension '703' priority 1 to parkedcalls
-- Added extension '704' priority 1 to parkedcalls
-- Added extension '705' priority 1 to parkedcalls
-- Added extension '706' priority 1 to parkedcalls
-- Added extension '707' priority 1 to parkedcalls
-- Added extension '708' priority 1 to parkedcalls
-- Added extension '709' priority 1 to parkedcalls
-- Added extension '710' priority 1 to parkedcalls
-- Added extension '711' priority 1 to parkedcalls
-- Added extension '712' priority 1 to parkedcalls
-- Added extension '713' priority 1 to parkedcalls
-- Added extension '714' priority 1 to parkedcalls
-- Added extension '715' priority 1 to parkedcalls
-- Added extension '716' priority 1 to parkedcalls
-- Added extension '717' priority 1 to parkedcalls
-- Added extension '718' priority 1 to parkedcalls
-- Added extension '719' priority 1 to parkedcalls
-- Added extension '720' priority 1 to parkedcalls
== Registered application 'ParkedCall'
== Manager registered action ParkedCalls
[chan_capi.so]Aug 17 10:41:01 WARNING[-150306688]: loader.c:242 ast_load_resource: /usr/lib/asterisk/modules/chan_capi.so: undefined symbol: ast_pthread_createAug 17 10:41:02 WARNING[-150306688]: loader.c:374 load_modules: Loading module chan_capi.so failed!
ich habs mal mit dem res_parking gepostet, damit man sieht, dass ich auch an das gedacht habe ..

achja .. verwendet hab ich:
chan_capi.0.3.5.
fcpci-suse9.1-3.11-02
asterisk-1.0-RC1

und ich bin auf einem Fedora Core 2 System ..

Vllt noch ein paar details an was ich arbeite:

ich habs geschafft, Asterisk mit PCs mit Softphones zum laufen zu bringen .. und jetzt will ich Asterisk an die ISDN-Telefonanlage stecken um sozusagen

ISDN telefon -> softphone

und umgekehrt zu ermöglichen

wenn wer Tipps oder links wie ich das am besten anstellen kann wär ich auch gleich dankbar :)

MfG Phil
 

rubinho

Mitglied
Mitglied seit
3 Aug 2004
Beiträge
207
Punkte für Reaktionen
0
Punkte
16
Also soweit ich weis hast Du den falschen Chan_Capi Treiber

für die Asterisk 1.0 RC1 Version musst Du die 0.3.4a nehmen.

Damit hats bei mir zumindest funktioniert.

Gruß
Rubinho
 

TheDeath

Neuer User
Mitglied seit
17 Aug 2004
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
Ok, werd ich versuchen, danke dir
 

TheDeath

Neuer User
Mitglied seit
17 Aug 2004
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
JA .. es geht :) ...

es klingelt .. nur ich muß noch konfigurieren, weil ich nur rausreden kann, aber ich hör das ISDN tel net .. oder ich kann ein ISDN tel nicht anwählen ..

sonst danke :)
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,158
Beiträge
2,030,791
Mitglieder
351,552
Neuestes Mitglied
mxfloeter