.titleBar { margin-bottom: 5px!important; }

Cisco 7940G - 1und1

Dieses Thema im Forum "Cisco" wurde erstellt von Argonox, 17 Juli 2005.

  1. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Leute,

    ich bin am verzweifeln. Hab euer Forum bis zum
    geht nicht mehr durchgestöbert aber nichts hat geholfen.

    Jetzt muss ich doch mal selber Posten.

    Also, habe einen Account bei 1und1 und dieser funzt ja wunderbar
    über X-Lite.

    Nur bei meinem Cisco phone steht halt immer ein kleines "X" neber dem telefonsymbol für leitung 1 und ich kann nicht raus wählen (besetzton und anzeige "reorder").
    Angerufen werden geht übrigens auch nicht.

    Über Telnet:
    ein ping zu 1und1.de funtzt.

    bei debug auth
    kann ich folgende fehlermeldung entdecken:
    E620 REG auth failed: no more credentials

    ich hab mehrmals überprüft:
    MEIN PW ist richtig eingeben.
    Auch line1_name steht meine 1und1 nummer
    als auch unter line1_auth.

    ich bin am verzweifeln.



    Hier meine settings.

    Bei mir ignoriert der über TFTP die Sipmac.cfg darum muss
    ich diese daten manuel ins phone eingeben.

    line1_name: 496474XXXXXX
    line1_auth: 496474XXXXXX
    line1_shortname: 1&1
    line1_proxyport: 5060
    line1_proxy: sip.1und1.de

    SIPDefault.cfg:

    Code:
    # SIP Default Generic Configuration File 
     
    # Image Version
    image_version: P0S3-07-5-00
    
    
    
    # Proxy Server
    proxy1_address: "sip.1und1.de"      ; Can be dotted IP or FQDN
    proxy2_address: ""      ; Can be dotted IP or FQDN
    proxy3_address: ""      ; Can be dotted IP or FQDN
    proxy4_address: ""      ; Can be dotted IP or FQDN
    proxy5_address: ""      ; Can be dotted IP or FQDN
    proxy6_address: ""      ; Can be dotted IP or FQDN
    
    # Proxy Server Port (default - 5060)
    proxy1_port: 5060
    proxy2_port: 5060
    proxy3_port: 5060
    proxy4_port: 5060
    proxy5_port: 5060
    proxy6_port: 5060
    
    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: 1
    
    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: 3600
    
    # Codec for media stream (g711ulaw (default), g711alaw, g729a)
    preferred_codec: g711ulaw
    
    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: 5
    
    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: 1
    
    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: avt
    
    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up)
    dtmf_db_level: 3
    
    # SIP Timers
    timer_t1: 500          ; Default 500 msec
    timer_t2: 4000          ; Default 4 sec
    sip_retx: 10         ; Default 10
    sip_invite_retx: 6       ; Default 6
    timer_invite_expires: 180    ; Default 180 sec
    
    ####### New Parameters added in Release 2.0 #######
    
    # Dialplan template (.xml format file relative to the TFTP root directory)
    dial_template: dialplan
    
    # TFTP Phone Specific Configuration File Directory
    tftp_cfg_dir: ""      ; Example:  ./sip_phone/
     
    # Time Server (There are multiple values and configurations refer to Admin Guide for Specifics)
    sntp_server: "217.10.79.4"   ; SNTP Server IP Address
    sntp_mode: directedbroadcast   ; unicast, multicast, anycast, or directedbroadcast (default)
    time_zone: CET         ; Time Zone Phone is in
    dst_offset: 1         ; Offset from Phone's time when DST is in effect
    dst_start_month: April      ; Month in which DST starts
    dst_start_day: ""      ; Day of month in which DST starts
    dst_start_day_of_week: Sun   ; Day of week in which DST starts
    dst_start_week_of_month: 1   ; Week of month in which DST starts
    dst_start_time: 02      ; Time of day in which DST starts
    dst_stop_month: Oct      ; Month in which DST stops
    dst_stop_day: ""      ; Day of month in which DST stops
    dst_stop_day_of_week: Sunday   ; Day of week in which DST stops
    dst_stop_week_of_month: 8   ; Week of month in which DST stops 8=last week of month
    dst_stop_time: 2      ; Time of day in which DST stops
    dst_auto_adjust: 1      ; Enable(1-Default)/Disable(0) DST automatic adjustment
    time_format_24hr: 1      ; Enable(1 - 24Hr Default)/Disable(0 - 12Hr)
    
    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    dnd_control: 0         ; Default 0 (Do Not Disturb feature is off)
    
    # Caller ID Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    callerid_blocking: 0      ; Default 0 (Disable sending all calls as anonymous)
    
    # Anonymous Call Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    anonymous_call_block: 0      ; Default 0 (Disable blocking of anonymous calls)
    
    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127)
    dtmf_avt_payload: 101      ; Default 101
    
    # Sync value of the phone used for remote reset
    sync: 1            ; Default 1
    
    ####### New Parameters added in Release 2.1 #######
    
    # Backup Proxy Support
    proxy_backup: ""      ; Dotted IP of Backup Proxy
    proxy_backup_port: 5060      ; Backup Proxy port (default is 5060)
    
    # Emergency Proxy Support
    proxy_emergency: ""       ; Dotted IP of Emergency Proxy
    proxy_emergency_port: 5060   ; Emergency Proxy port (default is 5060)
    
    # Configurable VAD option
    enable_vad: 0         ; VAD setting 0-disable (Default), 1-enable
    
    ####### New Parameters added in Release 2.2 ######
    
    # NAT/Firewall Traversal
    nat_enable: 1                   ; 0-Disabled (default), 1-Enabled
    nat_address: "meindyndns.ath.cx"   ; WAN IP address of NAT box (dotted IP or DNS A record only)
    voip_control_port: 5060         ; UDP port used for SIP messages (default - 5060)
    start_media_port: 16384    ; Start RTP range for media (default - 16384)
    end_media_port: 16390      ; End RTP range for media (default - 32766)
    nat_received_processing: 1   ; 0-Disabled (default), 1-Enabled
    
    # Outbound Proxy Support
    outbound_proxy: ""    ; restricted to dotted IP or DNS A record only
    outbound_proxy_port: 5060       ; default is 5060
    
    ####### New Parameter added in Release 3.0 #######
    
    # Allow for the bridge on a 3way call to join remaining parties upon hangup
    cnf_join_enable : 1      ; 0-Disabled, 1-Enabled (default)
    
    ####### New Parameters added in Release 3.1 #######
    
    # Allow Transfer to be completed while target phone is still ringing
    semi_attended_transfer: 1   ; 0-Disabled, 1-Enabled (default)
    
    # Telnet Level (enable or disable the ability to telnet into the phone)
    telnet_level: 2         ; 0-Disabled (default), 1-Enabled, 2-Privileged
    
    ####### New Parameters added in Release 4.0 #######
    
    # XML URLs
    services_url: ""      ; URL for external Phone Services
    directory_url: ""      ; URL for external Directory location
    logo_url: ""         ; URL for branding logo to be used on phone display
    
    # HTTP Proxy Support
    http_proxy_addr: ""      ; Address of HTTP Proxy server
    http_proxy_port: 80      ; Port of HTTP Proxy Server (80-default)
    
    # Dynamic DNS/TFTP Support
    dyn_dns_addr_1: ""              ; restricted to dotted IP
    dyn_dns_addr_2: ""              ; restricted to dotted IP
    dyn_tftp_addr: "192.168.0.10"               ; restricted to dotted IP
    
    # Remote Party ID
    remote_party_id: 0      ; 0-Disabled (default), 1-Enabled
    
    ####### New Parameters added in Release 4.4 #######
    
    # Call Hold Ringback (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    call_hold_ringback: 0      ; Default 0 (Call Hold Ringback feature is off)
    
    ####### New Parameters added in Release 6.0 #######
    
    # Dialtone Stutter for MWI
    stutter_msg_waiting: 0      ; 0-Disabled (default), 1-Enabled
    
    # RTP Call Statistics (SIP BYE/200 OK message exchange)
    call_stats: 0         ; 0-Disabled (default), 1-Enabled 
    
     
  2. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Wo hast du dein Proxy-Passwort gesetzt - deine manuellen settings sind nicht komplett!

    die ports (udp) müssen auf die IP des 7940 geforwarded werden:

    voip_control_port: 5060 ; UDP port used for SIP messages (default - 5060)
    start_media_port: 16384 ; Start RTP range for media (default - 16384)
    end_media_port: 16390 ; End RTP range for media (default - 32766)
     
  3. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sorry, hab vergessen das PW oben hinzuschreiben.
    Ist natürlich auch gesetzt.
    Diese settings hab ich über das Bildschirmmenü eingeben.

    Die Ports sind bereits an das Telefon geforwarded.
    Ich hab auch probiert das Telefon einfach mal im router in die DMZ zu setzen. Hat aber auch keinen erfolg gebracht.

    Gruß,

    Sven
     
  4. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    setze das mal auf 0:

    nat_received_processing: 0
     
  5. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habs gemacht,
    leider kein erfolg :-(

    was bedeutet dieser parameter eigentlich ?
     
  6. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    NAT received processing. Default is 0.

    If nat_received_processing is enabled, and received=tag
    is in the Via header of the 200 OK response from a
    REGISTER, the IP address in the received=tag is used
    instead of the nat_address in the Contact header. If this
    switch occurs, the phone unregisters the old IP address
    and reregisters with the new IP address.
     
  7. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    danke,

    leider hat es nichts gebracht den wert auf 0 zu setzen.

    Kennst du vielleicht nen telnet befehl wo ich genauer sehen kann warum die authentifizierung fehlgeschlagen ist?

    wegen:
    E620 REG auth failed: no more credentials
     
  8. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    credentials bedeutet: deine userid & password.

    Diese sind entweder falsch oder sipgate kann dir auf deine register-Anfrage nicht antworten, da deine öffentliche IP-Adresse nicht stimmt!

    Möglicherweise kann das 7940 dies nicht auflösen:

    nat_address: "meindyndns.ath.cx"

    setze doch spasseshalber hier mal deine aktuelle öffentliche IP ein und probiere es nocheinmal!

    PS: das phone kennt kein telnet.
     
  9. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    kannst du damit was anfangen? :


    habe mal "debug sip-task" gemacht




    Code:
    SIP Phone> debug sip-task
    Enabling bug logging on this terminal - use 'tty mon 0' to disable
    debugs: timestamp sip-task sip-reg-state
    SIP Phone> [18:29:29] ccsip_register_timeout_expire
    [18:29:29] ccsip_register_send_msg: cmd=0x161c04
    [18:29:29] SIPTaskProcessListEvent: cmd = 0x161c04
    [18:29:29] LINE 6/1: --0x0006ed61--     SIP_REG_STATE_IDLE<-E_SIP_REG_TMR_EXPIRE
    [18:29:29] ccsip_register_send_msg: cmd=0x161c01
    [18:29:29] SIPTaskProcessListEvent: cmd = 0x161c01
    [18:29:29] LINE 6/1: --0x0006ec41--                     : SIP_REG_STATE_IDLE <-
    E_SIP_REG_REG_REQ
    [18:29:29] LINE 6/1: Registration state change: SIP_REG_STATE_IDLE ---> SIP_REG_
    STATE_REGISTERING
    [18:29:29] SIPTaskProcessListEvent: cmd = 0x160200
    [18:29:29] SIPTaskProcessSIPMessage: Line filter: Determining destination line..
    .
    [18:29:29] SIPTaskProcessSIPMessage: Line filter: Call ID match:  Destination li
    ne = <6/1>.
    [18:29:29] SIPTaskProcessSIPMessage: Received SIP response.
    [18:29:29] SIPTaskProcessSIPMessage: Stopping any outstanding reTx timers...
    [18:29:29] SIPTaskProcessSIPMessage: Recv 4xx/5xx/6xx message.
    [18:29:29] LINE 6/1: --0x0006f7a5--                     : SIP_REG_STATE_REGISTER
    ING <- E_SIP_REG_4xx
    [18:29:29] SIPTaskProcessListEvent: cmd = 0x160200
    [18:29:29] SIPTaskProcessSIPMessage: Line filter: Determining destination line..
    .
    [18:29:29] SIPTaskProcessSIPMessage: Line filter: Call ID match:  Destination li
    ne = <6/1>.
    [18:29:29] SIPTaskProcessSIPMessage: Received SIP response.
    [18:29:29] SIPTaskProcessSIPMessage: Stopping any outstanding reTx timers...
    [18:29:29] SIPTaskProcessSIPMessage: Recv 4xx/5xx/6xx message.
    [18:29:29] LINE 6/1: --0x0006f7a5--                     : SIP_REG_STATE_REGISTER
    ING <- E_SIP_REG_4xx
    [18:29:29] LINE 6/1: no more credentials
    [18:29:29] LINE 6/1: Registration state change: SIP_REG_STATE_REGISTERING ---> S
    IP_REG_STATE_IDLE
    [18:29:29] %E620 REG auth failed: no more credentials
    
     
  10. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    also mit meiner IP Nummer hats auch nicht gefunzt.

    In dem Protoll welches ich einen Threat drüber gepostet habe, steht ja "Received SIP response".. also bekommt er schonmal kontakt oder ?

    kann es sein, das der probleme mit der Bildschirmeingabe von den benutzerdaten hat ?

    Muss ich vielleicht zwangsweise die SIPMac.cfg zum laufen bekommen ?
     
  11. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Ich denke nicht - allerdings hast du bei den account-Daten genau auf Gross- und Kleinschreibung geachtet?
     
  12. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Das phone läuft auf dem port 5060. Auf welchem port läuft X-Lite bzw. ist das port-forwarding richtig (eindeutig)?
     
  13. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Netview !

    ERSTMAL VIELEN VIELEN DANK für Deine Komptente Unterstützung.

    Es funktioniert jetzt.

    Also es lag nicht an der Groß und Kleinschreibung

    AABER:

    irgendwie hat cisco offensichtlich total die komplexe wenn im pw ein
    mix aus zahlen und buchstaben vorhanden ist.

    Ich schließe darauf, weil ich mir sicher bin, dass ich die buchstaben
    immer klein eingeben habe (wie sich auch im account definiert sind).
    UND weil ich das selbe kennwort bei meinem freenet account verwende
    und es dort auch nicht funzt.

    Ich habe meinen 1und1 account nun auf reine zahlen umgestellt... und siehe da ! ES GEHT !!!
     
  14. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Na - dann noch viel Spass mit deinem 7940!
     
  15. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    @Argonox
    Das ist ein mir bisher unbekanntes Problem mit den Cisco-Telefonen! Ich habe ab und zu schonmal einen neuen Account per Menü-Eingabe gestestet, bevor ich dann die *.cnf geändert habe. Ich bin mir auch sicher, daß die Passwörter niemals ausschließlich numerisch waren. Allerdings kann ich nicht sagen, ob die Buchstaben klein- oder großgeschrieben waren. Aber gute Info - muß man also anscheinend vorsichtig sein...

    Aber ansonsten auch: Viel Spaß damit!

    @Netview
    Wieso meinst Du, das Cisco hätte kein Telnet? Viele nette Sachen gehen nur per Telnet ;-) Du mußt das nur in einer der Konfigdateien aktivieren. Bei mir in der SIPDefault.cnf
    Code:
    telnet_level: 2                 ; 0-Disabled (default), 1-Enabled, 2-Privileged
     
  16. Argonox

    Argonox Neuer User

    Registriert seit:
    17 Juli 2005
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  17. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    @RB

    ähhh - vermutlich weil ich mein phone unter sccp betreibe und ich da zumindest nicht per telnet rangekommen bin :(

    Hast du da einen Tipp für mich?
     
  18. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    @Netview
    Da hapert's bei mir wiederum etwas. Ich weiß wohl, daß es da eine Web-Oberfläche geben soll. Aber ansonsten muß ich passen :-(
     
  19. cisco-fan

    cisco-fan Neuer User

    Registriert seit:
    7 März 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Offenbach am Main
    Argonox
    ich hatte das Problem mit 1und1 und dem "nicht hörenden GP" auch. Aber mit web.de ging's komischerweise!
    Hier im Forum stand was von V7.4 nehmen!!
    Das war beim mir die Lösung!
    Keine Konfigänderung nur die alte Software und schon gings.
    (ich habe ein passwort mit Zahlen und Zeichen!?)
    Aktuell kannst du auch die 8.2 nehmen.