.titleBar { margin-bottom: 5px!important; }

Cisco Phone über zweite NIC am PC und dann raus

Dieses Thema im Forum "Cisco" wurde erstellt von mick666, 1 Dez. 2004.

  1. mick666

    mick666 Neuer User

    Registriert seit:
    28 Nov. 2004
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    nachdem ich mit eurer Hilfe mein 7940 an Sipgate angebunden habe, kommt jetzt Level 2 meines VoIP-Projektes und vielleicht (ich bin mir eigentlich ganz sicher) habt ihr auch hier ein paar gute Tips für mich.

    Also, ich habe einen DLink Router (DI-614+) mit dem mein Cisco Phone direkt angeschlossen 1a funktioniert. Leider musste ich aus Räumlichen Gründen den Router ins Wohnzimmer packen und meinen PC natürlich ins Arbeitszimmer (Wo auch mein Cisco Phone steht). Weil ich keine Lust hatte meine Fliesen aufzustemmen musste ich meinen PC per WLAN anbinden.
    Mein PC hat eine eigene WLAN Karte und natürlich noch ein Paar "normale" Ethernet Ports.

    Ich möchte jetzt mein Cisco Phone an meinem PC anschliessen, so das ich schon von meinem Schreibtisch aus telefonieren kann. Ich habe das auch fast geschafft oder besser gesagt, ich kann rauswählen, kann aber nicht angerufen werden.

    Ich gehe jetzt mal ein bisschen ins Detail. Vielleicht habe ich ja auch irgendwo einen Gedankenfehler.
    Hier erstmal ein paar IP Adresse.
    Mein DLink Router hat die 192.168.1.1, der PC über WLAN hat die 192.168.1.11, der LAN Anschluß am PC hat die 192.168.2.11 und das Cisco Phone hat die 192.168.2.100.

    An meinem Router habe ich gesagt, dass die 192.168.1.11 (Also mein PC) auf die Ports 5060 und 5004-5007 durch dürfen.

    Mein PC (WindowsXP pro hat für die LAN Adresse die 192.168.2.11/24 ohne Gateway (Das ist ja auf der WLAN Karte definiert)

    Eine lokale Firewall ist nicht installiert.

    Mein Cisco Phone hat wie gesagt, die 192.168.2.100/24
    Default Router ist mein PC (192.168.2.11). Als DNS Server habe ich die offiziellen der Telekom genommen.

    So, ich kann an meinem Telefon nun Anrufen, kann Newsfeeds mir anschauen und kann auch pingen (Wenn ich per Telnet z.B. ein Ping auf sipgate.de mache).
    Was ich aber nicht kann ist zum einen nicht angerufen werden. Auf der Sipgate Seite ist mein Status als Offline (Obwohl ich anrufen kann) und was ich gerade festgestellt habe ist, dass wenn ich das Voicemail (Nr. 50000) anrufe, meine Sipgate-ID nicht übertragen wird, sprich er erkennt wohl nicht mein Phone.

    Meine Defaultkonfig sieht so aus:

    # SIP Default Generic Configuration File

    # Image Version
    image_version: P0S3-07-3-00

    proxy1_address: "sipgate.de"

    proxy1_port: 5060

    proxy_register: 0

    timer_register_expires: 3600

    preferred_codec: g711ulaw

    tos_media: 5

    sntp_server: "217.10.79.4"
    sntp_mode: unicast
    time_zone: CET
    dst_auto_adjust: 1
    dst_offset: 1
    time_format_24hr: 1
    date_format: D/M/Y

    dnd_control: 0

    callerid_blocking: 0

    anonymous_call_block: 0

    nat_enable: 1
    nat_address: ""
    voip_control_port: 5060
    start_media_port: 5004
    end_media_port: 5007
    nat_received_processing: 1

    outbound_proxy: ""
    outbound_proxy_port: 5060

    telnet_level: 2

    services_url: ""
    directory_url: ""
    logo_url: ""

    http_proxy_addr: ""
    http_proxy_port: 80

    call_hold_ringback: 0

    stutter_msg_waiting: 0 ; 0-Disabled (default), 1-Enabled

    call_stats: 0 ; 0-Disabled (default), 1-Enabled

    Hat jemand eine Idee, was ich noch tun kann, damit der Rest auch funktioniert??? Leider bringt ein Debug des Phones nix, weil ja schon garnichts ankommt, zumindestens sehe ich keine Einträge.

    Bin für jeden Tip echt dankbar.


    Nachtrag
    Kaum überlegt man mal selber kommt man auch drauf ;-)
    Ich habe folgende Zeilen geändert:

    proxy1_address: "sipgate.de"
    proxy1_port: 5060
    proxy_register: 1
    outbound_proxy: "sipgate.de"
    outbound_proxy_port: 5060

    Und schon geht alles. Super geil, sogar über WLAN kein Problem ;-)

    Ich bin quasi begeistert
     
  2. cobra

    cobra Neuer User

    Registriert seit:
    15 Nov. 2004
    Beiträge:
    197
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT Project Manager
    Ort:
    JWD
    Hallo Mick!

    Mich wundert es ein wenig, dass es vorher mit dieser Config funktioniert hat.
    Ich muss bei mit Proxy-Register auf 1 setzen, damit ueberhaupt etwas geht.

    Hast Du die Ports nur fuer den PC freigeschaltet, oder auch fuer das Phone? Ober betreibt der PC NAT?

    Gruss
    Michael
     
  3. mick666

    mick666 Neuer User

    Registriert seit:
    28 Nov. 2004
    Beiträge:
    18
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Am PC habe ich nix geändert, nur die IP so eingetragen wie beschrieben.
    An der Firewall habe ich die IP des PCs freigegeben.

    Habe gerade schon 10 Minturen über das Phone geredet und kein Aussetzer und nix und das obwohl ich hier noch am surfen war.

    Ich bin Begeistert