.titleBar { margin-bottom: 5px!important; }

cron; will nicht :-(

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Lindemann, 24 Jan. 2006.

  1. Lindemann

    Lindemann Neuer User

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    die Threads zu crond habe ich verfolgt, auch die bins gezogen und per debug.cfg geladen.

    Nach wget der bins
    folgt

    chmod +x crond
    chmod 777 crontabs
    /var/tmp/crond -d4 -c /var/tmp -S

    jedoch passiert nix. Da ich syslogd auf den win32 Rechner verbogen habe, kann ich die Ausgaben der Box sehr gut verfolgen, aber vom crond ist leider nix da.

    fuehrt man crond
    mit /var/tmp/crond -?

    folgt
    crond: /var/spool/cron/crontabs: No such file or directory


    Inhalt der crontabs
    0-59/2 * * * * voipd -R
    0-59/2 * * * * logger SIP-Registrierung per crond

    Wenn ich logger xxx auf der Box ausfuehre, kann ich es per syslog sehen. Aber genau wie der voipd -R wird dieser Befhel nciht ausgefuehrt.

    mkdir /var/spool/cron
    und
    mv /var/tmp/crontabs /var/spool/cron/crontabs
    in der debug.cfg funktioniert nicht. Nachtraeglich kann ich per ftp das Verzeichnis anlegen. Wieseo klappt es nicht per debug.cfg ?

    Hat jemand den crond mit seiner crontabs auf der Box verifizierbar laufen ?

    Danke vorab.
    Gruss
    Lindemann

    PS: es gibt eine 36k grosse win32 bin die auf 514 horcht.
    Syslogd 1.0
    Copyright (c) 2000, Herbert Hanewinkel, Neuried
    heha@altavista.net
    www.heha.cjb.net

    Wenn man noch das Fenster des Links der Exe auf 80*140 stellt, ist es sehr bequem und ohne Umbrueche eine realtime-Verfolgung des syslogd auf der win32-Maschine sehr gut moeglich. Ein vernueftiges tail.exe fuer win32, das eine Datei mit x Zeilen aktuell anzeigt habe ich nicht gefunde, deswegen die syslogd.exe.
     
  2. danisahne

    danisahne Aktives Mitglied

    Registriert seit:
    30 Juli 2005
    Beiträge:
    1,493
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Informatik Studium
    Ort:
    Marktoberdorf
    Hast du es schon per Hand probiert, das was in der debug.cfg steht? Ich kann mir nicht vorstellen, dass `mkdir /var/spool/cron' funktioniert, weil das Verzeichnis /var/spool noch nicht existiert. Versuch mal:
    Code:
    mkdir -p /var/spool/cron
    Mfg,
    danisahne
     
  3. Lindemann

    Lindemann Neuer User

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ... immer noch nicht

    Hallo,

    nochmal das Verzeichnis mit -p angelegt, doch leider nix. Er will ja auch

    /var/spool/cron/crontabs

    sehen. :).
    Nach einem manuellen mkdir startete das Ding auch.

    2006.24.01-15:13:52 fritzbox.XXXXXXX, <77>crond[635]: crond 2.3.2 dillon, started, log level 8

    Mit -c kann man den cron entweder auf das o.a. Verzeichnis oder auf /var/tmp setzen. Auch dies fuehrte zu keinem Erfolg. Nur der Start wird per syslog gemeldet aber kein Job wird zyklisch ausgefuehrt.
    Alle Rechte sind auf der crontabs vergeben, auch wenn man root ist.

    Any idea ?

    Gruss
    Lindemann
     
  4. danisahne

    danisahne Aktives Mitglied

    Registriert seit:
    30 Juli 2005
    Beiträge:
    1,493
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Informatik Studium
    Ort:
    Marktoberdorf
    Jetzt poste mal dein gesamtes Skript, so können wir ja nur im Dunkeln tappen. Wenn etwas manuell funktioniert, dann muss es auch im Skript gehen.
     
  5. buehmann

    buehmann Aktives Mitglied

    Registriert seit:
    11 Juni 2005
    Beiträge:
    1,810
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi, die Datei, in der die Jobs eingetragen sind (also deine "Crontab"), muss in dem Verzeichnis /var/spool/cron/crontabs (oder in dem, dass du per -c angibst) liegen und so heißen wie der Benutzer, mit dessen Rechten die Jobs ausgeführt werden sollen; in unserem Fall also fast immer "root" (und nicht "crontabs"! Bei dir findet der crond die Datei "crontabs", findet keinen Benutzer gleichen Namens und überspringt die Datei daher).

    Gruß,
    Andreas
     
  6. Lindemann

    Lindemann Neuer User

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    *heureka*; crond OK (somit auch die Kombination fli4l 2.0.7/8+FBox als IPClient)

    Hallo,

    das war es, die crontabs in /var/tmp in root umbenannt und syslogd meldete die eingetragenen Jobs. :))

    ******* DANKE ********


    ###################################################
    ....
    wget http://192.168.XX.YY:8088/fritz/crond
    ....
    ....
    chmod +x /var/tmp/crond
    echo "0-59/2 * * * * voipd -R" >> /var/tmp/root
    echo "0-59/2 * * * * logger SIP-Registrierung per crond" >> /var/tmp/root
    echo "0-59/1 * * * * logger [----**---- 1min MARK fritzbox ----**----]" >> /var/tmp/root
    chmod 777 /var/tmp/root
    /var/tmp/crond -c /var/tmp -S
    ###################################################

    fuehrt zu:

    2006.24.01-21:00:00 fritzbox.XXXXXXXX.de, <77>crond[433]: USER root pid 1613 cmd voipd -R
    2006.24.01-21:00:00 fritzbox.XXXXXXXX.de, <77>crond[433]: USER root pid 1614 cmd logger SIP-Registrierung per crond
    2006.24.01-21:00:00 fritzbox.XXXXXXXX.de, <77>crond[433]: USER root pid 1616 cmd logger [----**---- 1min MARK fritzbox ----**----]

    ###################################################
    Erfahrungsbericht; vielleicht hilft dieser und jener Ansatz einem anderen:

    Ich habe den cronjob gebraucht, weil die FBox 7050 hinter einem Fli4l **V2.0.7/8** -nicht 2.1.x und auch nicht 3.0.0, da fehlen mir srv.Pakete- laufen soll.
    Seit mehreren Tagen sieht es sehr gut aus. Sehr funktional und unauffaellig. So unauffaellig, dass die Oma, per Siemens Gigaset ueber Funk-DECT 1000 an S 1054 angebunden ihre Leitung/ihr Telefon ohne Probleme weiternutzt. Die Anrufe kommen (auch per Inet) rein und gehen auch per Internet ab.

    Dazu waren einige Modifikationen notwendig, die ich aus diesem und Fli4l Foren erfahren, getestet habe. Weiterhin habe ich das UDP-Masq. modifiziert.

    in fwrules:
    /sbin/ipchains -M -S 3600 300 600
    ->
    /sbin/ipchains -M -S 3600 300 60
    Somit ist das UDP masq stark verkuerzt, bisher hat keine Applikation weder auf dem Router (srv.-services, ja da laufen viele :)) noch auf den Clients diese Einstellung moniert.

    an portfwd sind folgende Einstllungen in der rc.cfg:
    PORTFW_N='39'
    PORTFW_1='3478 192.168.XX.YY:3478 udp'
    PORTFW_2='3479 192.168.XX.YY:3479 udp'
    PORTFW_3='5060 192.168.XX.YY:5060 udp'
    PORTFW_4='7080 192.168.XX.YY:7080 udp'
    PORTFW_5='7081 192.168.XX.YY:7081 udp'
    PORTFW_6='30000 192.168.XX.YY:30000 udp'
    PORTFW_7='30001 192.168.XX.YY:30001 udp'
    PORTFW_8='30002 192.168.XX.YY:30002 udp'
    PORTFW_9='30003 192.168.XX.YY:30003 udp'
    PORTFW_10='30004 192.168.XX.YY:30004 udp'
    PORTFW_11='30005 192.168.XX.YY:30005 udp'
    PORTFW_12='5004 192.168.XX.YY:5004 udp'
    PORTFW_13='10000 192.168.XX.YY:10000 udp'
    PORTFW_14='5062 192.168.XX.YY:5062 udp'
    PORTFW_15='5070 192.168.XX.YY:5070 udp'
    PORTFW_16='5071 192.168.XX.YY:5071 udp'
    PORTFW_17='5072 192.168.XX.YY:5072 udp'
    PORTFW_18='7077 192.168.XX.YY:7077 udp'
    PORTFW_19='7078 192.168.XX.YY:7078 udp'
    PORTFW_20='7079 192.168.XX.YY:7079 udp'
    ....

    Ergaenzung in der FW:
    FIREWALL_DENY_PORT_19='5000:5003 REJECT'
    FIREWALL_DENY_PORT_20='5005:5010 REJECT'

    da auf 5000/1 der imond/telmond lauschen.

    Noch ist zu erurieren, ob **alle** Ports fuer die normale Telephonie (ohne Softphones) benoetigt werden. Wahrscheinlich eher nicht, doch sie schaden jetzt aktuell auch nicht. Im betrieb ohne ein Telephonat meldet der Router, dass per UDP:5060 auf die Fbox eine Verbindung besteht. Kein anderer Port wird angezeigt.

    SIP_INBOUND='eth0'
    SIP_OUTBOUND='ppp0'
    SIP_HOSTS_ALLOW_REG='192.168.0.0/16'
    SIP_HOSTS_ALLOW_SIP='192.168.0.0/16'
    SIP_HOSTS_DENY_SIP=''
    SIP_PORT_LOW='5070'
    SIP_PORT_HIGH='5079'

    Ist auch als OPT installiert.

    Die debug.cfg der FBox enthaelt (unter anderem auch):
    echo "route add default gw 192.168.XXX.1" >> /var/tmp/debug.cfg
    Die dns-Eintraege zeigen auf den Router, IP-Adresse = 192.168.XXX.1

    ad Zwangstrennung:
    Ein ping crond-Job a 5 min 6x auf dem Fli4l haelt die Leitung tagsueber auf.
    Per crond (auf dem Fli4l) wird die Leitung nachts fuer 2,5x der UDP masq Timeout-Zeit, also 60*2,5 = 150s getrennt und durch

    { echo "disable"; echo "quit"; } | netcat localhost 5000
    { echo "hangup"; echo "quit"; } | netcat localhost 5000

    auch verhindert (keine Auto-Einwahl, steht auf "Aus"), dass ein Prozess die Leitung vor dem Ablauf der UDP-Timeout hochzieht, noch bevor die Routen sauber abgeraeumt sind. Mit den 2,5 min sind auch die 24 h nicht voll erfuellt.

    Ein

    { echo "enable"; echo "quit"; } | netcat localhost 5000
    echo "Der Einwahlmodus wird wieder auf auto gesetzt, die Einwahl erfolgt sogleich"|logger -t [24 Trennung]
    # waehlt den default-Provider an
    { echo "dial"; echo "quit"; } | netcat localhost 5000

    ermoeglicht, wenn kein anderer Prozess aufmacht, spaetestens dem ping-Prozess oder dem crond-Registrierungs-Prozess [deswegen die Anfrage hier im Forum] auf der 7050 automatisch wieder die Verbindung ins Internet herzustellen.

    Leider stellte ich fest, das ist noch spaeter zu verifizieren wie jetzt die FBox sich verhaelt, dass nachdem der Router tagsueber und unerwartet auflegte (z.B. bei der Umschaltung auf 2 Mbit) erst ein voipd -R ermoeglichte ueber das Internet zu telephonieren. Das macht jetzt zyklisch der crond auf der FBox.

    Ich denke auch, dass

    sipping_enabled = yes;
    sipping_interval = 30s; [von 280s auf 30s verkuerzt]

    in der voip.cfg wichtig ist.

    Denn das Einspielen des International-Patchs ueber die debug.cfg hatte diese Werte wieder auf reset/default gestellt. Danach war das In-Out nicht mehr moeglich. Vielleicht langt auch nur diese Einstellung + der crond voipd-R Job auf der FBox, damit die FBox hinter einem Fli4l 2.0.7/8 sauber funktioniert ?

    Abgesehen davon, nicht alle Funktionen des Fli4l auf der 3.0.0 abbilden zu koennen, bringt diese im ersten Moment etwas frustrane Situation auch paar Vorteile mit sich, als da sind:

    * Nicht immense Zeit in den Aufbau/Erweiterung des 3.0.0 stecken zu muessen
    * im DSL haengt die FBox hinter dem Router, bei ISDN genau anders=>
    Anrufe koennen per Vbox des Fli4l angenommen, mail ueber verpasste Anrufe kann auch fuer die Inetnummern konfiguriert werden (der Websrv, der Fbox ist eher traege, wenn er die Liste holt/darstellt)
    * Faxe koennen mit 01033 (oder eine anderer Provider) trotzdem ueber die Box versandt werden
    * Das Volumen, welches von der FBox verursacht wird, ist auf dem mini-httpd des Fli erfassbar, OPT-Trafficlog (OK, hat sie auch irgendwo, jedoch nicht als IP-Client)
    * vpn/mail/AB/Fax/samba/sane/nfs (gar ntop) weiterhin auf dem Fli nutzbar.
    ....

    Das zeigt nur, dass der Fli4l ein tolles Stueck Soft- und Brainware ist, aber auch, dass es heute noch in der **alten** Version seinen alten *und* neuen Aufgaben vollends genuegt (OK, kein USB, Bluetooth, WLAN-AP ..).

    Ich habe dies mal zusammengeschrieben, weil es zeigt, dass F2.0.7 mit neuer Technologie sich gut (?) vertraegt. Dazu gab es *wenig* pos. Meldungen, eher Gegenteiliges und immer der Hinweis auf 2.1.x oder 3.0.0.

    q.e.d :))



    Unsere Umgebung:
    AVM 7050 von 1und1 (Dez. Angebot 1und1) FW-14.03.89, keine FW mods, nur debug.cfg Erweiterung mit ftp/telnet/wds/Enum/jetzt auch crond

    Fli4l 2.0.7/8 mit ca 96 :)) Paketen, absolut stabil und hochfunktional (fraglich ,ob ein 3.0.0 je so eine Funktionalitaet erreichen wird)

    Telefon, Siemens Gigaset-Uralt-Modell 1054 mit 1000C, sieben MSN, eine als Inet registriert.

    Provider 1und1 mit 2M/192k, mit ohne garnichts (fastpath oder so.)

    Die Inet-1und1-Nummern funktionieren mit den voreingestellten Parametern oder mit *anderer Anbieter*.

    Vielleicht hilft es jemandem weiter, viel Erfolg.

    Gruss
    Lindemann