[Problem] E-Mail Versand mit Cron

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,629
Punkte für Reaktionen
1,189
Punkte
113
Bei allem Verständnis (bzw. bei aller "Dankbarkeit" für die prompte Befolgung meines Vorschlags) ... aber mit:
und vergleiche den Inhalt des Environments in den beiden Fällen
meinte ich schon "selbst vergleichen" und nicht nur, die hier anderen "vorzusetzen", auf daß sie die für Dich vergleichen mögen.

Denn wenn ich nur einen ganz vorsichtigen Blick in die beiden Dateien riskiere (dafür gibt es ja Programme, das muß ja niemand von Hand prüfen), dann stelle ich für meinen Teil sofort fest, daß sich der Wert von LD_LIBRARY_PATH tatsächlich in beiden unterscheidet:
compare.PNG
und wenn man dann noch einen Blick in das Verzeichnis wirft, was bei der funktionierenden Variante eben genau nicht in dieser Verzeichnisliste ist (das wäre dann /usr/lib/freetz) und dabei dann feststellt, daß sich darin genau die Bibliotheken der uClibc-ng 1.0.36 befinden, während die AVM-Programme ja eigentlich 1.0.31 erwarten, dann kommt man fast zwangsläufig zu dem Schluß, daß meine Angabe weiter oben, daß da irgendetwas mit dieser Variablen nicht stimmt, auch hier zutreffen dürfte.

Das fällt halt bei anderen Kommandos nicht so sehr auf, weil die eher selten AVM-Programme aufrufen, die gegen die 1.0.31 gelinkt sind - üblicherweise rufen eben Freetz-Skripte und -Kommandos auch nur die Binaries auf, die neu dazu gekommen sind und die sind ja gegen die 1.0.36 gelinkt. Nun ruft aber genau das "/usr/bin/mail" (ein Shell-Skript, siehe oben) seinerseits ein AVM-Programm (nämlich "/sbin/mailer") auf ... und bei diesem Aufruf muß man eben dafür sorgen, daß das Verzeichnis "/usr/lib/freetz" sich nicht im Suchpfad für Bibliotheken befindet, damit eben Namen (bzw. Symlinks) wie "ld-uClibc.so.1" auch auf die passende Datei verweisen und das ist für "mailer" nun mal die, welche AVM in der originalen Firmware verwendet.

Von hier an solltest Du Dir dann aber auch selbst helfen können (notfalls hilft es eben auch, ein wenig "im Internet" zu lesen, wenn Du Dich mit Suchreihenfolgen, den LD-Variablen für den dynamischen Loader und Bibliotheken im Allgemeinen so gar nicht auskennst) - die Ursache ist jedenfalls (für mich) schon mal geklärt und wie man das Problem vermeidet, sollte jedem (der Shell zumindest im Ansatz versteht) auch klar sein. Ist das bei Dir tatsächlich nicht der Fall, solltest Du eben dringend "nacharbeiten" - ich bin jedenfalls jetzt wirklich raus, weil mich auch die ganzen OSCAM-Variablen im Environment vollkommen durcheinander bringen - so etwas kenne ich (bei Freetz(-NG)) gar nicht.
 

Genesis100

Neuer User
Mitglied seit
6 Mrz 2011
Beiträge
77
Punkte für Reaktionen
1
Punkte
8
Trotzdem vielen Dank. Ich glaube, dass ist für mich tatsächlich zu hoch.

Gruß
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,629
Punkte für Reaktionen
1,189
Punkte
113
Ich sehe hier eher mangeldes Interesse ... denn wie man beim Aufruf eines Programms (oder eines Shell-Skripts) auch passende Environment-Variablen übergibt (und was da drin stehen muß, damit es funktioniert, ist ja auch schon klar), das kriegt man mit ein wenig Recherche tatsächlich im Handumdrehen heraus, wenn man sich nur selbst ein wenig rührt.

Aber das ist ja tatsächlich nicht mein Problem ... also muß ich es auch nicht lösen.
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
237,461
Beiträge
2,094,095
Mitglieder
359,672
Neuestes Mitglied
IPex4Fax