.titleBar { margin-bottom: 5px!important; }

eingehender Anruf CLIP / SIP Info

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Fux, 12 Juli 2004.

  1. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Betreibe einen * der per ISDN einegehende Anrufe über chan_capi entgegennimmt und per SIP an meinen ATA 286 zu Hause weiterleitet. An diesem ist ein DECT-Tel angeschlossen, was CLIP unterstützt.
    Funzt auch alles prima: ich sehe die Rufnummer des Anrufers - alles klar.
    Ruft jedoch jemand ohne Nummer an, sehe ich auf dem Display meines DECT "asterisk".
    Zunächst mal war ich sehr erstaunt, daß sich per CLIP überhaupt was anderes als Zahlen übertragen läßt. Das war mir nicht bekannt.
    Weiß jemand, wie man diese Info beeinflussen kann ?
    Auf diese Art und weise müßte es ja auch möglich sein, bei einem eingehenden Anruf den Namen (Stichwort Asterisk Database) statt der Rufnummer anzeigen zu lassen.
    Hat jemand hier schon Erfahrungen ?
     
  2. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,280
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    Interessant, das der ATA das so weitergibt. Es gibt ein erweitertes CLIP, bei dem auch alphanummerische Zeichen übertragen werden. Bei Auerswald wird damit z.B. neben der Numer auch der Name aus dem globalen (nicht dem des Telefons) Telefonbuch übertragen. Wäre mal interessant, ob Du das bei Dir über SetCIDName beeinflussen kannst.

    jo
     
  3. Ber5erker

    Ber5erker Mitglied

    Registriert seit:
    6 Apr. 2004
    Beiträge:
    305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Asterisk und der ATA scheinen ALLES durchzugeben.

    Habe hier das schnurlose "AEG Comfort SMS" zu Testzwecken gehabt - wow sag ich nur :dance:

    Die Anrufe aus dem Sipgate-Netz kamen samt Namen und Telefonnummer auf dem Display an!

    Sogar SMS ließen sich damit über Asterisk verschicken - nur das Empfangen wollte nicht so richtig...
     
  4. Fux

    Fux Mitglied

    Registriert seit:
    3 Juni 2004
    Beiträge:
    420
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Tatsächlich ! Es funzt ! :lol: :lol: :lol:
    Einfach mal
    exten => 42,1,SetCIDName(Test)
    &
    exten => 42,2,Dial(SIP/ATA,30)
    eingegeben - und siehe da: Das DECT-Teil zeigt "Test".