.titleBar { margin-bottom: 5px!important; }

Einwahl erzeugt: handle_request: Failed to authenticate user

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von kasi, 19 Nov. 2004.

  1. kasi

    kasi Neuer User

    Registriert seit:
    18 Nov. 2004
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problembeschreibung:
    Einwahl vom Festnetz über Sipgate führt zum Besetztzeichen auf dem Telefon und zur Notice "NOTICE[1112488880]: chan_sip.c:6351 handle_request: Failed to authenticate user <Festnetz-Nummer>" auf der Asterisk-Konsole.

    Zu diesem Problem gibt es massenhaft Posts; aber so richtig schlau bin ich daraus nicht geworden:

    * insecure=very ist ein heißer Tip
    * Konfiguration als reiner peer und entfernen jediglicher auth-config aus der [sipgate] Section ist ein anderer.

    Grundsätzlich einmal die Frage: Was zum Teufel authentifiiziert * da?? Erkennt er sipgate nicht als friend??

    Peinlicherweise hier anbei meine aktuelle sip.conf (nach Stunden der Probiererei allerdings etwas verkonfiguriert)


    Code:
     
    [general]
    port=5060
    bindaddr=0.0.0.0
    externip=kasi.homeip.net
    localnet=192.168.0.0/255.255.0.0
    srvlookup=yes
    context=default
    disallow=all
    allow=alaw
    allow=ulaw
    allow=g726
    allow=gsm
    allow=ilbc
    register => XXXXXXX:geheim@sipgate.de/XXXXXXX
    canreinvite=no
    tos=0x18
    nat=yes
    useragent=Asterisk PBX 
    dtmfmode=info
    context=from-sip
    
    
    [sipgate]
    ;realm=kasi.homeip.net
    type=friend
    ;host=sipgate.de
    host=217.10.79.9
    reinvite=no
    canreinvite=no
    dtmfmode=rfc2833
    insecure=very
    nat=yes
    ;username=XXXXXXX
    :secret=geheim
    ;fromuser=XXXXXXX
    ;fromdomain=sipgate.net
    ;auth=md5,plaintext
    context=default
    ;qualify=yes
    disallow=all
    allow=alaw
    allow=ulaw
    allow=g726
    allow=gsm
    allow=ilbc
    dtmfmode=info
    tos=0x18
    
    Hat jemand einen Hinweis?
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Code:
    
    [1012345] 
    type=friend
    username=xxxxxxx
    fromuser=xxxxxxx
    secret=ganzdollgeheim
    context=default
    host=sipgate.de
    fromdomain=sipgate.de
    insecure=very
    caninvite=no
    canreinvite=no
    nat=no
    disallow=all
    allow=ulaw
    
    
    Und dann müßten wir mal noch sehen, wie Dein Dial-Commando in der extensions.conf aussieht.

    hier würde das so aussehen: Dial(SIP/Rufnummer@1012345,60,r)
     
  3. kasi

    kasi Neuer User

    Registriert seit:
    18 Nov. 2004
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    extension conf

    Meine Extension.conf: Anwahl über HFC-Karte im NT-Modus:

    Code:
    exten => 58007468,1,Dial(Zap/2/123456,60,tT)
    exten => 58007468,2,Hangup
    
    Da meine Augen flimmern: Erst mal schlafen ehe ich Unsinn verzapfe.
    Danke bis hierher...
     
  4. kasi

    kasi Neuer User

    Registriert seit:
    18 Nov. 2004
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Erledigt!

    Ich habe heute einen Schnitt gemacht und die Konfiguration auf Basis diverser Informationen aus diesem BB komplett neu aufgebaut.
    und siehe da:
    es läuft.

    Leider kann ich jetzt nicht mehr mit einem Lösungsbericht dienen da ich das Problem an sich nicht identifiziert habe (vermute NAT als Ursache).

    Für blutige Anfänger (wie ich einer bin) scheinen sich folgende Hinweise zu lohnen:
    * die config für sipgate in "incoming" und "outgoing" zu trennen
    * schlafen und Neuanfangen lohnt sich bei verfahrenen Konfigurationen immer :)

    THX kasi