elmeg ip120 session timer (SIP 422 - Session Interval Too Small)

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
Hallo zusammen,

ich versuche ein ip120 (FW 2.0.0.1) an einer nicht elmeg Telefonanlage als SIP-Client anzumelden.
Die Registrierung funktioniert, ausgehende verbindungen funktionieren auch.
Eingehend Verbindungen z.B. über ein SNOM funktioniert auch (Session timer 3600).
Eingehen über ein Handy geht nicht, wird abgeleht mit der Meldung "SIP 422 - Session Interval Too" Small MIN-SE1800.
Im trace wurde vom Handy ein SE von 90 offeriert. Kann ich das im IP120 irgendwie beeinflussen oder bin ich da auf einer falschen fährte?
 

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,676
Punkte für Reaktionen
336
Punkte
83
  1. War das Elmeg IP120 nicht ein Gigaset DE410IP PRO? Ich gehe jetzt mal davon aus:
  2. Hat das Modell nicht noch die Firmware 02.01.00 bekommen? Laut jener und dieser Webseite, ja.
  3. Hast Du das Telefon-Profil bereits einmal gelöscht? Web-Oberfläche → (Reiter) Settings → Telepfony (→ Connections) → (Taste) Edit → (Taste) Delete Connection
Nicht dass das Gerät irgendwann so fern-konfiguriert wurde oder das aus dem Web-Assistent geladene Telefon-Profil solch einen Murks enthielt. Ein Min-SE von 90 Sekunden ist nämlich ein ganz normaler Wert. 1800 zu verlangen wäre Hammer. Aber ob die Unterstützung für Session-Timer in dieser Gigaset-Serie abschaltet ist, habe ich mir auch schon gefragt. Hatte mit der Funktion auch schon Probleme (aber nicht Dein spezielles Problem) und musste das Gerät am Ende aufgeben.
Im trace wurde vom Handy ein SE von 90 offeriert.
Min-SE oder Session-Expires? Steht timer in Supported oder Require?
 

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
Hab mich vertippt bei der FW Firmware 02.01.00. hab das aus dem Kopf raus geschrieben. ist die letzte FW.
Vom Handy Steht der Timer Supportet.
Ich kann leider die Konfguration nicht öffnen/ändern da es eine .dat ist. Und den Wert 1800 kann man definitiv nicht über die WebGui ändern
 

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,676
Punkte für Reaktionen
336
Punkte
83
Stehen diese 90 Sekunden im Min-Se oder in Session-Expires?
Ich kann leider die Konfiguration nicht öffnen/ändern da es eine .dat ist.
Kannst Du die Einstellungen für Deinen Anbieter wie oben beschrieben nicht löschen und manuell anlegen? Oder was genau meinst Du mit .dat, eine über die Web-Oberfläche Deines Telefons exportierte Konfiguration? In der wüsste ich auch nicht, wie man rum-editiert. Ich meinte über die Web-Oberfläche den Anbieter löschen und manuell anlegen (oder sogar das ganze Telefon zurücksetzen und manuell über die Web-Oberfläche neu aufbauen).
 

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
Hab das schon mehrfach durchgespielt, gelöscht, zurückgesetzt, immer der selbe Fehler, nerv.
Hab auch schon mal mit und ohne STUN versucht, hat auch nix gebracht, das Telefon besteht auf 1800, löst aber keinen Re-Invite aus mit neuem Timer, soweit ich das verstanden habe, sondern lehnt einfach nur ab.
 

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
So, hab den Fehler gefunden. das Ip120 bzw. die FW. Mit Hilfe vom Provider haben wir das Problem auf den Session Timer eingegrenzt. Da das Handygespräch ohen Timer beim Provider eingeht, setzt der Provider eine SE von 1780 (Max default). Und das IP120 sagt, NÖ!!!! Min 1800 und statt weiter die Session auszuhandeln, wird die Session beendet.
 

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
Das ist der Invite:
Code:
INVITE sip:[email protected]:61552 SIP/2.0
From: "Anonymous"<sip:[email protected]>;tag=sc1atph1-3c23850877e0c88a
To: <sip:[email protected]>
Call-ID: cd8550003156-611f51cf-611f561a-c7c3a60-2ca7fb9-01
CSeq: 1 INVITE
Allow: INVITE, ACK, CANCEL, BYE, OPTIONS
Max-Forwards: 64
User-Agent: AareSwitch/6.15.13583
Session-Expires: 1780;refresher=uas
Min-SE: 90
Supported: timer
Via: SIP/2.0/UDP XX.XX.XX.XX:55060;nat;uac=sc1;branch=z9hG4bKsc1atph1-5c0821ccc27de38b
Contact: <sip:[email protected]:55060>
Diversion: <sip:X[email protected]>;privacy=off;counter=1
Privacy: id
Content-Type: application/sdp
Content-Length: 265

v=0
o=- 1231123511275989338 1 IN IP4 XX.XX.XX.XX
s=TELES-SBC
t=0 0
m=audio 40108 RTP/AVP 9 8 0 110
c=IN IP4 XXX.XXX.XXX.XXX
a=silenceSupp:eek:ff - - - -
a=rtpmap:9 G722/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:110 telephone-event/8000
a=fmtp:110 0-15
a=ptime:20

Und das die Antwort vom IP120:

Code:
SIP/2.0 422 Session Interval Too Small
Via: SIP/2.0/UDP XXX.XXX.XXX.XXX:55060;nat;uac=sc1;branch=z9hG4bKsc1atph1-5c0821ccc27de38b
Min-SE: 1800
From: "Anonymous" <sip:[email protected]>;tag=sc1atph1-3c23850877e0c88a
To: <sip:[email protected]>;tag=7C2F802099E0_T2052787693
Call-ID: cd8550003156-611f51cf-611f561a-c7c3a60-2ca7fb9-01
Contact: <sip:[email protected]:5060>
CSeq: 1 INVITE
User-Agent: elmeg IP120/62.02.01.00;7C2F802099E0
Allow: ACK,BYE,CANCEL,INVITE,NOTIFY,REFER,MESSAGE,UPDATE,OPTIONS,SUBSCRIBE,PRACK,INFO
Content-Length: 0

[CODE] TAGs [/CODe] gesetzt by stoney
 
Zuletzt bearbeitet von einem Moderator:

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,676
Punkte für Reaktionen
336
Punkte
83
Ja, jetzt kann ich es bei meinem Gigaset DE900 IP PRO ebenfalls reproduzieren. :oops:
Bei mir ist das nie aufgefallen, weil mein Telefon-Anbieter dann einfach die 1800 aus der SIP-Status 422 übernimmt und seinen Default-Wert überschreibt.
setzt der Provider eine SE von 1780 (Max default)
Entweder
  1. Dein Telefon-Anbieter setzt seinen Maximal-Wert höher, also mindestens auf 1800 Sekunden. Oder
  2. Dein Telefon-Anbieter aktiviert keine SIP Session-Timers. Oder
  3. Du setzt einen SIP-B2BUA dazwischen, z.B. ein Digium Asterisk, SignalWire FreeSWITCH, AVM FRITZ!Box bzw. ähnliches. Oder
  4. Du trennst Dich von diesem Telefon und nimmst eines mit einer anderen Software-Plattform …
 

_SFL_

Neuer User
Mitglied seit
27 Sep 2019
Beiträge
26
Punkte für Reaktionen
0
Punkte
1
Ich nehm Punkt 4. Danke für die hilfe
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via