[erledigt]Asterisk mit 2 HFC (1xNE, 1xNT) funktioniert nicht

johnyt11

Neuer User
Mitglied seit
27 Aug 2004
Beiträge
120
Punkte für Reaktionen
0
Punkte
16
Hallo,

leider haben mir die anderen Beiträge zu ähnlichen Problemen nicht geholfen.

Ich habe Linux wie hier nach der Anleitung von hier mit dem bristuff installiert.

Mit den Original Samples erhalte ich keine Fehlermeldung.
Nachdem ich die Dateien Zaptel.conf, Zapta.conf, Sip.conf und Extensions.conf nach der Anleitung ändere erhalte ich folgende Fehlermeldung:

Code:
login as: root
Sent username "root"
Password:
Response:
Last login: Mon Oct 11 19:00:25 2004 from 192.168.101.21
Have a lot of fun...
linux:~ # asterisk -vvvvc
  == Parsing '/etc/asterisk/asterisk.conf': Found
  == Parsing '/etc/asterisk/extconfig.conf': Found
Asterisk CVS-D2004.08.13.22.00.00-10/07/04-14:34:19, Copyright (C) 1999-2004 Digium.
Written by Mark Spencer <[email protected]>
=========================================================================
  == Parsing '/etc/asterisk/logger.conf': Found
Asterisk Event Logger Started /var/log/asterisk/event_log
  == Manager registered action Ping
  == Manager registered action Events
  == Manager registered action Logoff
  == Manager registered action Hangup
  == Manager registered action Status
  == Manager registered action Setvar
  == Manager registered action Getvar
  == Manager registered action Redirect
  == Manager registered action Originate
  == Manager registered action MailboxStatus
  == Manager registered action Command
  == Manager registered action ExtensionState
  == Manager registered action AbsoluteTimeout
  == Manager registered action MailboxCount
  == Manager registered action ListCommands
  == Parsing '/etc/asterisk/manager.conf': Found
  == Parsing '/etc/asterisk/rtp.conf': Found
  == RTP Allocating from port range 10000 -> 20000
Asterisk PBX Core Initializing
Registering builtin applications:
 [AbsoluteTimeout]
  == Registered application 'AbsoluteTimeout'
 [Answer]
  == Registered application 'Answer'
 [BackGround]
  == Registered application 'BackGround'
 [Busy]
  == Registered application 'Busy'
 [Congestion]
  == Registered application 'Congestion'
 [DigitTimeout]
  == Registered application 'DigitTimeout'
 [Goto]
  == Registered application 'Goto'
 [GotoIf]
  == Registered application 'GotoIf'
 [GotoIfTime]
  == Registered application 'GotoIfTime'
 [Hangup]
  == Registered application 'Hangup'
 [NoOp]
  == Registered application 'NoOp'
 [Prefix]
  == Registered application 'Prefix'
 [Progress]
  == Registered application 'Progress'
 [ResetCDR]
  == Registered application 'ResetCDR'
 [ResponseTimeout]
  == Registered application 'ResponseTimeout'
 [Ringing]
  == Registered application 'Ringing'
 [SayNumber]
  == Registered application 'SayNumber'
 [SayDigits]
  == Registered application 'SayDigits'
 [SayAlpha]
  == Registered application 'SayAlpha'
 [SayPhonetic]
  == Registered application 'SayPhonetic'
 [SetAccount]
  == Registered application 'SetAccount'
 [SetAMAFlags]
  == Registered application 'SetAMAFlags'
 [SetGlobalVar]
  == Registered application 'SetGlobalVar'
 [SetLanguage]
  == Registered application 'SetLanguage'
 [SetVar]
  == Registered application 'SetVar'
 [StripMSD]
  == Registered application 'StripMSD'
 [Suffix]
  == Registered application 'Suffix'
 [Wait]
  == Registered application 'Wait'
 [WaitExten]
  == Registered application 'WaitExten'
Asterisk Dynamic Loader Starting:
  == Parsing '/etc/asterisk/modules.conf': Found
 [chan_modem.so] => (Generic Voice Modem Driver)
  == Parsing '/etc/asterisk/modem.conf': Found
  == Loading modem driver chan_modem_aopen.so => (A/Open (Rockwell Chipset) ITU-2 VoiceModem Driver)
  == Registered channel type 'Modem' (Generic Voice Modem Channel Driver)
 [res_musiconhold.so] => (Music On Hold Resource)
  == Parsing '/etc/asterisk/musiconhold.conf': Found
Oct 11 19:42:46 WARNING[16384]: res_musiconhold.c:543 moh_register: Unable to open pseudo channel for timing...  Sound may be choppy.
  == Registered application 'MusicOnHold'
  == Registered application 'WaitMusicOnHold'
  == Registered application 'SetMusicOnHold'
 [res_indications.so] => (Indications Configuration)
  == Parsing '/etc/asterisk/indications.conf': Found
    -- Registered indication country 'cl'
    -- Registered indication country 'tw'
    -- Registered indication country 'us'
    -- Registered indication country 'au'
    -- Registered indication country 'fr'
    -- Registered indication country 'de'
    -- Registered indication country 'nl'
    -- Registered indication country 'uk'
    -- Registered indication country 'fi'
    -- Registered indication country 'no'
    -- Registered indication country 'br'
    -- Registered indication country 'za'
    -- Registered indication country 'it'
    -- Registered indication country 'us-o'
    -- Registered indication country 'gr'
    -- Registered indication country 'ru'
    -- Registered indication country 'nz'
    -- Setting default indication country to 'us'
  == Registered application 'Playtones'
  == Registered application 'StopPlaytones'
 [res_features.so] => (Call Parking Resource)
  == Parsing '/etc/asterisk/features.conf': Found
    -- Registered extension context 'parkedcalls'
    -- Added extension '700' priority 1 to parkedcalls
  == Registered application 'ParkedCall'
  == Registered application 'Park'
  == Manager registered action ParkedCalls
 [res_agi.so] => (Asterisk Gateway Interface (AGI))
  == Registered application 'DeadAGI'
  == Registered application 'EAGI'
  == Registered application 'AGI'
 [res_crypto.so] => (Cryptographic Digital Signatures)
    -- Loaded PUBLIC key 'iaxtel'
    -- Loaded PUBLIC key 'freeworlddialup'
 [res_adsi.so] => (ADSI Resource)
  == Parsing '/etc/asterisk/adsi.conf': Found
 [res_monitor.so] => (Call Monitoring Resource)
  == Registered application 'Monitor'
  == Registered application 'StopMonitor'
  == Registered application 'ChangeMonitor'
  == Manager registered action Monitor
  == Manager registered action StopMonitor
  == Manager registered action ChangeMonitor
 [app_sms.so] => (SMS/PSTN handler)
  == Registered application 'SMS'
 [app_hasnewvoicemail.so] => (Indicator for whether a voice mailbox has messages in a given folder.
  == Registered application 'HasVoicemail'
  == Registered application 'HasNewVoicemail'
 [format_wav_gsm.so] => (Microsoft WAV format (Proprietary GSM))
  == Registered file format wav49, extension(s) WAV|wav49
 [app_url.so] => (Send URL Applications)
  == Registered application 'SendURL'
 [chan_modem_i4l.so] => (ISDN4Linux Emulated Modem Driver)
 [chan_mgcp.so] => (Media Gateway Control Protocol (MGCP))
  == Parsing '/etc/asterisk/mgcp.conf': Found
  == MGCP Listening on 0.0.0.0:2727
  == Using TOS bits 0
  == Registered channel type 'MGCP' (Media Gateway Control Protocol (MGCP))
 [app_eval.so] => (Reevaluates strings)
  == Registered application 'Eval'
 [chan_zap.so] => (Zapata Telephony w/PRI)
  == Parsing '/etc/asterisk/zapata.conf': Found
Oct 11 19:42:46 ERROR[16384]: chan_zap.c:9017 setup_zap: Unknown signalling method 'bri_net_ptmp'
Oct 11 19:42:46 ERROR[16384]: chan_zap.c:8677 setup_zap: Signalling must be specified before any channels are.
Oct 11 19:42:46 WARNING[16384]: loader.c:328 ast_load_resource: chan_zap.so: load_module failed, returning -1
  == Unregistered channel type 'Tor'
  == Unregistered channel type 'Zap'
Oct 11 19:42:46 WARNING[16384]: loader.c:423 load_modules: Loading module chan_zap.so failed!
linux:~ # Junk at the beginning 49443302
Warning, flexibel rate not heavily tested!
Ouch ... error while writing audio data: : Broken pipe
Meine Konfiguration sieht so aus:

zaptel.conf
Code:
loadzone=nl 
defaultzone=nl 

span=1,1,3,ccs,ami 
bchan=1-2 
dchan=3 6 

span=2,1,3,ccs,ami 
bchan=4-5 
dchan=6
zapta.conf
Code:
[channels]
switchtype=euroisdn
signalling=bri_net_ptmp
pridialplan=local
echocancel=yes
immediate=no
;setcallerid(""<${CALLERIDNUM}>)
overlapdial=yes
group=1
context=default
channel=>1-2 
; 
signalling = bri_cpe_ptmp 
group = 2 
channel => 4-5
sip.conf
Code:
[general]
port = 5060
bindaddr = 0.0.0.0
externip = meinserver.homeftp.net
localnet = 192.168.101.0/255.255.0.0
srvlookup = yes
context = default
disallow=all
allow=gsm
register => 8000123:[email protected]/8000123
canreinvite=no
tos=0x18
insecure=very
nat=no
dtmfmode=info

[sipgate]
type=friend
username=8000123
secret=Passwort
host=sipgate.de
fromuser=8000123
fromdomain=sipgate.de
context=default
canreinvite=no
qualify=yes
disallow=all
allow=gsm
insecure=very
nat=no
dtmfmode=info
tos=0x18
extensions.conf
Code:
[general]
static=yes
writeprotect=no

[globals]
IAXINFO=guest

[default]
include => calls

[calls]
exten => 8000123,1,Dial(Zap/2/23,60,tT)
exten => 8000123,2,Hangup

exten => _1.,1,Dial(SIP/${EXTEN:1}@sipgate,60,tT)
exten => _1.,2,Congestion
exten => _1.,3,Busy
exten => _1.,4,Hangup
Die restlichen .conf Dateien habe ich so gelassen die mit "make samples" estellt wurden.

Durch den Ausfall der Forums sind auch die Antworten, die hierauf waren verloren gegangen.

Wer kann mir helfen.
(PS: wenn es einfacher mit SSH, durch direcktem Zugriff auf dem Rechner, zu helfen ist, SSH ist eingerichtet und funktioniert.)
 

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
Zu dem Error bei chan_zap.so bin ich ratlos.
Vielleicht stimmt /etc/zaptel.conf evtl. noch nicht oder auch zapata.conf ?

Sicher, dass es mit 2 Karten GENAU so konfiguriert werden muß/kann ?

Vielleicht erstmal mit einer Karte probieren ?

Wie lädst Du denn zaphfc.so ?
insmod zaphfc modes=2 ?
 

johnyt11

Neuer User
Mitglied seit
27 Aug 2004
Beiträge
120
Punkte für Reaktionen
0
Punkte
16
also, ich hab halt nur die Samples kompiliert. nach der Anleitung von Bach-online.de und aus einer anderen Beitrag hier im Forum die Zaptel eingestellt weil 2 Karten.

@Blackvel
Sicher, dass es mit 2 Karten GENAU so konfiguriert werden muß/kann ?

ne, ich steh da noch ganz am Anfang.
Wo kann ich mich eingehend mit den Einstellungen (Deutsch) befassen?
Englisch gibts ja viele, aber das geht mit meinem Schulenglisch sehr mühsam. :?

@Blackvel
Vielleicht erstmal mit einer Karte probieren ?

Einfach PC aus, karte raus, und System neustarten?
Oder muß ich den bristuff dann neu kompilierem?

@Blackvel
Wie lädst Du denn zaphfc.so ?
insmod zaphfc modes=2 ?

wo seh ich das?
Ich hab (soweit ich sehen kann= auch keinen anderen Treiber unter suse für die HFC Karten. (unter "yast" ist nichts konfiguriert)
 

johnyt11

Neuer User
Mitglied seit
27 Aug 2004
Beiträge
120
Punkte für Reaktionen
0
Punkte
16
Ist zwar schon ein paar Tage her...
aber auf dieser Seite habe ich meine Antworten gefunden.

www.voip-info.org/tiki-index.php?page=Asterisk+zaphfc

im Bristuff Ordner /zapfhfc "insmod ./zaphfc.o modes=1" ausführen dann "make loadNT"

und so soll die zaptel.conf aussehen:
Code:
span=1,1,3,ccs,ami  
bchan=1-2  
dchan=3 
span=2,1,3,ccs,ami 
bchan=4-5 
dchan=6
und die zapta.conf so:
Code:
; Zapata telephony interface 
; 
; Configuration file 
; 
[channels] 
; 
;defaults 
switchtype = euroisdn 
signalling = bri_net_ptmp  
pridialplan=local 
echocancel=yes 
immediate=yes 
setcallerid(""<${CALLERIDNUM}>) 
;usecallerid=yes 
group = 1 
context=default 
channel => 1-2 
; 
signalling = bri_cpe_ptmp  
group = 2 
channel => 4-5
und es klappt.
 

Blackvel

Mitglied
Mitglied seit
4 Mai 2004
Beiträge
624
Punkte für Reaktionen
0
Punkte
0
Ich hab leider den Überblick verloren, aber was hast denn jetzt konkret falsch gemacht ? :)
 

johnyt11

Neuer User
Mitglied seit
27 Aug 2004
Beiträge
120
Punkte für Reaktionen
0
Punkte
16
ich hab im bristuff Verzeichnis /zaphfc durch den Befehl insmod "./zaphfc.o modes=1 " die Datei zaphfc.o auf den Modus "1 Karte NT und 1 Karte NE" umgestellt.

und den Befehl "make loadNT" aus dem bristuff Verzeichnis /zaphfc muß ich wohl, jedesmal wenn der PC neugestartet wird ausführen.
Sonst kommt die o.A. Fehlermeldung.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,920
Beiträge
2,028,163
Mitglieder
351,083
Neuestes Mitglied
deckling