Err: load chan_zap.so: undefined symbol: q931_resume_ackno..

vschellin

Neuer User
Mitglied seit
10 Jun 2004
Beiträge
30
Punkte für Reaktionen
0
Punkte
0
Mein System
Suse 9.0 mit Kernel 2.6.8
1 HFC-Karte (von Conrad)
bri-stuff.0.1.0-RC4a

Der Download und das Compilieren klappte ohne Fehler (allerdings etliche Warnungen)

make loadlinux26NT ohne Fehler .. .3 channels configured

wenn ich jetzt asterisk -vvvvvvgc starte bekomme ich die Fehlermeldung

[chan_zap.so]Nov 22 10:20:01 WARNING[16384]: loader.c:242
ast_load_resource: /usr/lib/libpri.so.1: undefined symbol: q931_resume_acknowledge
Nov 22 10:20:01 WARNING[16384]: loader.c:423 load_modules: Loading module chan_zap.so failed!

und Asterisk bricht ab.

Füge ich in die /etc/asterisk/modules.conf
unload => chan_zap.so
hinzu, startet Asterisk felherfrei.

lade ich chan_zap.so manuell nach kommt die gleiche Felhermeldung

Jede Hilfe willkommen
 

lo4dro

Mitglied
Mitglied seit
14 Okt 2004
Beiträge
656
Punkte für Reaktionen
0
Punkte
0
Hi.

Versuch mal bristuff-0.2.0.
 

vschellin

Neuer User
Mitglied seit
10 Jun 2004
Beiträge
30
Punkte für Reaktionen
0
Punkte
0
Danke für den Hinweis,

habe gerade bristuff-0.2.0-rc2b geladen und wie bei 0.1.0 bei ./install.sh ausgeführt - es kommt dann:
: bad interpreter: Datei oder Verzeichnis nicht gefunden

was mache ich falsch / was hat sich geändert?
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,920
Beiträge
2,028,163
Mitglieder
351,083
Neuestes Mitglied
deckling