.titleBar { margin-bottom: 5px!important; }

Faxempfang

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von kpkniehl, 23 März 2005.

  1. kpkniehl

    kpkniehl Neuer User

    Registriert seit:
    21 Feb. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich hab ein Problem mit dem Faxempfang...

    Ich hab der * zum testen an einer nebenstelle unserer Octopus hängen. Jetzt versuche ich ein Fax zu schicken, alles sieht gut aus, aber nach genau 36 s, lt. normal-Fax (mehrere Faxversuche) bricht er mit einem OK-Seite gesendet ab. Es ist aber nur ein Teil der Seite angekommen.

    Hat jemand auch schon mal ähnliches gehabt oder weis eine Lösung?

    auszug aus der Extensions.conf
    Code:
    ; Testfax
    exten => 444,1,Answer()
    exten => 444,2,SetVar(FAXFILE=/var/spool/asterisk/fax/${UNIQUEID}.tif)
    exten => 444,3,RxFax(${FAXFILE})
    exten => 444,4,Congestion()
    exten => 444,104,Congestion()
    
    Danke und Gruß

    Markus
     
  2. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    ist eine korrekte version der libtiff auf dem system installiert? iirc ist spandsp da wählerisch / bzw. manche libtiff-versionen sind buggy und produzieren dann keine korrekte ausgabe.
     
  3. kpkniehl

    kpkniehl Neuer User

    Registriert seit:
    21 Feb. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    foglende Versionen hab ich installiert:

    libtiff-3.7.1
    spandsp-0.0.2pre9
    curl-7.13.1

    Laut spansp sollte die 3.7.1 Ok sein. Wobei hier wieder was anders steht...

    Gruß Markus
     
  4. kpkniehl

    kpkniehl Neuer User

    Registriert seit:
    21 Feb. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich habs jetzt nochmal mit libtiff 3.6.0 versucht... mit dem gleichen ergebniss, nach ca. 10 % Datenübertragung bricht der Empfang ab und das Faxgerät sagt OK.
     
  5. kpkniehl

    kpkniehl Neuer User

    Registriert seit:
    21 Feb. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich hab hier was gefunden, aber ich verstehe nich so recht was die von mir wollen.
     
  6. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    also was o.g. link sagen will ist im wesentlichen, dass Fax recht empfindlich gegenüber ungenauer Synchronisation ist. Das kann zum einen auftreten, wenn man auf die Idee kommt Faxe per IP (z.B.) SIP zum * zu schicken (was aber bei dir nicht der Fall sein dürfte?) oder aber sonstwas auseinanderläuft.

    Mit was für einer Karte hast Du den * denn an die Octopus angeschlossen und was für ein Rechner ist es?

    Soweit ich gesehen hab sind die 0.0.2er Versionen von Spandsp Entwicklerversionen -- ggf. mal ein anderes Release probieren?
     
  7. kpkniehl

    kpkniehl Neuer User

    Registriert seit:
    21 Feb. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Is ne Sirrix 4S0 Karte.. also nix Schlechtes, Der Rechner is allerdings nich so der Bringer... PIII 700. Aber ich bin gerade dabei einen P4 3 GHz zu installieren.

    werd ich dann mit dem neuen Rechner versuchen, da wollte nur bis heute mittag Debian nur 1,1 GB der Festplatte erkennen. Nun gehts aber.... Aber ich muss noch den Kernel 2.4 zum laufen bekommen. Da haperts noch mit dem SCSI-Treiber... (Die Sirrix-Channel-Treiber sind bis jetzt nur für 2.4 verfügbar)

    Gruß Markus