Fehlerhafte Anzeige und unbrauchbares "make menuconfig"

schlimmchen

Neuer User
Mitglied seit
15 Sep 2007
Beiträge
30
Punkte für Reaktionen
0
Punkte
6
Beim Ausführen von "make menuconfig" in einer (frischen) freetz svn working copy bekomme ich lediglich ein unbrauchbares Konfigurationsmenü, siehe Screenshot im Anhang.

broken_menuconfig.jpg

Es handelt sich um ein Ubuntu 11.10 64bit System mit proprietären fglrx Treibern. Das Problem tritt erst seit kurzem auf. Ich habe auf dem gleichen Rechner keine Probleme wenn ich eine Ubuntu Live-Version benutze. Das Problem tritt allerdings auch in meinem 32bit chroot auf. Gleiches Verhalten, wenn ich versuche menuconfig zu nutzen um einen Linux Kernel zu konfigurieren.

Ich habe die lib[32]ncurses[-dev] libraries neu installiert ("reinstall"), ohne Erfolg. Ich kann nicht sehen, dass irgendwelche Terminaleinstellungen falsch wären. Das Ergbnis im gnome-terminal und im xterm ist vergleichbar. Andere [n]curses-basierte Programme wie nano und midnight-commander funktionieren wie gewohnt und einwandfrei.

Würde mich freuen wenn jemand Hilfe anbieten kann, google konnte mir nicht weiterhelfen...
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Zum einen könntest Du mal erläutern, warum ein unbrauchbares Konfigurationsmenü kommt, aus dem Bild geht das nämlich nicht hervor.
Zum anderen ist es kein Problem von Freetz, denn wie Du selbst schreibst, funktioniert es mit einem anderen Host-System.
 

schlimmchen

Neuer User
Mitglied seit
15 Sep 2007
Beiträge
30
Punkte für Reaktionen
0
Punkte
6
Zum einen könntest Du mal erläutern, warum ein unbrauchbares Konfigurationsmenü kommt, aus dem Bild geht das nämlich nicht hervor.
Wenn ich die Pfeiltasten benutzen will, passiert nicht, was man erwartet, nämlich dass die Auswahl sich verändert. Es erscheinen lediglich Zeichen am unteren Rand des Menüs, sowas wie "^[[A^[[C^[[D^[[A^[[D^" (auf die trifft man schonmal häufiger wenn ein konsolenbasiertes Programm nicht richtig funktioniert oder die Pfeiltasten nicht verarbeitet).
Zum anderen ist es kein Problem von Freetz, denn wie Du selbst schreibst, funktioniert es mit einem anderen Host-System.
Ja....?! Was willst du mir damit sagen? Dürfen hier nur Probleme diskutiert werden, die von vornherein auf Freetz zurückzuführen sind?