[Problem] Fertiges Debian System auf Fritz Box7390 installieren

koerli

Neuer User
Mitglied seit
7 Dez 2010
Beiträge
96
Punkte für Reaktionen
0
Punkte
6
Hallihallo,
ich möchte gern nach dieser Anleitung http://www.ip-phone-forum.de/showthread.php?t=137008&highlight=debian+fritz das Debian System auch auf der FritzBox7390 installieren. Allerding scheitere ich bereits bei der Erstellung des benötigten freetz images. Gebraucht wird
  • bash (debian zu starten)
  • automount
  • ex3

bash habe ich unter PACKAGE SELECTION-->TESTING-->BASH gefunden. Wo finde ich die anderen Packages?!


Und dazu gleich ne andere Frage was bedeutet eigentlich Binary only genau? Bitte erschlagt mich nicht gleich ich bin neu hier :rolleyes::cry:

Vielen Dank für eure Hilfe:)
 
R

rentier-s

Guest
Schau mal bei den Patches.

http://freetz.org/wiki/FAQ#Wasbedeutetbinaryonly

-----

Die 7390 hat einen anderen Prozessor, da bin ich auch schon mal reingefallen, siehe ab #361 in dem Thread.

@Ralf, bei mir (Forum-Standardeinstellungen) ist es Seite 19.
Dafür finde ich in Freetz den Bebootstrap nicht, Oli hatte in #361 lediglich auf Debootstrap verwiesen. ;-)
 
Zuletzt bearbeitet von einem Moderator:

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
"binary only" heißt, dass für das ausgewählte Paket nur das Programm ("binary") selbst erstellt wird, jedoch kein Webinterface, init-Skripte etc. vorhanden sind.
Das hat nichts mit dem Prozessor der Box zu tun.
Am Prozessor liegt es, dass nachher das Debian für die älteren Boxen nicht auf der 7390 laufen würde.

Der Thread hat übrigens nur 7 Seiten und nicht 19.

Im Fretz gibt es auch Bebootstrap.
 

koerli

Neuer User
Mitglied seit
7 Dez 2010
Beiträge
96
Punkte für Reaktionen
0
Punkte
6
Hallo,
vielen Dank erstmal. Ich habe mich an die Anleitung auf der Wiki Seite von Debootstrap gehalten und es hat funkioniet. Das mit den "Binary only" habe ich auch verstanden.

Jetzt wollte ich folgenden Befehl ausführen
Code:
echo deb http://ftp.us.debian.org/debian etch main > /etc/apt/sources.list
apt-get update
Ausgabe ist nun:
Code:
Ign http://archive.debian.org etch Release.gpg
Ign http://archive.debian.org etch Release
Err http://archive.debian.org etch/sources Packages
  404 Not Found [IP: 2001:630:206:4000:1a1a:0:c13e:ca1c 80]
Failed to fetch http://archive.debian.org/debian/dists/dists/etch/sources/binary-mips/Packages.gz  404 Not Found [IP: 2001:630:206:4000:1a1a:0:c13e:ca1c 80]
Reading package lists... Done
W: Couldn't stat source package list http://archive.debian.org etch/sources Packages (/var/lib/apt/lists/archive.debian.org_debian_dists_dists_etch_sources_binary-mips_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.
[email protected]:/# echo deb http://ftp.us.debian.org/debian etch main > /etc/apt/sources.list 
[email protected]:/# apt-get update
Ign http://ftp.us.debian.org etch Release.gpg
Ign http://ftp.us.debian.org etch Release
Err http://ftp.us.debian.org etch/main Packages
  404 Not Found [IP: 2001:500:61:28::70 80]
Failed to fetch http://ftp.us.debian.org/debian/dists/etch/main/binary-mips/Packages.gz  404 Not Found [IP: 2001:500:61:28::70 80]
Reading package lists... Done
W: Couldn't stat source package list http://ftp.us.debian.org etch/main Packages (/var/lib/apt/lists/ftp.us.debian.org_debian_dists_etch_main_binary-mips_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.
und dann wollte ich apache2 installieren:
Code:
[email protected]:/# apt-get install apache2 phpmyadmin mysql-server mysqlReading package lists... Done
Building dependency tree... Done
W: Couldn't stat source package list http://ftp.us.debian.org etch/main Pack (/var/lib/apt/lists/ftp.us.debian.org_debian_dists_etch_main_binary-mips_Paes) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Couldn't find package apache2
Allerdings bleib es hängen(siehe oben) was muss ich als source dann richtig angeben, damit es funktioniert?!

Vielen dank für eure Hilfe


Habe nun lenny verwendet un damit geht es
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,769
Beiträge
2,038,216
Mitglieder
352,702
Neuestes Mitglied
Mieze09