.titleBar { margin-bottom: 5px!important; }

Firewall-cgi (ds-0.2.9) "löst" IPs falsch auf

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von michael1969, 24 Dez. 2006.

  1. michael1969

    michael1969 Neuer User

    Registriert seit:
    21 Mai 2006
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 michael1969, 24 Dez. 2006
    Zuletzt bearbeitet: 24 Dez. 2006
    Hallo,

    nachdem ich nun den DS-0.2.9 am laufen habe, gerade wegen der iptables, stehe ich vor einem seltsamen Phänomen. Egol ob ich über die whitelist (sind dann eben mehrere Regeln) oder über die Konsole eine Regel eingebe, wird die entsprechende IP als lokalhost angezeigt und auch sp verarbeitet.

    Alle Rechner befinden sich im selben Netz ist aktiviert --> 192.168.179.1 (es macht aber keinen Unterschied, habs ausprobiert)

    iptables -A INPUT -s 192.168.182.1 -d 192.168.179.1 -p tcp -j DROP

    ergibt mit iptables -L


    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    DROP tcp -- localhost localhost



    komischerweise scheint es mit der Range 192.168. zusammen zu hängen, da wenn ich versuchsweise eine 192.169...... eingebe wird diese korrekt dargestellt.
    Wie oder wo müsste / kann ich ansetzen?
    Hängts u.U. mit dnsmasq zusammen?
    War schon fleißig auf den Seiten von iptables, netfilter und google unterwegs aber brachten mit keine Lösung.


    Wünsche schöne und erholsame Weihnachten


    Michael
     
  2. michael1969

    michael1969 Neuer User

    Registriert seit:
    21 Mai 2006
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Man muss es mir an Weihnachten langweillig sein ;)

    Also googeln, Forumssuche haben mich an den Punkt mal gebracht.

    servercfg {
    hostname = "(none)";
    dns1 = 192.168.180.1;
    dns2 = 192.168.180.2;
    }

    aus http://www.ip-phone-forum.de/showpost.php?p=637046&postcount=4

    könnte es daran liegen das FBF hier nicht so arbeitet wie man es sich erwartet?


    Michael
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Auf 192.168.180.1/2 laufen die DNS-Server der FritzBox. Hast du wirklich 192.168.179.x als Netzwerk? Kannst du das Testweise mal ändern?

    MfG Oliver
     
  4. michael1969

    michael1969 Neuer User

    Registriert seit:
    21 Mai 2006
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #4 michael1969, 25 Dez. 2006
    Zuletzt bearbeitet: 25 Dez. 2006
    Also ich hab das Gnaze auf 192.168.0.1 geändert, ebenso mal mit 192.168.10.1 versucht, aber wenn ich iptables -L aufrufe kommt die von mir o.g. Ausgabe :(

    Allerdings, habe ich die Option "Alle Computer befinden sich im selben IP-Netzwerk" aktiviert


    Michael


    Edit: Es muss mit den Nameservern der FBF zusammenhängen. Ich habe hinter der FBF nochmals nen Router (linksys mit DD-WRT) gehängt, die so eingestellt, dass er per DHCP die IP bekommt, sowie die DNS Einträge. Dann hab ich dort zu Testzwecken auch eine iptables Regel erstellt, ebenso wurde die 192.168.179.0 als localhost dargestellt. Diesen Router hab ich nun wie statisch eigestellt mit einem DNS von meinem ISP. Rest gemacht die selbe Regel wieder per putty erstellt. Nun erscheint mit iptables -L auch die korrekte Darstellung bei "destination" --> 192.168.179.0 ...... komisch die Sache

    Ich vermute es hängt mit den DNS der FBF zusammen. Nur wie und wo kann ich dies beeinflussen?