.titleBar { margin-bottom: 5px!important; }

Fragen zu Treiber

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von nc2001, 29 Juli 2004.

  1. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    nach dem Lesen von zahlreichen FAQs habe ich immer noch ein paar Fragen. Ich möchte eigentlich nur ein ISDN Telefon an einen Linux Rechner hängen und damit über Sipgate telefonieren. Der Linuxrechner befindet sich hinter einem NAT. Das ganze soll dann mittels Asterisk laufen.

    Welche Treiber muss ich nun nehmen, um meine HFC-S Karte in den NT Modus zu schalten, die mISDN Treiber oder die von Junghanns?

    Danke für Antworten!
    Chris
     
  2. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die von Junghanns. Genauer gesagt: bristuff-0.1.0RC2i (oder, falls es noch eine aktuellere geben sollte, dann eben die neueste). Dann am besten mit install.sh installieren.

    Ciao, Mike
     
  3. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für die Antwort. Mal sehen, ob ich das hinbekomme.

    Chris
     
  4. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nachdem die Installation erstaunlich gut geklappt hat, hängt es jetzt an der Konfiguration. Beim Start von Asterisk bekomme ich folgenden Fehler:

    Meine SIP.conf (erstellt nach Anleitung des Mini FAQs):

    Code:
     [1234] 
     type=friend 
     username=1234
     secret=meinpasswort 
     host=dynamic 
     disallow=all 
     allow=ulaw 
     allow=alaw 
     dtmfmode=rfc2833
     context=sipgate
     
     [general] 
     port = 5060 
     bindaddr =  84.129.32.XX  ////hier habe ich die aktuelle IP eingetragen 
     context = default 
     disallow=all 
     allow=gsm
     allow=ulaw 
     allow=alaw 
     register => user:pass@sipgate.de/1234
    
     [sipgate] 
     type=friend 
     username=58001234
     host=sipgate.de 
     fromuser=58001234
     fromdomain=sipgate.de
     nat=no  /// hier wusste ich nicht ob das nicht auf yes muss
     context=default
     canreinvite=no
    Hier meine Extensions.conf

    Code:
    exten => 1234,1,Dial(SIP/${EXTEN},60)
     exten => 1234,2,Congestion
     exten => 1234,102,Busy
     
      [default] 
     exten => 1234,1,Dial(SIP/${EXTEN},60)
     exten => 1234,2,Congestion
     exten => 1234,102,Busy
     
     [sipgate] 
     include => default
     exten => _9.,1,Dial(SIP/${EXTEN:1}@sipgate,60)
     exten => _9.,2,Congestion
     exten => _9.,102,Busy
    Jetzt ist ja die Sache die mit dem Router bzw. NAT. Der Asterisk Servers läuft hinter einem FLI4L Router mit der lokalen IP 192.168.0.113 bzw. einer vom DHCP vergebenen. Was muss ich da noch anders einstellen? ISDN Telefon habe ich noch gar nicht angeschlossen, die Kernelmodule wurden aber ohne Fehler geladen.

    CU
    Chris
     
  5. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    sip.conf ist falsch. bindaddr ist die lokale Linux Server IP.
    externip=x.x.x.x
    localnet=x.x.x.x/x.x.x.x (CVS HEAD),
    localnet=x.x.x.x
    localmask=x.x.x.x die 2 bei CVS Stable

    Sieh mal im Thread Asterisk+SIP+NAT nach.
     
  6. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bin leider nur ein wenig weitergekommen, zumindest meldet asterisk beim Start keine Fehler mehr mit der IP und SIP Registrierung. Allerdings tut sich an meinem ISDN Telefon nichts wenn ich den Hörer abnehme. Es ist Stille und nach einiger Zeit erschein Installationsfehler im Display. Die Kernelmodule für die HFC Karte wurden geladen und auch die Leitungen korrekt eingerichtet.

    Asterisk startet so:
    Code:
    asterisk -c
    Asterisk CVS-D2004.07.25.22.00.00-07/29/04-18:21:11, Copyright (C) 1999-2004 Digium.
    Written by Mark Spencer <markster@digium.com>
    =========================================================================
    [ Booting.................Jul 30 14:54:17 NOTICE[1077094496]: chan_mgcp.c:3909 reload_config: Unable to load config mgcp.conf, MGCP disabled
    ...Jul 30 14:54:17 NOTICE[1077094496]: chan_skinny.c:2538 reload_config: Unable to load config skinny.conf, Skinny disabled
    ..Jul 30 14:54:17 WARNING[1077094496]: config.c:613 cfg_process: No '=' (equal sign) in line 8 of zapata.conf
    .................................................................................... ]
    Asterisk Ready.
    *CLI>
    Wenn ich den Hörer abnehme, erscheint das hier:
    Hier nochmal meine Konfigurationsdateien:
    unter /etc/asterisk extensions.conf
    Code:
    [general]
    
    static=yes
    writeprotect=no
    
    [globals]
    IAXINFO=guest					; IAXtel username/password
    
      [default] 
     exten => 1234,1,Dial(SIP/${EXTEN},60)
     exten => 1234,2,Congestion
     exten => 1234,102,Busy
     
     [sipgate] 
     include => default
     exten => _9.,1,Dial(SIP/${EXTEN:1}@sipgate,tr)
     exten => _9.,2,Congestion
     exten => _9.,102,Busy
    sip.conf

    Code:
    [general] 
     port = 5060 
     bindaddr= 192.168.0.113
     externip=xxx.dyndns.org
     realm=xxx.dyndns.org
     nat=yes
     localnet=192.168.0.0/255.255.255.0
     srvlookup=yes
     context = default 
     disallow=all 
     allow=gsm
     allow=ulaw 
     allow=alaw 
     register => 1234:pass@sipgate.de/1234
     
     [sipgate] 
     type=friend 
     username=1234
     host=sipgate.de 
     fromuser=1234
     fromdomain=sipgate.de
     nat=yes
     context=default
     canreinvite=no
     
      [1234] 
     type=friend 
     username=1234
     secret=meinpasswort 
     host=dynamic 
     disallow=all 
     allow=ulaw 
     allow=alaw 
     dtmfmode=rfc2833
     context=sipgate
    zapata.conf

    Code:
    [channels]
    switchtype=euroisdn
    signalling=bri_net_ptmp
    pridialplan=local
    echocancel=yes
    immediate=no
    overlapdial=yes
    setcallerid(""<${CALLERIDNUM}>)
    ;setcallerid=12345
    usecallerid=yes
    group=1
    context=sipgate
    channel=>1-2 
    und unter /etc/zaptel.conf
    loadzone=nl
    defaultzone=nl

    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3

    Hierzu auch noch ein paar Fragen. Sie die Speicherorte der conf Dateien so richtig, oder muss z.B. die zaptel.conf in das Verzeichnis aus dem kompiliert wurde?

    Was muss ich am ISDN Telefon einstellen? Irgendeine MSN?

    Nach einem Reboot bekomme ich jetzt ein Freizeichen und diese Meldung:
    Tausend Dank für eine Antwort, weiß hier im Moment nicht weiter.

    Greetz
    Chris
     
  7. Raffi

    Raffi Neuer User

    Registriert seit:
    25 Juli 2004
    Beiträge:
    179
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Zaptel.conf "nl" auf "us" ändern und dann speichern. Module entladen, Module laden, dann ztcfg -c zaptel.conf dann asteriisk -vvvvgc starten. Dann solltest Du beim Abnehmen des Hörers bereits sowas ähnliches sehen:

    Spawn extension (intern, s, 1) exited non-zero on 'Zap/5-1'

    Zum testen:
    modprobe zaptel
    modprobe zaphfc
    ztcfg -c /etc/asterisk/zaptel.conf
    asterisk -vvvgc


    Viel Spaß beim testen.

    Raffi
     
  8. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es geht aufwärts, nach einem Reboot bekomme ich nun Freizeichen und auch bei Sipgate bin ich nun registriert. Wenn ich allerdings jetzt über Sipgate eine Telefonnummer anrufen will, also mit der 9 davor, z.B. 9030123456, kommt folgendes:

    Ein Testanruf, zu folgenden Daten aus den Extensions, Nummer 500, klappt, hier höre ich eine Stimme am anderen Ende.

    exten => 500,1,Playback(demo-abouttotry); test
    exten => 500,2,Dial(IAX2/guest@misery.digium.com/s@default);
    exten => 500,3,Playback(demo-nogo) ;
    exten => 500,4,Goto(s,6)

    Wo liegt nun der Fehler, in den SIP Einstellungen, bei den Extensions ?

    Cu
    Chris
     
  9. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mittlerweile kann ich sogar mit SIP raustelefonieren, allerdings tritt nun ein Fehler hier mit dem NAT auf, die Gegenstelle kann mich prima hören, nur ich die Gegenstelle nicht. Sipgate hat hier mit meinem Fli4l z.B. per X-Lite unter Windows funktioniert (ohne irgendwelche Ports weiterleiten zu müssen). Weiß jemand evtl. abhilfe? Kann man evtl. den Stun Server irgendwo eintragen?

    Cu
    Chris
     
  10. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    Asterisk hat keinen Support für STUN Server + Outbound SIP Proxy.
    Stelle mal bei dem XLite (das an Asterisk hängt) ein :
    nat=yes
    qualify=yes
     
  11. nc2001

    nc2001 Neuer User

    Registriert seit:
    29 Juli 2004
    Beiträge:
    134
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir hängt kein XLite dran, sondern nur ein ISDN Telefon über diese HFC Karte. Mittlerweile habe ich es zu 95% am laufen, um einen Portforward bin ich im Augenblick nicht hinweggekommen. Wenn ich fertig bin werde ich mal meine confs hier posten, dann haben andere evtl. auch noch was davon.

    Cu
    Chris
     
  12. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    Dann ist es das Problem, dass Du nicht externip in sip.conf eingestellt hast.