[Frage] fritz 7390 int version mit freetz-1.2 stable

dolphs

Neuer User
Mitglied seit
26 Sep 2008
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Hallo, wann es freetz1.2 final gibt will ich mich freetz im 7390 flashen (immer nicht).
Damit habe ich mehrere Fragen:

Ich moechte gern AVM vpn (IPSec) ersetzen mit openVPN, den 7390 ausstatten mit einem "lite" SSH server (dropbear) , ext3 (ext2) installieren fuer mount to USB harddisk ( ohne NTFS mounts ). Auch keine Notwendigkeit fuer (USB) Drucker oder zusaetzliche USB devices. Falls moeglich flash memory verwenden fuer configs/data.

Sind folgenden Optionen richtig gesetzt, oder sollte ich andere Aspekten beobachten bitte:

--- General ---
Hardware type: Fon WLAN 7390
Firmware language: en- international
[*] Show advanced options
[X] Enable IPv6 support
-- Mod ---
Freetz language (en- english)
Patches --->

...
[*] FREETZMOUNT:
[X] Automount filesystems
[*] ext3
...
[*] Remove AVM vpn
[*] Remove dtrace
...
[*] Remove NTFS support
[*] Remove printserv
[*] Remove usblp kernel module
...
[*] Replace dtrace


Package selection --->

[*] Packages supporting selected language only

Standard packages --->
...
[X] bridge-utils 1.4
...
[*] Dropbear 0.53.1
[*] Without scp & ssh client
[*] Disable DNS reverse-lookup of the client
[ ] Build static binary
...
[X] haserl 0.9.29
[X] Inted
...
[*] OpenVPN 2.2.1
[ ] Statically link libraries
[*] With lzo Compression
[*] Enable Management Console
[*] Optimize for size
...

Web interfaces --->
[X] Frontend for managing SSH authorized_keys
[*] AVM-firewall 2.0.4_rc5
...
[*] Syslogd CGI 0.2.3


( rest default )


Package selection --->
( leave default )


Nach kompilieren will ich mich openvpn als Server einsetzen und gibt es dafuer irgendwo ein detaillierten hinweis bitte?
 

dolphs

Neuer User
Mitglied seit
26 Sep 2008
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Habe gerade erste compilierung gemacht ( mit version 8640 ) und es gibt leider " ERROR: modpatch: Error in patch-file ./patches/7390/110-rc.S-mknod.patch ":

Making install in tests
---> library/libfreetz: downloading... preparing... building... done.
---> library/lzo: downloading... preparing... configuring... building... done.
---> library/openssl: downloading... preparing... configuring... building... done.
---> library/zlib: downloading... preparing... configuring... building... done.
---> package/busybox: preparing... building... done.
---> kernel: kernel image... building... modules... done.
---> package/bridge-utils: downloading... preparing... configuring... building... done.
---> package/dropbear: downloading... preparing... configuring... building... done.
---> package/haserl: downloading... preparing... configuring... building... done.
---> package/modcgi: downloading... preparing... building... done.
---> package/openvpn: downloading... preparing... configuring... building... done.
---> package/sg3_utils: downloading... preparing... configuring... building... done.
STEP 1: UNPACK
unpacking firmware image
splitting kernel image
unpacking filesystem image
Reading a different endian SQUASHFS filesystem on build/original/kernel/kernelsquashfs.raw
unpacking var.tar
done.

STEP 2: MODIFY
applying symlinks, deleting additional webinterfaces in: usr/www usr/www.nas
applying patches
ERROR: modpatch: Error in patch-file ./patches/7390/110-rc.S-mknod.patch
make: *** [firmware-nocompile] Error 2


Es scheint dass nur FRITZ.Box_Fon_WLAN_7390.en-de-es-it-fr.84.04.88.image unterstuetzt ist im Moment? Habe dafuer FRITZ.Box_Fon_WLAN_7390.en-de-es-it-fr.84.05.06.image umbenannt nach " 84.04.88 "
 
Zuletzt bearbeitet: