[Problem] FYI: Asterisk in Debian Bullseye: MP3Player/Playback funktioniert z. Zt. nicht

sunnyman

Mitglied
Mitglied seit
13 Jan 2006
Beiträge
592
Punkte für Reaktionen
57
Punkte
28
Ich habe bei einer Maschine, die mit Debian und dem Asterisk aus dem Debian-Repo läuft, ein Upgrade auf bullseye gemacht.
Fehlerbild: Bei MP3Player-Aufrufen oder Playback von MP3-Dateien gibt es nur extrem starkes Rauschen zu hören.
Nachdem ich heute stundenlang den Fehler bei mir gesucht habe, habe ich die Lösung gefunden:
Aktuelle Versionen von mpg123 haben die Default-Ausgabe von 16 auf 32 Bit verändert.
In Debian bullseye ist eine entsprechend junge mpg123-Version enthalten.
Asterisk erwartet aber 16 Bit, sodass alles was über mpg123 reingeholt wird aktuell nicht klappt.
Auf Asterisk-Seite ist das Problem bekannt und mit 16.21 gelöst worden:
In bullseye ist allerdings Asterisk 16.16 der aktuelle Stand, und offenbar ist da (noch nicht) gepatcht worden.
 
  • Like
Reaktionen: sonyKatze

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,542
Punkte für Reaktionen
328
Punkte
83
Nur der Vollständigkeit wegen: Der Fehler ist inzwischen auch in Debian gemeldet … bin gespannt, was deren VoIP-Team daraus macht.
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via