.titleBar { margin-bottom: 5px!important; }

[GELÖST] Fehlermeld.: Please don't use private IP addresses

Dieses Thema im Forum "blueSIP-Störungsstelle" wurde erstellt von der_Gersthofer, 2 Nov. 2004.

  1. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hallo,

    ich erhalte - ähnlich wie bei GMX - eine Fehlermeldung "Please don't use private IP addresses" wenn ich mich mit meinem SNOM 190 bei Bluesip anmelden möchte.

    Das merkwürdige daran ist, dass ich - das SNOM hat 7 Leitungen und kann daher mit mehreren VoIP-Providern parallel gefüttert werden - gleichzeitig keinerlei Probleme habe, mich bei Sipgate, Sipsnip, Web.de und Nikotel anzumelden, sondern eben nur bei den Providern Bluesip und GMX das Problem auftritt.

    Das LOG zeigt an: [2]4/11/2004 10:10:14: Registrar bluesip/ID@bluesip.net refused with code 479


    Die Fehlermeldung besagt, dass die Register Meldung von Ihrem Client eine private IP im Contact enthaelt (Bsp. 192.168.x.x). An diese IP koennen von aussen keine Gespraeche signalisiert werden, daher laesst der Bluesip-Server eine Registrierung gar nicht erst zu.

    Warum das aber dann bei den anderen Providern geht?
     
  2. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
  3. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Nur für das Record:

    Das Problem (sowohl mit blueSIP.net als auch mit GMX und damit wohl auch mit 1&1) betrifft natürlich nicht nur das SNOM sondern damit jedes VoIP-Hardwaregerät oder VoIP-Software. Mit SIPPS kann ich z. B. auch nicht über diese Provider telefonieren wenn die Firmware 3.01.3 installiert ist.

    Das Problem tritt auch bei Verwendung des Linksys Routers BEFW11S4 Version 2 mit Firmware 1.45.10 und auch mit einem Telekom T-Sinus 154DSL Router mit uPnP auf "aus" auf. Nachdem bei letzterem Router uPnP auf "an" gestellt wurde, war das Problem wohl (?) behoben - konnte ich nicht selbst testen, daher letzteres nur vom Hörensagen.


    Kann das jemand bestätigen?
    Wie sieht es mit dem Linksys WRT54GS aus?
     
  4. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Da es vielleicht auch für andere User von Interesse ist - hier die Antowrt des blueSIP-Supports:

    Sehr geehrter Herr...,

    es gibt Tools auf Providerseite, mit denen fehlerhafte SIP REGISTER Messages mit privaten IPs im contact umgeschrieben werden.
    Das Problem ist, dass normalerweise der RTP Stream direkt zwischen den clients ausgehandelt wird. Da der Client hier auch die private IP als Ziel aushandeln wuerde waere der Client zwar bei blueSIP registriert, koennte aber keinen direkten RTP Stream zu anderen Clients aufbauen.
    Loesbar ist dieses Dilemma mit einem RTP Proxy, den wir auch anbieten, allerdings nur fuer Vertragskunden. Das hat zum einen rechtliche aber auch Skalierungs- und Kostengruende (schliesslich muessen wir ausreichend Bandbreite fuer RTP Streams welche dann ueber unseren Proxy laufen vorhalten).

    NAT ist leider der groesste Stolperstein fuer VoIP. Das Verbiegen von falschen register Messages ist aber nach unserer Sicht keine gute Loesung.
    Uns ist klar, dass andere Anbieter diese 'Korrekturmachanismen' und freie RTP Proxies anbieten. Inwieweit sich hier mit steigender Nutzerzahl eine Qualitaet aufrechterhalten laesst darf zumindest bezweifelt werden. Unsere Zielgruppe sind Geschaeftskunden, fuer die Telefonie in herkoemmlicher Qualitaet unabdingbar ist.

    Wir meinen der bessere Ansatz ist geeignete Router einzusetzen, die 'SIP aware' sind. Nur solche Router garantieren auch eine saubere Sprachqualitaet, wenn ueber die Leitung noch andere Daten transportiert werden (QoS fuer SIP).

    Mit freundlichen Gruessen
     
  5. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    wenn ich bei blueSIP schon Vertragskunde wäre, dann würde mich auch der RTP-Proxy nicht besonders interessieren, weil ich dann bei blueSIP auch das IAX-Protokoll nutzen könnte - das auch nur für Vertragskunden verfügbar ist :D
     
  6. haeberlein

    haeberlein Aktives Mitglied

    Registriert seit:
    10 März 2004
    Beiträge:
    1,712
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Bei mir geht das SNOM mit Bluesip irgendwie nicht. Es erscheint zwar beim Status o.k. aber man hört weder die Gegenseite noch sich selbtst. Alles anderen Provider einschließlich GMX und Purtel funktionieren mit dem SNOM 190 und Firmware 3.56l
     
  7. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ich denke, dass alles klappen würde, wenn du einen anderen Router nehmen würdest. Du hast sicherlich uPnP am Router aktiviert - damit kann man aber nicht feststellen, ob er wirklich "sip aware" ist. Ich würde ja fast wetten, dass es mit einem IX67 reibungslos klappen würde. Kannst du dir nicht mal einen solchen irgendwoher ausleihen (z. B. aus dem nächsten MediaMarkt)?

    blueSIP ist sehr restriktiv was die Einhaltung von Spezifikationen angeht
    http://www.ip-phone-forum.de/forum/viewtopic.php?t=7940
    (und das ist m. E. auch gut so)
     
  8. haeberlein

    haeberlein Aktives Mitglied

    Registriert seit:
    10 März 2004
    Beiträge:
    1,712
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hallo!

    Lag an der veralteten Firmware des D-Link Routers meines Schwiegervaters. Nun geht auch Bluesip wunderbar ,an einen SNOM 190 Telefon am D-Link 604 hinter einer AVM Fritz Box Fone.