.titleBar { margin-bottom: 5px!important; }

[gelöst] AVM C4 und CAPI, fcpci modul nicht gefunden

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von ceicke, 5 Aug. 2005.

  1. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    Hallo!

    Mir schwirrt der Kopf weil ich irgendwie das ganze CAPI ISDN nicht verstehe. Ich habe hier eine AVM C4 Karte welche ich gerne mit Asterisk zum Laufen bekommen möchte. Die ganze Geschichte läuft auf einem Debian System welches relativ aktuell ist, Kernel ist 2.6.8.
    Ich habe der Anweisung von http://www.voip-info.org/tiki-index.php?page=Asterisk+How+to+connect+with+CAPI befolgt, und ganz brav chan_capi-0.3.5 installiert.
    Meine /etc/capi.conf sieht so aus:
    Code:
    #card     file   proto io    irq mem  cardnr options
    b1isa     b1.t4  DSS1  0x150 7   -    -      P2P
    b1pci     b1.t4  DSS1  -     -   -    -
    c4        c4.bin DSS1  -     -   -    -
    c4        -      DSS1  -     -   -    -
    c4        -      DSS1  -     -   -    -      P2P
    c4        -      DSS1  -     -   -    -      P2P
    t1isa     t1.t4  DSS1  0x340 9   -    0
    t1pci     t1.t4  DSS1  -     -   -    -
    fcpci     -      -     -     -   -    -
    fcclassic -      -     0x300 5   -    -
    
    Brauch ich diese ganzen Einträge oder reichen die C4 Dinger aus?

    Die Datei c4.bin liegt bei mir unter /usr/local/bin.
    Wenn ich nun zu dem Schritt komme wo ich capiinit ausführen soll, kommt folgende Fehlermeldung:

    Code:
    FATAL: Module fcpci not found.
    ERROR: failed to load driver fcpci
    ERROR: controller 1: firmware file "c4.bin" not found
    ERROR: controller 2: firmware file "-" not found
    ERROR: controller 3: firmware file "-" not found
    ERROR: controller 4: firmware file "-" not found
    ERROR: failed to load firmware for controller 1 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 2 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 3 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 4 driver c4 name c4-e000
    
    Ich denke mal das liegt daran das ich das fcpci Modul nicht habe. Wo bekomme ich das denn her? Im Kernel kann ich dazu nichts finden und habe auch schon unerfolgreich versucht mir das irgendwo runterzuladen.
    Wie gesagt, mir schwirrt der Kopf schon so früh am Morgen...

    Gruß,
    Christoph
     
  2. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    Oha, noch mal Kaffee geholt und beim trinken gemütlich Google benutzt und erfolgreich das Modul fcpci installiert und geladen.
    Für alle die dieses Problem vielleicht auch irgendwann mal haben sollten, hier die Lösung: das Modul gibts auf der AVM Seite. Einfach auf Download->Fritz!Card->Fritz!CardPCI->Linux->Download starten und dann einfach das fcpci-suseXX.tar.gz runterladen, entpacken und mit "make && make install" installieren. Anschließend in den Kernel lagen (modprobe fcpci) und gut ist.
    Allerdings kommt nun wenn ich capiinit eingebe die Fehlermeldung:

    Code:
    ERROR: controller 1: firmware file "c4.bin" not found
    ERROR: controller 2: firmware file "-" not found
    ERROR: controller 3: firmware file "-" not found
    ERROR: controller 4: firmware file "-" not found
    ERROR: failed to load firmware for controller 1 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 2 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 3 driver c4 name c4-e000
    ERROR: failed to load firmware for controller 4 driver c4 name c4-e000
    
     
  3. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    he he, kaffee hilft wunder und das hier entwickelt sich gerade zu einem schönen Selbstgespräch mit anschließender Lösung... einfach in der /etc/isdn/capi.conf den Pfad für die c4.bin angeben, oder die c4.bin einfach in das Verziechniss /etc/isdn/capi.conf kopieren...
     
  4. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bevor hier kein andere mehr was schreibt, mache ich das doch mal :) :

    Ich will Dich ja nicht von Deinem Kaffee-Tripp runter holen, aber dieses Problem ist hier im Forum nicht neu (und die Lösung auch nicht ...) ;)

    Schade, weiter viel Kaffee trinken, damit es weiter so gut läuft (never touch a running system !)