.titleBar { margin-bottom: 5px!important; }

[gelöst] bristuff-0.2.0-RC7k Segmentation fault

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von kombjuder, 11 März 2005.

  1. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hallo,

    Ich habe den Asterisk aktuell compiliert anhand der Anweisung von Jui. Zapata/zaptel.conf sind anhand der Anleitung von Ch. Blog erstellt. Ein make loadNT bringt:

    make -C /usr/src/linux-2.6 SUBDIRS=/usr/src/asterisk/bristuff-0.2.0-RC7k/zaphfc
    ZAP=-I/usr/src/asterisk/bristuff-0.2.0-RC7k/zaptel-1.0.6 modules
    make[1]: Entering directory `/usr/src/linux-2.6.8-24.11'

    WARNING: Symbol version dump /usr/src/linux-2.6.8-24.11/Module.symvers is missi
    ng, modules will have CONFIG_MODVERSIONS disabled.

    Building modules, stage 2.
    MODPOST
    make[1]: Leaving directory `/usr/src/linux-2.6.8-24.11'
    modprobe zaptel
    insmod ./zaphfc.ko modes=1
    make: *** [loadlinux26NT] Segmentation fault


    Im Rechner befindet sich eine AVM mit Capi und eine HFC-Karte. Der Asterisk läuft mit noload chan_zap.so.

    Wo fang ich an zu suchen?
     
  2. WrMulf

    WrMulf Mitglied

    Registriert seit:
    2 Okt. 2004
    Beiträge:
    553
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Stuttgart
    Re: bristuff-0.2.0-RC7k Segmentation fault

    Ich habe exakt dieselben Symptome und dieselbe Konstellation und Konfiguration. Die HFC-Karte war ein Fehlkauf, sie hat noch nie mit Asterisk zusammen funktioniert (im Moment fehlt mir auch ein ISDN-Telefon, um sie zu benutzen) und bristuff wird zunehmend instabiler.
     
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Re: bristuff-0.2.0-RC7k Segmentation fault

    Obiges scheint eine Suse-Problem zu sein.
    Werden die entsprechenden Sourcen (Google sagt was dazu) eingebunden, bricht die Kompilierung mit einem Error 2 ab.
     
  4. nitana

    nitana Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    203
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    habe genau die selben prob mit einer 9.2er suse, schöne bescherung....,

    nitana
     
  5. Schetti

    Schetti Neuer User

    Registriert seit:
    8 März 2005
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ich poste verzweifelt durch die Gegend um eine Lösung für mein Problem zu finden. Ich habe genau die gleichen Fehlermeldungen wie Kombjuder. Gibt es inzwischen eine Lösung? Ich bunutze Suse 9.2 mit aktuellstem Kernel und den Bristuff *RC7k. Ich glaube es liegt an Suse 9.2!
     
  6. WrMulf

    WrMulf Mitglied

    Registriert seit:
    2 Okt. 2004
    Beiträge:
    553
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Stuttgart
    Bei mir war der segmentation fault nach einem Reboot weg. Ich vermute es hing damit zusammen, dass zuvor eine andere Version des zaphfc geladen war. Im Moment verwende ich mein Asterisk aber immer im "noload => zaphfc.so"-Modus...
     
  7. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    Bei mir geht es (RH9).

    Allerdings rebootet jetzt öfters mein Linux - Server, da bei dmesg das Modul zaphfc einen Kernel Trap verursacht.

    Liegt an RC7k, vorher ging alles (very old bristuff).
    RC7k setzt aber auf Asterisk 1.0.6 auf, damit geht endlich FWD und GMX, also damit geht kein Downgrade auf RC7j (RC7f hat eh einen Audio-Hau!).

    Crasht bei Euch mit RC7k auch öfters mal das Linux?
     
  8. ecco

    ecco Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    174
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir läuft es ziemlich stabil:
    Seit der Installation keine Linux- oder Asterisk-Crashs :mrgreen:
    Die recht kurze Uptime liegt an meinem Experimenten mit Wake-On-LAN ;)
     
  9. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Nachdem ich den Rechner aus- und wieder eingeschaltet hatte ging es bei mir auch.

    Reboot hat nicht ausgereicht!

    Anscheinend werden irgendwo Register gesetzt, die durch einen reboot nicht zurückgesetzt werden.
     
  10. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    Hi,

    um festzustellen an welcher Stelle im Treiber-Code der segf
    aufgetreten ist, kann man einfach ein

    $ dmesg|ksymoops

    ausführen. Die Pfeile Zeigen auf den Maschinen/Assembler
    Code an der die exception aufgetreten ist.

    Aber es scheint mir so, als ob es an modes=1 liegt, versuch mal
    modes=2 o. ä. Ich kann mich an die semantik nicht mehr
    erinnern.

    Gruß
    britzelfix