.titleBar { margin-bottom: 5px!important; }

[gelöst] Das Problem mit den Nullen

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von kombjuder, 17 Dez. 2005.

  1. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Hallo,

    ich bekomme im master.csv die richtige Rufnummer vom Zap-Decice angezeigt, bekomme aber auf dem Telefon eine Null zuviel präsentiert.

    In der zapata.conf sind nur für die an der Telefonleitung hängende Karte

    internationalprefix = 00
    nationalprefix = 0
    definiert.

    In der extensions.conf wird direkt in den Zielcontextgesprungen und direkt das Ziel angewählt.

    Was läuft da falsch?
     
  2. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Was steht in der zapata.conf als dialplan / localdialplan? Default ist glaube ich 'national', damit wird die übergebene Rufnummer als nationale Rufnummer einschliesslich Ortsvorwahl aber ohne die führende Null deklariert. Der Empfänger hängt dann blind eine Null davor.

    Genaueres offenbart mein Lieblingsspielzeug im Asterisk, der D-Kanal-Tracer.
     
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Gibt es irgendwo eine Erklärung zu localpridialplan?
    Ich habe bisher nur die möglichen Werte gefunden, wobei alle Werte das selbe Ergebnis bringen, eine Null zuviel.
    Das passiert übrigens nur auf den internen zap-Kanälen. Ein Voip-Telefon wie auch das Log zeigen die korrekte Rufnummer an.
     
  4. clan

    clan Mitglied

    Registriert seit:
    21 Apr. 2005
    Beiträge:
    266
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Option heisst 'prilocaldialplan'. Eine Erklärung gibt es bei den Asterisk-Quellen, in der Beispiel-zapata.conf. 'prilocaldialplan' bestimmt die Einstellungen für die calling party number. 'unknown' oder 'private' sollten richtig sein. Falls es damit nicht läuft solltest du dir wirklich mal den Verbindungsaufbau ansehen, schon um Fehler am Endgerät auszuschliessen.
     
  5. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Ich hatte mich auf die deutschen Beispiele im card_installation_guide_de.pdf
    von Beronet verlassen. Da steht loacalpridialplan. Asterisk hat das nicht angemault.

    Mit dem richtigen Wort habe ich auch eine entsprechende Erklärung gefunden.
    Wobei auch füe das andere weissgottwieviel Einträge bei google sind.

    Es scheint mit unknown zu laufen.

    Das Endgerät kann es nicht sein, da 4 Geräte unterschiedlicher Hersteller an zwei verschiedenen S0-Bussen hängen und alle den selben Mist anzeigen.