.titleBar { margin-bottom: 5px!important; }

[gelöst: eigenes Versagen] bluesip verweigert Registrierung

Dieses Thema im Forum "blueSIP-Störungsstelle" wurde erstellt von WrMulf, 12 Apr. 2005.

  1. WrMulf

    WrMulf Mitglied

    Registriert seit:
    2 Okt. 2004
    Beiträge:
    553
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Stuttgart
    Seit Montag abend [11.04.05] erhalte ich von Asterisk im Minutentakt:

    Apr 12 10:16:57 NOTICE[10822]: chan_sip.c:4067 sip_reg_timeout: -- Registration for 'bluesip/wrmulf@bluesip.net' timed out, trying again
    -- parse_srv: SRV mapped to host bluesip.net, port 5060
    -- Got SIP response 479 "Please use a valid IP address" back from 217.74.179.29

    Wieso ist meine IP-Adresse plötzlich invalid? Hat sonst noch jemand dieses Problem? Asterisk befindet sich hinter NAT, Portweiterleitung auf Asterisk ist aktiv, ebenso die Option "externhost". An der Konfiguration wurde nichts verändert, sie lief bis gestern auch über Wochen stabil.
     
  2. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,278
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    Hast Du den bluesip support mal gefragt?

    jo
     
  3. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Das ist das bekannte: "Please don´t use private IP addresses". Verwende die Suche, dann findest du mehr dazu.

    [2]XX/2/2005 18:04:14: Registrar bluesip/ID@bluesip.net refused with code 479

    Du verwendest bzw. erzeugst fehlerhafte sip register Messages und blueSIP lässt eine Anmeldung an ihren Servern (zum Glück, da deshalb ihr Dienst so stabil läuft!) nicht zu. Sie sind seit gestern wohl auch noch strenger bzw. genauer, was das Zurückweisen fehlerhafter sip register messages betrifft, da es ansonsten zu Beeinträchtigungen/Störungen im Dienst kommt bzw. gekommen ist. Und da es blueSIP vor allen Dingen um Stabilität geht, weisen Sie alle Anmeldeversuche, die nicht dem Standard entsprechen bzw. fehlerhaft sind, nun noch konsequenter ab. Ich weiß, das wird dich nicht freuen, aber alle anderen Kunden, denen absolute Stabilität bei VoIP am Wichtigsten ist, schon.

    Es bleibt dir nur, an deiner Hardware/Software zu basteln, bis du den Fehler behoben hast.

     
  4. WrMulf

    WrMulf Mitglied

    Registriert seit:
    2 Okt. 2004
    Beiträge:
    553
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Stuttgart
    Danke für die Aufklärung. Ich dachte, das Thema "Don't use private IP adresses" wäre vom Tisch, seit ich "externhost" in asterisk verwende und bis gestern war es das auch. Wie du schreibst hat bluesip etwas geändert, die Gründe dafür kann ich nachvollziehen und die Antwort ist für mich auch zufriedenstellend. Offensichtlich ist bluesip.net damit aber nicht mehr Asterisk+NAT-kompatibel, oder gibt es dafür doch eine Lösung?
     
  5. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,278
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    Bei mir läuft es unverändert seit Monaten mit Asterisk hinter NAT.

    Mach doch mal ein "sip debug peer bluesip" und guck Dir an, was da so hin und her geht.

    jo
     
  6. WrMulf

    WrMulf Mitglied

    Registriert seit:
    2 Okt. 2004
    Beiträge:
    553
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Stuttgart
    Asche auf mein Haupt! Ich hatte noch von früher (testweise) ein

    127.0.0.1 wrmulf.homelinux.net localhost

    in meiner /etc/hosts drin stehen, daher stand im header immer wrmulf@127.0.0.1 drin.

    Das Problem saß wie immer vor dem Bildschirm.
     
  7. Netzmeister01

    Netzmeister01 Neuer User

    Registriert seit:
    9 Okt. 2008
    Beiträge:
    33
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT TK
    Ort:
    Köln
    so das ist schon was alt aber dennoch: in meiner hosts steht wie folgt:

    127.0.0.1 localhost
    192.0.2.2 Voice-Board
    ~
    ~
    ~
    Hardware ist die Horstbox

    Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g, Copyright (C) 1999 - 2006 Digium, Inc. and others.
    Created by Mark Spencer <markster@digium.com>
    Asterisk comes with ABSOLUTELY NO WARRANTY; type 'show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'show license' for details.
    =========================================================================
    Connected to Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g currently running on Voice-Board (pid = 2677)


    der Fehler der im LOG steht:
    Connected to Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g currently running on Voice-Board (pid = 929)
    Oct 13 23:56:09 NOTICE[952]: chan_sip.c:6845 sip_reg_timeout: -- Registration for 'psg@bluesip.net' timed out, trying again (Attempt #102)


    was kann ich machen
     
  8. Timmbo

    Timmbo Aktives Mitglied

    Registriert seit:
    6 Nov. 2005
    Beiträge:
    1,935
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Austria
    Hi psg,

    Bluesip benützt die Account ID bluesip/name in Deinem Fall wäre das bluesip/psg, dann sollte es gehen.
    Hatte eben mit einem Kunden das Problem.

    Grüße
    Timm
     
  9. Netzmeister01

    Netzmeister01 Neuer User

    Registriert seit:
    9 Okt. 2008
    Beiträge:
    33
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT TK
    Ort:
    Köln
  10. Rodi20

    Rodi20 Neuer User

    Registriert seit:
    24 Feb. 2014
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    schwierige klingende frage, simple antwort.
    hatte gerade das selbe problem (neukunde bei bluesip)
    trag den stun ein (stun.bluesip.net) und schon is die fehlermeldung weg :)
    wenn dann auch noch die übrigen daten stimmen kommst du rein
    (ansonsten kommt ne andere fehlermeldung :)