[gelöst: eigenes Versagen] bluesip verweigert Registrierung

WrMulf

Mitglied
Mitglied seit
2 Okt 2004
Beiträge
553
Punkte für Reaktionen
0
Punkte
0
Seit Montag abend [11.04.05] erhalte ich von Asterisk im Minutentakt:

Apr 12 10:16:57 NOTICE[10822]: chan_sip.c:4067 sip_reg_timeout: -- Registration for 'bluesip/[email protected]' timed out, trying again
-- parse_srv: SRV mapped to host bluesip.net, port 5060
-- Got SIP response 479 "Please use a valid IP address" back from 217.74.179.29

Wieso ist meine IP-Adresse plötzlich invalid? Hat sonst noch jemand dieses Problem? Asterisk befindet sich hinter NAT, Portweiterleitung auf Asterisk ist aktiv, ebenso die Option "externhost". An der Konfiguration wurde nichts verändert, sie lief bis gestern auch über Wochen stabil.
 

rollo

IPPF-Promi
Mitglied seit
5 Jul 2004
Beiträge
8,288
Punkte für Reaktionen
1
Punkte
38
Hast Du den bluesip support mal gefragt?

jo
 

der_Gersthofer

Admin-Team
Mitglied seit
17 Apr 2004
Beiträge
3,585
Punkte für Reaktionen
0
Punkte
36
Das ist das bekannte: "Please don´t use private IP addresses". Verwende die Suche, dann findest du mehr dazu.

[2]XX/2/2005 18:04:14: Registrar bluesip/[email protected] refused with code 479

Du verwendest bzw. erzeugst fehlerhafte sip register Messages und blueSIP lässt eine Anmeldung an ihren Servern (zum Glück, da deshalb ihr Dienst so stabil läuft!) nicht zu. Sie sind seit gestern wohl auch noch strenger bzw. genauer, was das Zurückweisen fehlerhafter sip register messages betrifft, da es ansonsten zu Beeinträchtigungen/Störungen im Dienst kommt bzw. gekommen ist. Und da es blueSIP vor allen Dingen um Stabilität geht, weisen Sie alle Anmeldeversuche, die nicht dem Standard entsprechen bzw. fehlerhaft sind, nun noch konsequenter ab. Ich weiß, das wird dich nicht freuen, aber alle anderen Kunden, denen absolute Stabilität bei VoIP am Wichtigsten ist, schon.

Es bleibt dir nur, an deiner Hardware/Software zu basteln, bis du den Fehler behoben hast.

Wie es scheint ist das von Ihnen beobachtete Fehlverhalten ein Folgefehler von Vermittlungsversuchen zu ungueltigen SIP contacts.

Auch Sie waren z.B. am 5. April mit einem falschen contact registriert (IP=0.0.0.0). Nachstehend finden Sie die (erfolglosen) Vermittlungsversuche sowie die entpsrechenden expire Meldungen:

ggf. liegt hier ein allgemein verbreiteter SW Bug im SIP Client/Router vor, da wir solche falschen contact Adressen auch bei anderen Kunden tracen konnten.
Am 9.4. fanden ebenfalls Vermittlungsversuche zu einer 0.0.0.0er Adresse statt (zwar nicht von Ihnen aber wie es scheint kommt es hier zu Wechselwirkungen).

Register Meldungen werden nun noch umfassender geprueft und ungueltige IPs im contact abgwiesen.
Wir hoffen somit das Problem nachhaltig beseitigt zu haben.
 

WrMulf

Mitglied
Mitglied seit
2 Okt 2004
Beiträge
553
Punkte für Reaktionen
0
Punkte
0
Das ist das bekannte: "Please don´t use private IP addresses". Verwende die Suche, dann findest du mehr dazu.

[2]XX/2/2005 18:04:14: Registrar bluesip/[email protected] refused with code 479

Du verwendest bzw. erzeugst fehlerhafte sip register Messages und blueSIP lässt eine Anmeldung an ihren Servern (zum Glück, da deshalb ihr Dienst so stabil läuft!) nicht zu. Sie sind seit gestern wohl auch noch strenger bzw. genauer, was das Zurückweisen fehlerhafter sip register messages betrifft, da es ansonsten zu Beeinträchtigungen/Störungen im Dienst kommt bzw. gekommen ist. Und da es blueSIP vor allen Dingen um Stabilität geht, weisen Sie alle Anmeldeversuche, die nicht dem Standard entsprechen bzw. fehlerhaft sind, nun noch konsequenter ab. Ich weiß, das wird dich nicht freuen, aber alle anderen Kunden, denen absolute Stabilität bei VoIP am Wichtigsten ist, schon.

Es bleibt dir nur, an deiner Hardware/Software zu basteln, bis du den Fehler behoben hast.
Danke für die Aufklärung. Ich dachte, das Thema "Don't use private IP adresses" wäre vom Tisch, seit ich "externhost" in asterisk verwende und bis gestern war es das auch. Wie du schreibst hat bluesip etwas geändert, die Gründe dafür kann ich nachvollziehen und die Antwort ist für mich auch zufriedenstellend. Offensichtlich ist bluesip.net damit aber nicht mehr Asterisk+NAT-kompatibel, oder gibt es dafür doch eine Lösung?
 

rollo

IPPF-Promi
Mitglied seit
5 Jul 2004
Beiträge
8,288
Punkte für Reaktionen
1
Punkte
38
Bei mir läuft es unverändert seit Monaten mit Asterisk hinter NAT.

Mach doch mal ein "sip debug peer bluesip" und guck Dir an, was da so hin und her geht.

jo
 

WrMulf

Mitglied
Mitglied seit
2 Okt 2004
Beiträge
553
Punkte für Reaktionen
0
Punkte
0
Asche auf mein Haupt! Ich hatte noch von früher (testweise) ein

127.0.0.1 wrmulf.homelinux.net localhost

in meiner /etc/hosts drin stehen, daher stand im header immer [email protected] drin.

Das Problem saß wie immer vor dem Bildschirm.
 

Netzmeister01

Neuer User
Mitglied seit
9 Okt 2008
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
so das ist schon was alt aber dennoch: in meiner hosts steht wie folgt:

127.0.0.1 localhost
192.0.2.2 Voice-Board
~
~
~
Hardware ist die Horstbox

Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g, Copyright (C) 1999 - 2006 Digium, Inc. and others.
Created by Mark Spencer <[email protected]>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'show license' for details.
=========================================================================
Connected to Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g currently running on Voice-Board (pid = 2677)


der Fehler der im LOG steht:
Connected to Asterisk 1.2.18-BRIstuffed-0.3.0-PRE-1y-g currently running on Voice-Board (pid = 929)
Oct 13 23:56:09 NOTICE[952]: chan_sip.c:6845 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #102)


was kann ich machen
 

Timmbo

Aktives Mitglied
Mitglied seit
6 Nov 2005
Beiträge
1,935
Punkte für Reaktionen
0
Punkte
0
Hi psg,

Bluesip benützt die Account ID bluesip/name in Deinem Fall wäre das bluesip/psg, dann sollte es gehen.
Hatte eben mit einem Kunden das Problem.

Grüße
Timm
 

Netzmeister01

Neuer User
Mitglied seit
9 Okt 2008
Beiträge
33
Punkte für Reaktionen
0
Punkte
0

Rodi20

Neuer User
Mitglied seit
24 Feb 2014
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
schwierige klingende frage, simple antwort.
hatte gerade das selbe problem (neukunde bei bluesip)
trag den stun ein (stun.bluesip.net) und schon is die fehlermeldung weg :)
wenn dann auch noch die übrigen daten stimmen kommst du rein
(ansonsten kommt ne andere fehlermeldung :)
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,039
Beiträge
2,018,138
Mitglieder
349,322
Neuestes Mitglied
fensterrahmen